Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/103: Рейтинг темы: голосов - 103, средняя оценка - 4.83
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
1

Выборка документов

19.03.2007, 13:44. Просмотров 18488. Ответов 10
Метки нет (Все метки)

Здравствуйте у меня такой вопрос, как мне сделать выборку документов по определенному контрагенту,т.е. другими словами, мы выбираем определенного контрагента, затем мы выбираем документ, и нужно чтобы при выборе документа отображались только те, которые в реквизите имеют точно такого же контрагента,другие из этого же журнала выводить не надо.Мой код имеет следующий вид, и он выводит все документы...

Док=СоздатьОбъект("Документ.ПередачаИмВЗалог");
Док.ВыбратьДокументы(); //***Делаем выборку документов
Пока Док.ПолучитьДокумент()=1 Цикл
///***Выбираем только документы,у которых контрагент такой же как и в "Кредитном договоре"
Если Док.Контрагент=Контрагент Тогда
Если Док.Выбран()=1 Тогда
Док.ВыбратьСтроки(); //***Делаем выборку табличной части документа
Пока Док.ПолучитьСтроку()=1 Цикл
//***Заносим значения в определенные поля
Сумма=Док.Сумма;
ДатаДог=ДатаДок;
СуммаКредита=Сумма;
КонецЦикла
КонецЕсли;
Иначе
Сообщить("Нет подходящих документов для данного контрагента!");
КонецЕсли;
КонецЦикла;

За ранее спасибо...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.03.2007, 13:44
Ответы с готовыми решениями:

Выборка документов, затем расположение реквизитов в разных строках таблицы
Привет всем. У меня стоит задача выбрать все документы, которые указаны в...

Есть выборка документов. Перебрать в ней значения по каждому реквизиту
Доброго времени суток всем. У меня стоит такая задача. Есть выборка...

Журнал документов + ТЗ
Всем Хай. В академических целях интересует: Возможно ли в Фоме Журнала...

Перепроведение документов
Здраствуйте. Мне, в УСН, потребовалось дописать модуль документов, а именно...

Проведение документов
Есть ли какая-нибудь общая процедура, которая вызывается при проведении любого...

10
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
19.03.2007, 13:54 2
Лучше всего будет сделать запросом.
0
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
19.03.2007, 14:54 3
А каким образом после запроса, привязать полученные данные к таблице на форме,точнее к ее определенному полю (в данном случае поле называется "Документ залога", который мы будем выбирать)?
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
19.03.2007, 15:03 4
Интересный вопрос...
Опять же настоятельно рекомендую все же почитать книги по программированию в 1С.
0
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
19.03.2007, 15:09 5
Эти книги сейчас передо мной лежат открытые, но в них конкретных примеров нет,есть типовые...Вы бы не могли привести хотя бы, какой-нибудь пример запроса, подходящий для моего случая,если вам не сложно...
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
19.03.2007, 15:13 6
В книгах как раз есть примеры запросов по документам.
0
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
19.03.2007, 15:15 7
Ок, щас посмотрю....Дак а как связать результат запроса с колонкой?
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
19.03.2007, 15:22 8
в цикле пройтись по результатам запроса и в соответствующие строки соответствующей колонки записать нужные данные.
0
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
19.03.2007, 15:27 9
А с помощью какого метода можно обращаться к колонкам из реквизитов табличной части документа?
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
19.03.2007, 15:33 10
Например, реквизит табличной части "Номенклатура".
Номенклатура = ...
0
kymtoshyk
0 / 0 / 0
Регистрация: 15.03.2007
Сообщений: 18
19.03.2007, 15:51 11
Понял..спасибо
0
19.03.2007, 15:51
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.03.2007, 15:51

Связка документов в 1С
Здравствуйте! Помогите разобраться с простым вопросом. Есть два документа...

Автозагрузка документов
Подскажите, пожалуйста, как реализовать процесс автозагрузки документов из...

выгрузка документов
У меня такая проблема,мне нужно выгрузить документы из ТИС 7.7 в ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru