Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.53/156: Рейтинг темы: голосов - 156, средняя оценка - 4.53
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
1

Перебор документов по дате

04.03.2007, 15:05. Просмотров 28124. Ответов 15
Метки нет (Все метки)

Подскажите пож-та алгоритм перебора документов по дате.. Как подступиться к проблеме этой7 нужно чтобы программа сверяла дату документа с заданым интервалов времени(например с 1.01.07 по 31.02.07). как задать этот интервал можно? если кто нибудь знает, подскажите, а то идей пока конкретных нету..
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.03.2007, 15:05
Ответы с готовыми решениями:

Перебор документов
День добрый! Нужно осуществить перебор документов в запросе. Простой перебор...

Перебор документов и их табличных частей, замена нужного товара на новый и перепроведение
1С:Предприятие 8.2 (8.2.19.130) Подскажите пожалуйста, не могу заменить...

Отбор по банковскому счету документов в журнале документов (банковская выписка)
Добрый день! Подскажите, пож, как правильно написать код для отбора по...

Перебор Документов В Коллекции
Доброго времени суток. Прошу помощи по такому вопросу: есть вид, в нем...

Перебор документов во View по полю
Есть View "Menu", в ней находятся сохраненные документы. Мне нужно написать...

15
Zob
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 584
04.03.2007, 15:57 2
Посмотри метод ВыбратьДокументы(<Дата1>,<Дата2>) помоему тут понятно и без пояснений.
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
04.03.2007, 16:06 3
спасибо, сейчас попробую

вопрос только, как эти документы перебрать?

1C
1
2
3
4
ВыбратьДокументы(дата1,дата2);
Пока Док.ПолучитьДокумент()=1 Цикл
//тело программы
КонецЦикла;
будет открываться вся выборка в заданых датах?что-то легко прям..
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
04.03.2007, 17:21 4
1C
1
2
3
4
5
6
7
8
9
10
11
12
Процедура ОК()
Перем ДатаДок;
ы=0;
Док=СоздатьОбъект("Документ");
Док.ВыбратьДокументы(НачДата,КонДата);
Пока Док.ПолучитьДокумент() > 0 Цикл
ТекДок=Док.ТекущийДокумент();
ы=ы+1;
Сообщить("датадок" +ТекДок.ДатаДок +ы +ТекДок.Модифицированность);
 
КонецЦикла;
КонецПроцедуры;
Выдает ошибку
Сообщить("датадок" +ТекДок.ДатаДок +ы +ТекДок.Модифицированность);
{D:\1C\EXTFORMS\СЧЕТФАКТУРА.ERT(16)}: Поле агрегатного объекта не обнаружено (Модифицированность)
Не подскажите в чем дело?
0
Pro
0 / 0 / 0
Регистрация: 05.04.2009
Сообщений: 3
04.03.2007, 17:24 5
Модифицированность работает только непосредственно из формы документа... imho
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
04.03.2007, 17:54 6
к тому же - это еще и функция Модифицированность() B)
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
05.03.2007, 18:45 7
блин а еще 1 проблемка возникла, которую ввиду своей неопытности немогу решить :
как закрыть форму ? т.е ее можно открыть строчкой:
1C
1
2
ОткрытьФорму("Документ." + "СчетФактура", , Док.ТекущийДокумент());
//тек.док берется из выборки док-ов по датам
когда открывается форма, она создаёт счетфактуру для каждого док-та, и после этого ее нужно закрыть и сохранить док-т, который она создаёт. как это можно сделать ?
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
06.03.2007, 09:35 8
а для чего его вобще открывать ?
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
06.03.2007, 13:52 9
суть работы программы:
перебор документов по заданым датам, для каждого док-та создается счетфактура или открывается если она создана. все это делается формой, которую я немогу закрыть програмно.

и еще обьясните кому нетрудно разницу между открыть форму и открытьформумодально
0
Zob
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 584
06.03.2007, 14:55 10
Форму документа открывать не обязательно, для того, чтобы изменить или создать документ. Хуже того, 1С не позволяет программно заполнить табличную часть документа, ч-з контекст формы. (извращения в счет не берем.)
Модально, открытая форма останавливает выполнение модуля, который ее открыл.
Не модальная открывается, и выполнение идет дальше.
Я надеюсь, ты в курсе, что при открытой модальной форме, ты не сможешь переключиться на другое окошко.

Для закрытия формы, смотри Форма.Закрыть(<ЗапрСохр>) или атрибут СтрокаДействийФормы
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
08.03.2007, 14:29 11
как же тогда решить проблему : Есть документ, который создает счетфактуру для документа реализация товара...нужен внешнией отчет, который будет перебериать документы в заданых датах,и создавать счетфактуру для них, если а.Это документ "реализация товара". б.счетфактура для тек.док-та несоздана.



Что смог сделать я :
Проверка названия док-та "реализация товара"
Проверка на существование счетфакуты для текдока есть
Перебор док-ов есть


как видно это совсем, мало..пытаюсь разобраться, рад всем советам...
Нужен метод, совет, как использовать уже готовый док-т , который создает счетфактуру эту...а потом в цикл перебора док-та вставить и все... свиду просто, а не получается, или подход к решению этой проблемы неправильный?
0
Zob
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 584
09.03.2007, 11:11 12
1C
1
2
3
4
5
6
Процедура СоздатьСФ()
Док=СоздатьОбъект("Документ.СчетФактура");
Док.Новый();
// заполнение реквизитов дока.
Док.Записать();
КонецПроцедуры
помогло? :(
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
14.03.2007, 17:33 13
ага. )) а вот вопрос еще 1. если это все мне нужно реализовать во внешнем отчете, что изменится в синтаксисе или еще в чем-нибудь. ?
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
14.03.2007, 17:46 14
вот непонятно например, в реквизитах шапки документа есть такой реквизит : тип , имеющий значение перечисление.типысчетов фактур.. так же в модуле этого же документа есть строчка
1C
1
Если Тип = Перечисление.ТипыСчетовФактур.Отгрузка Тогда
как эта же строчка будет выглядеть во внешнемочтете(обработке)
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
15.03.2007, 08:45 15
Если Док.Тип = Перечисление.ТипыСчетовФактур.Отгрузка Тогда
0
stym
0 / 0 / 0
Регистрация: 04.02.2007
Сообщений: 38
15.03.2007, 11:03 16
Ура. Программа сделал. Спасибо всем, кто помог.
0
15.03.2007, 11:03
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.03.2007, 11:03

Перебор файлов по дате
Доброго времени суток! Есть задача, но пока не могу добиться результата в ее...

Выбор документов по дате
Подскажите, пожалуйста, варианты решения следующей задачи: Нужно показать...

Полный перебор и сокращенный перебор, путем исключения одного цикла
1) Разработать на основе метода полного перебора программу razmen1 для решения...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru