Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.87/77: Рейтинг темы: голосов - 77, средняя оценка - 4.87
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
1

БухИтоги: необходимо найти сумму оборота по счетам 69, 70 по конкретному Сотруднику

13.03.2007, 17:02. Просмотров 13946. Ответов 5
Метки нет (Все метки)

Вот такая проблема. Для расчета необходимо найти сумму оборота по счетам 69, 70 по конкретному Сотруднику (он же - Субконто - Справочник "Сотрудники"). Пишу так:

1C
1
2
3
4
5
БухИтоги = СоздатьОбъект ("БухгалтерскиеИтоги");
БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник);
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);
 
ПособияНачислены = БухИтоги.ОБ (СчетПоКоду ("70"), СчетПоКоду ("69.3")); // это искомое значение
Но это не правильно. Выдает ошибку. Как написать не знаю! Уже могз закипает! Как?! Help...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.03.2007, 17:02
Ответы с готовыми решениями:

Выбрать только документы "Ввод расчета сотруднику" по указанному сотруднику
Всем доброго времени суток Необходимо выбрать все документы "Ввод расчета...

Необходимо найти сумму элементов массива с k1-го по k2-й
Дан массив из n элементов и числа k1 и k2. Необходимо найти сумму элементов...

Необходимо найти сумму ряда чисел
Нужно реализовать программу, которая будет считать сумму чисел из ряда...

Необходимо найти сумму очков карт в блекджеке
Суть задачи состоит в том, чтобы посчитать сумму очков карт на руках (игра...

1с 7.7 Бухитоги По Проводкам
Добрый день! Может быть, кто-то сталкивался с таким. Делаю запрос: ...

5
Zob
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 584
13.03.2007, 18:05 2
Как?!
1C
1
2
3
4
5
6
7
8
9
БухИтоги.ИспользоватьСубконто (ВидыСубконто.Сотрудники,Сотрудник,2);
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);
 
БухИтоги.ВыбратьСчета();
Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
БухИтоги.ВыбратьКорСчета();
Если БухИтоги.ПолучитьКорСчет(СчетПоКоду("69.3"))=0 Тогда Продолжить; КонецЕсли;
 
ПособияНачислены = БухИтоги.ОБ(); // это искомое значение
Примерно так. (Это общее направление, код я не запускал.)
0
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
13.03.2007, 19:55 3
4 Zab
К сожаленю, так тоже ничего не получается.
И еще. Скажите, пожалуйста, какой смысл в следующей записи:
Если БухИтоги.ПолучитьСчет(СчетПоКоду("70"))=0 Тогда Продолжить; КонецЕсли;
?
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
13.03.2007, 21:07 4
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",2);

Пятый параметр в функции Запрос - Валюта. Вы туда передаете "2" (это как я понял тип итогов - обороты).
Надо так:
БухИтоги.ВыполнитьЗапрос (ДатаНач, ДатаКон, "70","69.3",,2);
0
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
14.03.2007, 09:47 5
LSH, да, вы правы. Запрос я исправила. А дальше? Опять не работает.
Вот какую ошибку выдает:
ПособияНачислены = БухИтоги.ОБ();
{Документ.ЗарплатаРасчет.Форма.Модуль(82)}: Недостаточное число параметров передано при вызове функции/процедуры объекта

Как получить оборот по счетам в разрезе Субконто???
0
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
14.03.2007, 10:23 6
Все заработало! Проблема закрыта. Всем спасибо. :D
0
14.03.2007, 10:23
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.03.2007, 10:23

Необходимо найти контрольную сумму CRC-16 некого сообщения
Здравия. Необходимо найти контрольную сумму CRC-16 некого сообщения. На сколько...

Необходимо найти сумму всех чисел из промежутка от A до B кратных 13 и 5
Необходимо найти сумму всех чисел из промежутка от A до B кратных 13 и 5. А И В...

Дано число n необходимо найти сумму m последних цифр числа n
Дано число n необходимо найти сумму m последних цифр числа n. Вписываем n(само...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru