Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.72/274: Рейтинг темы: голосов - 274, средняя оценка - 4.72
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
1

Выделение цветом

01.03.2007, 14:12. Просмотров 49434. Ответов 10
Метки нет (Все метки)

Подскажите, если кто знает, можно ли как то выделить цветом во многострочной части документа столбцы и строки
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.03.2007, 14:12
Ответы с готовыми решениями:

Выделение цветом номенклатуры товара
Всем привет! Вопрос к спецам, если кто знает как сделать что-бы в номенклатуре...

8.2 Упр.прилож.: Дерево значений - можно ли выделить цветом/шрифтом одну строку ?
Вывожу в упр.форму дерево значений - могу посмотреть тек.строку/тек.данные есть...

1c8 выделение даты из строки
Есть строка типа "дата пог 12.07.07" или "дата пог 12.07.2007". Как можно из...

Выделение строки табличной части
Что нужно сделать, что бы при клике мышкой по строке табличной части документа...

8.2 Динамический список: множественное выделение строк ?
Пользователю требуется выделять по несколько объектов за раз - предполагаю...

10
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
01.03.2007, 14:32 2
Можно.
FormEx.dll
0
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
01.03.2007, 14:40 3
vitfil, ты уж прости, но я еще не опытный в 1с, поэтому спрашиваю, как использовать эту FormEx.dll
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
01.03.2007, 14:41 4
в документации к ней есть примеры.
0
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
04.03.2007, 15:49 5
в общем то подключить FormEx я сумел, но вот раскрасить многострочную часть не получается, ну вот никак, писал в строке формулы BRUSH [1] и с ковычками и со скобочками и без ничего и как только не писал, все равно ошибки. подскажите как правильно написать команду? или мож у кого примерчик есть по раскраске многостр. части дока?
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
04.03.2007, 17:46 6
в глобальном модуле пишешь например так :

Функция ПолучитьЦвет(Красный = 0,Зеленый = 0,Синий = 0) Экспорт
// функция для формирования значения цвета из составляющих (RGB)
Возврат Макс(0,Синий)*65536 + Макс(0,Зеленый)*256 + Макс(0,Красный);

КонецФункции


Использование :

Т = СоздатьОбъект("ТаблицаЗначений");
Т.НоваяКолонка("ЦветСтр","Строка");
Т.ВидимостьКолонки("ЦветСтр",0);

Т.ЦветСтр = "BRUSH["+ ПолучитьЦвет(255,100,100)+"]";
0
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
05.03.2007, 09:28 7
попробовал, в глоб. модуле написал все как посоветовали, в процедуре ПриОткрытии оформил следующим образом:

Процедура ПриОткрытии()
Сервис = СоздатьОбъект("Сервис");
Сервис.ВключитьРаскраскуТаблиц();
ПриЗаписиПерепроводить(1);
Кр = "BRUSH["+ ПолучитьЦвет(115,50,41)+"]";
КонецПроцедуры

Кр - колонка ТЧ

И всеравно не красит ничего. Подскажите что я не так делаю, может есть у кого нибудь примерчик попобробнее?
Мне в принципе от ФормЕкс нужна только возможность раскраски строк и столбцов в тч дока, и никак не могу воткнуть как она работает
0
jj_moyt
0 / 0 / 0
Регистрация: 25.02.2007
Сообщений: 88
05.03.2007, 10:59 8
а нет желания использовать 1CPP.DLL ? там все как-то проще..... (и функций больше)
Никаких СоздатьОбъект там писать не нужно. В параметрах включил раскраску и вперед
Если есть желание, могу подкинуть
0
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
05.03.2007, 11:03 9
конечно хочу! скинь мне на мыло Greymen@mail.ru
и если не сложно то документацию какую нибудь к ней и примерчики.
Заранее благодарен
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
05.03.2007, 16:11 10
Для: jj_mail

В 1С++ включено ядро компоненты FormEx. Минус - приходится таскать с собой 1,5 Мб библиотеку, грузится дольше чем ФормЕКС, да и зачем тянуть библиотеку, если 95% ее функций использоваться не будет? Плюс еще там ядро обновляется довольно редко, а Формекс - часто.

<!--QuoteBegin-GreyMen+6:03:2007, 09:15 -->
<span class="vbquote">(GreyMen @ 6:03:2007, 09:15 )</span><!--QuoteEBegin-->попробовал, в глоб. модуле написал все как посоветовали, в процедуре ПриОткрытии оформил следующим образом:

Процедура ПриОткрытии()
Сервис = СоздатьОбъект("Сервис");
Сервис.ВключитьРаскраскуТаблиц();
ПриЗаписиПерепроводить(1);
Кр = "BRUSH["+ ПолучитьЦвет(115,50,41)+"]";
КонецПроцедуры

Кр - колонка ТЧ

И всеравно не красит ничего. Подскажите что я не так делаю, может есть у кого нибудь примерчик попобробнее?
Мне в принципе от ФормЕкс нужна только возможность раскраски строк и столбцов в тч дока, и никак не могу воткнуть как она работает
[snapback]58313" rel="nofollow" target="_blank[/snapback]?[/quote]

Там всё не так.
Вешаем на табл. часть формы реквизит текст (кликнуть по тексту в панельке, кликнуть по форме), на нее вешаем функцию, например, Раскрас(), делаем этот реквизит невидимым.
Далее, в глоб. модуле заводим переменную Сервис, а
Процедура ПриНачалеРаботыСистемы()
Попытка
ЗагрузитьВнешнююКомпоненту("FormEX.DLL");
Сервис = СоздатьОбъект("Сервис");
Сервис.ВключитьРаскраскуТаблиц();
Исключение
Сообщить("Компонента недоступна");
КонецПопытки;
КонецПроцедуры

В модуле:
Функция Раскрас()
Если [Какое_то_условие] Тогда
Возврат "BRUSH["+ПолучитьЦвет(221,221,255)+"]"; //ну или какие-то другие цвета
Иначе
Возврат ""; //чтобы не раскрашивало
КонецЕсли;
КонецФункции

<!--QuoteBegin-jj_mail+6:03:2007, 10:46 -->
<span class="vbquote">(jj_mail @ 6:03:2007, 10:46 )</span><!--QuoteEBegin-->В параметрах включил раскраску и вперед
[snapback]58323" rel="nofollow" target="_blank[/snapback]?[/quote]

В формексе аналогично. В Предприятии Сервис-Параметры-FormEx
0
kryyMym
0 / 0 / 0
Регистрация: 26.02.2007
Сообщений: 6
06.03.2007, 08:08 11
Благодарю, все получилось!!!!
0
06.03.2007, 08:08
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.03.2007, 08:08

Выделение внесенных изменений
Здравствуйте! Как в 1с8 делать отметки об изменениях аналогично приведенному...

Выделение цветом
Есть текстбокс в который выводится вычисление с трёх других текстбоксов, как...

Выделение строк цветом
Как можно выделить только лишь определенную строку цветом, при этом что бы...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru