Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.81/79: Рейтинг темы: голосов - 79, средняя оценка - 4.81
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
1

Заполнение формы документа

20.02.2007, 12:19. Просмотров 14223. Ответов 4
Метки нет (Все метки)

Такая вот проблема.
В форме документа (табличная часть) вводятся два счета - д*цензура* и кредит (реквизиты табличной части). Причем один из них (или д*цензура* или кредит) может повторяться в следующих строках. Например, д-т "01", кр-т "00", далее д-т "10", кр-т "00"; д-т "41", кр-т "00" и т.д. Может быть наоборот д-т "00", кредит "02" и т.д. Подскажите, как и где сохранить этот счет (в моем примере "00"), чтобы он по умолчанию использовался в следующей строке. Причем этот счет может меняться: быть и в д*цензура*е и в кредите (но счет один - "00"). Т.О. если в д*цензура*е выбран другой счет (не "00"), то в кредит счет "00" должен ставиться автоматически.
Спасибо за ответы.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.02.2007, 12:19
Ответы с готовыми решениями:

Active document, заполнение документа реквизитами с формы
Добрый день! 1с 8.2, управляемая форма, надо чтобы при нажатии на кнопку печать, в макет,...

Заполнение реквизита табличной части документа (строки, из справочника наименования, внутри документа)
Здравствуйте. Волею судеб нужно сваять пару документов в 1с 77. Вроде бы как все шло нормально,...

Как изменить текст надписи формы документа при записи документа
Здравствуйте уважаемые, у меня простой вопрос - как мне при записи документа изменить надпись на...

Проведение документа из модуля формы документа
Столкнулся с такой проблемой. Нужно провести документ из формы документа. Побывал на многих сайтах...

Закрытие формы документа из внешней печатной формы
Нужно после печати документа, закрыть его форму. Управляемое приложение. Никак не могу понять прошу...

4
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
20.02.2007, 13:10 2
Используй СчетПоКоду("00")
На счет д*цензура*а и счет кредита (колонки в табл. части) повесь процедуру, которая будет анализировать текущую колонку, и, если это д*цензура* - автоматом в реквизит счет кредита записывать СчетПоКоду("00"), и наоборот.
примерно так:

1C
1
2
3
4
5
6
7
Процедура ПриВыбореСчетаДК()
Если Форма.ТекущаяКолонка() = "СчетД*цензура*" Тогда
СчетКредит = СчетПоКоду("00");
ИначеЕсли Форма.ТекущаяКолонка() = "СчетКредит" Тогда
СчетД*цензура* = СчетПоКоду("00");
КонецЕсли;
КонецПроцедуры
0
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
25.02.2007, 15:30 3
Спасибо, попробовала - не работает. Вернее, так как надо не работает. Возможно, проблему сформулировала не ясно. Дело в том, что мне надо, чтобы в следующей строчке были те же счета д*цензура*а и кредита, что и в предыдущей. В 1С 6.0 у меня это очень просто получалось. Хочу тоже и в 7.7. - а не выходит :D . Буду пробовать другие варианты. Вот например:
Процедура ПриРедактированииНовойСтроки ().
Может посоветуете как ее применить? Спасибо за ответы.
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
25.02.2007, 15:48 4
Хех, как формулируете, так и отвечем.

А процедуру в вашем случае применить просто:


1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ПриРедактированииНовойСтроки()
Если НомерСтроки = 1 Тогда
Возврат; //чтобы при вводе первой строки не было ошибок
КонецЕсли;
ПолучитьСтрокуПоНомеру(НомерСтроки-1); //позиционируемся на предыдущ. строку
БылСчД = Счетд*цензура*;
БылСчК = СчетКредит; //или как там эти реквизиты у вас называются
ПолучитьСтрокуПоНомеру(НомерСтроки+1); //возвращаемся на свою строку
СчетД*цензура* = БылСчетД; //присваиваем
СчетКредит = БылСчетК;
КонецПроцедуры
0
Butty
0 / 0 / 0
Регистрация: 17.02.2007
Сообщений: 28
27.02.2007, 16:52 5
LSH, большое спасибо! Действительно, очень просто (о чем я и догадывалась)
Пойду переделывать следующий документ. Еще раз спасибо за помощь. Просто хочу сделать свою настойку, "с нуля". А опыта маловато.
Пока
0
27.02.2007, 16:52
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.02.2007, 16:52

Заполнение документа
Не заполняется ТЧ документа при выборе данных из ТЧ другого дока. Вот выбираю и заполняю:...

Заполнение ТЧ документа (1С 8.2)
Здравствуйте! Есть справочник "Номенклатура", у которого есть табличная часть "ДопРеквизит" с...

Заполнение ТЧ Документа из Реквизитов справочника
нужно заполнить ТЧ документа из Реквизита справочника. &НаКлиенте Процедура...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru