Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/33: Рейтинг темы: голосов - 33, средняя оценка - 4.91
rpoM
0 / 0 / 0
Регистрация: 28.07.2012
Сообщений: 2
1

Внешняя Обработка

31.07.2012, 17:07. Просмотров 6081. Ответов 2
Метки нет (Все метки)

добрый день!
Очень нужна помощь.В 1с8.2 есть справочник контрагенты.Необходимо в наименовании убрать ковычки и ООО,ОАО, и т.д.убрать в конец.не получается
Код внеш.обр.
Запрос = Новый
Запрос;
Запрос.Текст=
"Выбрать*
|из Справочник.Контрагенты //ищу справочник,не группу
|ГДЕ
|не этоГруппа";
Выб=Запрос.Выполнить().Выбрать();
Пока Выб.Следующий()Цикл
Об_спр=Выб.Ссылка.ПолучитьОбъект();
a=Об_спр.Наименование;
//далее не уверен в написанном
Если Об_спр.Наименование="" тогда
Результат = СтрЗаменить(Об_спр.Наименование, "//здесь находим нужный символ", "//найден.символ меняем на тут");
//Функцию перемещения в конец строки не нашел((
КонецЕсли;
Об_спр.Записать();
КонецЦикла
Только прошу не гнать,код в 1с пишу впервые.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.07.2012, 17:07
Ответы с готовыми решениями:

Внешняя обработка
Здравствуйте, конфигурация УТ 10.3, создал внешнюю обработку для отправки вложений по почте. Как...

Внешняя обработка
Добрый день! создал внешнюю обработку, вопрос в том как добавить на печатную форму юрадрес клиента,...

Внешняя обработка
1С Предприятие 8.2 Как из внешней обработки создать элемент в корень какого-нибудь справочника? (В...

Внешняя обработка (ЗаполнениеОбъекта)
1С 8.2 Управляемые формы Не могу понять как перехватить ссылку с документа, чтобы обработка...

1с 8.2 Не открывается внешняя обработка
Доброго времени всем! Такая беда, запускаю 1С Предприятие 8.2 УТ 11 запускаю созданную обработку, а...

2
ottyxyy
0 / 0 / 0
Регистрация: 27.04.2008
Сообщений: 371
01.08.2012, 03:33 2
Кури

Код ( (Unknown Language)):
Запрос = Новый Запрос("ВЫБРАТЬ
| Контрагенты.Ссылка
|ИЗ
| Справочник.Контрагенты КАК Контрагенты
|ГДЕ
| Контрагенты.ЭтоГруппа = ЛОЖЬ");

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

Контрагент = Выборка.Ссылка.ПолучитьОбъект();

Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, """", "");
Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, "«", "");
Контрагент.Наименование= СтрЗаменить(Контрагент.Комментарий, "»", "");

Если НЕ Найти(Контрагент.Наименование, "ООО") = 0 Тогда
Контрагент.Наименование = СтрЗаменить(Контрагент.Комментарий, "ООО", "");
Контрагент.Наименование = Контрагент.Наименование + " ООО";
КонецЕсли;
Контрагент.Записать();
КонецЦикла;
Код не совсем феншуйный, но принцип работы будет понятен
0
rpoM
0 / 0 / 0
Регистрация: 28.07.2012
Сообщений: 2
01.08.2012, 11:40 3
спасибо.
Вечером сам разобрался,код примерно такой же написал.С некоторыми нюансами.СпС
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.08.2012, 11:40

1с: Документооборот 8.2 + Внешняя Обработка
Доброго времени суток, господа и дамы. На днях попалась задачка - создать для ДО обработку, на...

1c77. Не Открывается Внешняя Обработка
На сервере пытаюсь открыть внешнюю обработку (проблема только с одной, остальные открываются без...

Таблица Умножения (Внешняя Обработка)
Здравствуйте, помогите пожалуйста разобраться с заданием. Требуется создать таблицу умножения...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru