Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/47: Рейтинг темы: голосов - 47, средняя оценка - 4.91
mub
0 / 0 / 0
Регистрация: 18.11.2010
Сообщений: 59
1

Печатная Форма

28.09.2011, 13:15. Просмотров 8532. Ответов 3
Метки нет (Все метки)

Подскажи пожалуйста
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.РасчётЦены.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| РасчётЦены.Заказ,
| РасчётЦены.Заказчик,
| РасчётЦены.КалькуляционнаяЕдиница,
| РасчётЦены.НаименованиеИзделия,
| РасчётЦены.ЦехИзготовитель
|
|ИЗ
|
| Документ.РасчётЦены КАК РасчётЦены
|ГДЕ
|
| РасчётЦены.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьЗаголовок1 = Макет.ПолучитьОбласть("Заголовок1");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьТабличнаяЧасть1Шапка = Макет.ПолучитьОбласть("ТабличнаяЧасть1Шапка");

ОбластьПоле1 = Макет.ПолучитьОбласть("Поле1");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;
ТабДок.Вывести(ОбластьЗаголовок1);

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьТабличнаяЧасть1Шапка);
ТабДок.Вывести(ОбластьПоле1);
ВставлятьРазделительСтраниц = Истина;
КонецЦикла;


//}}
КонецПроцедуры




вот код,что нужно сюда добавить что бы значения выбирались не из одного документа а из 2-ух
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.09.2011, 13:15
Ответы с готовыми решениями:

Печатная форма М-15
Помогите. В 1С-упрощенке есть таблица М-15 Мне нужно чтоб эта форма была в 1с ТиС 7.7 и...

Печатная Форма 1с 8.2
Здравствуйте,помогите новичку Вот печатная форма

Печатная форма
Уже не знаю что делать. Вроде детская проблемка, устраняющаяся на раз - два, а никак не могу понять...

Печатная форма
Помогите пожалуйста. Есть такая процедура: //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать) // Данный...

Печатная форма
Такая проблема: есть печатная форма, допустим, счет-фактуры. Там много строк и 1-2 строки не...

3
Skyttor
0 / 0 / 0
Регистрация: 29.07.2008
Сообщений: 87
28.09.2011, 14:27 2
Добавь в запрос еще один документ и свяжи его с первым.
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
28.09.2011, 15:02 3
Мое сообщение надо удалить
0
Usyr1s
0 / 0 / 0
Регистрация: 24.04.2008
Сообщений: 30
28.09.2011, 17:16 4
Добавь массив документов, или используй

Код ( (Unknown Language)):
ВЫБРАТЬ ПЕРВЫЕ 2
, укажи тады с... по...
0
28.09.2011, 17:16
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.09.2011, 17:16

Печатная форма 8.2
1.Добрый день не подскажите можно в одной ячейке написать разными шрифтами? к примеру:...

Печатная форма
Добрый день Уважаемые! У меня такая проблема нигде в сети не могу найти печатную форму...

Внешняя печатная форма в 1С 7.7
Всем доброго дня! Появилась необходимость добавить в 1С 7.7 Бухгалтерию внешнюю печатную форму для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru