Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/53: Рейтинг темы: голосов - 53, средняя оценка - 4.92
1

Помогите разобраться с документом ГТД

27.09.2010, 12:24. Просмотров 9805. Ответов 2
Метки нет (Все метки)

Всем привет, помогите разобраться, комплексная конфигурация, документ ГТД. Формируются проводки не так как бы хотелось. Необходимо чтобы в проводке 281-632, по 281 счету в проводке было указано субконто 1, субконто 2 ну и + количество. Вроде и в плане счетов все предусмотрено, а проводки формируются итоговыми суммами по документу (а надо грубо говоря в цикле по строкам), соответственно тогда и в 281 нет аналитики по субконто. Может где то есть какая то загвоздочка и можно быстро решить мою проблему, вместо того чтобы изобретать заново велосипед?
про обработку ЭП_ФормированиеПроводокТорговля

текОперация.Дебет.Счет = текСчетД;
Если ПустоеЗначение(текСчетД) = 0 Тогда
Для Инд = 1 по 3 Цикл
//Если текСчетД.ВидСубконто(Инд) = ВидыСубконто.Партии Тогда
// раскомментировать, если необходимо формирование поводок по счетам учета товаров с аналитикой
// нужно найти или создать партию
спПартия = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
ЗначениеСубк = 0;
Если ТипЗначенияСтр(спПартия)="СписокЗначений" Тогда
глПолучитьПартию(ЗначениеСубк,спПартия.Получить("ТМЦ"),спПартия.Получить("Партия"));
КонецЕсли;
Иначе
ЗначениеСубк = тбПроводки.ПолучитьЗначение(тбПроводки.НомерСтроки, "СубконтоД"+Инд);
КонецЕсли;
КонецЦикла;

Так вот в чем дело: когда я раскоментировала необходимые строки для ведения аналитики по товарам, ничего не произошло, такие же проводки как были такие и остались, как заставить программу видеть 281 счет по товарам.

и ещё один вопрос:
Справочник ЭП_Проводки

Если ПустоеЗначение(ВидСубконто) = 0 Тогда
Если (ТипЗначенияСтр(Счет) = "Счет") и ((Лев(Сч.Код,2) = "28") или (Лев(Сч.Код,2) = "66")) Тогда
// для счетов 28х и 66х запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Пустое субконто");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
ИначеЕсли (ТипЗначенияСтр(Счет) = "Справочник")
и (Лев(Сч.Код,2) = "28") Тогда
// для доп.параметров "Счет учета товаров", "Счет учета товаров в рознице"
// и "Счет учета товаров, отданных на комиссию"
// запрещено редактирование субконто
Форма.ПолучитьАтрибут(Субконто).Видимость(0);
Форма.ПолучитьАтрибут(тСубконто).Заголовок("Определяется автоматически");
Форма.ПолучитьАтрибут(тСубконто).Видимость(1);
Форма.ПолучитьАтрибут(АвтоСубконто).Доступность(0);
Форма.ПолучитьАтрибут(Параметр).Доступность(0);
Иначе
........
и т.д.

почему ЗАПРЕЩЕНО РЕДАКТИРОВАНИЕ СУБКОНТО по 28 счету?
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.09.2010, 12:24
Ответы с готовыми решениями:

Помогите с документом кто-нибудь!
Ребята нужна помощь сам не справлюсь мелочь а не могу но не программер я 1С а пользователь! Сделаю...

Помогите с документом кто-нибудь!
Ребята нужна помощь сам не справлюсь мелочь а не могу но не программер я 1С а пользователь! Сделаю...

Взаиморасчеты по ГТД, УПП
Здравствуйте. Мне нужно обеспечить возможность списания суммы с нескольких платежных поручений для...

1C 7.7:пропала колонка ГТД в табличной части!!
Скажите, что именно я должна сделать, чтобы в табличной части документа "Отгрузка товаров"...

1с 7.7 Помогите разобраться.
Помогите, пожалуйста. При загрузке 1с Предприятия выходит ошибка, делаю переиндексацию ошибка...

2
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
27.09.2010, 12:31 2
А это в Белорусии такие большие номера счетов?
Ваша конфа кем-то дописывалась? Кто ж может знать, зачем это делалось...
0
27.09.2010, 12:36 3
Это комплексная конфигурация для Украины(( Типа стандарт, в данном контексте не дописывалась, т.е. это по умолчанию так есть(
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.09.2010, 12:36

Помогите разобраться!
Доброго времени суток. Умные люди, помогите пожалуйста разобраться. Существуют две одинаковые...

Помогите разобраться
1С 7.7 Торговля+Склад В справочник Номенклатура добавлены следующие реквизиты: ФлВозврТары (Тип...

Помогите разобраться со строками
Доброго времени суток всем. Проблема такова, что я только новичок в программировании в 1С, и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.