Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.84/269: Рейтинг темы: голосов - 269, средняя оценка - 4.84
dymom_ob_304
0 / 0 / 0
Регистрация: 23.07.2007
Сообщений: 3
1

Пяти минутное дело. 1С 7.7 Торговля и склад

26.07.2007, 13:49. Просмотров 48492. Ответов 17
Метки нет (Все метки)

Есть код, этот код выводит на печать ценники (три ряда по два ценника в каждом ряде на странице). Необходимо чтоб было три ряда по три ценника. Заранее спасибо.


Сам код:

//******************************************************************************
// ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
//
// Параметры:
// Таб - таблица, в которую выполняется вывод ценника
// ПечНаименование - наименование товара
// ПечЕдиница - единица измерения товара
// ПечРозн - цена товара
// Столбик - номер столбика.
// Ряд - номер ряда
//
// Возвращаемое значение:
// Нет.
//
// Описание:
// Добавляет ценник в таблицу.
//
Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)

Столбик = ?(Столбик = 1, 0 , 1 );
Ряд = ?(Столбик = 0, Ряд + 1, Ряд);

Если Ряд > 3 Тогда
Таб.НоваяСтраница();
Ряд = 1;
КонецЕсли;

Если Столбик = 0 Тогда
Таб.ВывестиСекцию("Товар|Ценник");
Иначе
Таб.ПрисоединитьСекцию("Товар|Ценник");

КонецЕсли;

КонецПроцедуры // ДобавитьЦенник()


//******************************************************************************
// Сформировать(ТаблицаТоваров, ПечФирма)
//
// Параметры:
// ТаблицаТоваров - таблица значений, содержащая информацию о цене товара
// ПечФирма - наименование фирмы, которое будет выводиться вверху ценника
//
// Возвращаемое значение:
// Нет.
//
// Описание:
// Формирует таблицу с ценниками.
//
Процедура Сформировать(ТаблицаТоваров,ПечФирма)

// Создание Таблицы для выходного отчета
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");

Столбик = 1;
Ряд = 0;

ТаблицаТоваров.ВыбратьСтроки();
Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
ПечРозн = глФРМ(ТаблицаТоваров.Цена, ТаблицаТоваров.Валюта);
ПечНаименование = ТаблицаТоваров.Товар;
ДобавитьЦенник(Таб, ПечФирма, ТаблицаТоваров.Товар, ТаблицаТоваров.Единица, ПечРозн, Столбик, Ряд);
глОживить(1);
КонецЦикла;

//Вызов выходного отчета в окно просмотра и редактирования.
Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
Таб.ТолькоПросмотр(1);
Таб.Показать("Товарные ценники","");

КонецПроцедуры

//******************************************************************************
// Предопределенная процедура
//
Процедура ПриОткрытии()

СтатусВозврата(0);
ДанныеДляПечати = Форма.Параметр;

Если ТипЗначенияСтр(ДанныеДляПечати) <> "СписокЗначений" Тогда
Возврат;
КонецЕсли;

ПечФирма = ДанныеДляПечати.Получить("Фирма");
ТаблицаТоваров = ДанныеДляПечати.Получить("Таблица");

Сформировать(ТаблицаТоваров, ПечФирма);

КонецПроцедуры // ПриОткрытии()
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.07.2007, 13:49
Ответы с готовыми решениями:

1C Торговля и склад
Добрый день хотел спросить у меня есть накладная хотелось бы заменить 2 столбца заменить одним:...

1с торговля склад версия 8.0
Помогите пожалуйста найти сайт где можно скачать бесплатно без отправки смс на номер программу 1с...

Вопрос по 1С Склад + Торговля
Проблема состоит в следующем:мне нужно сделать,что бы в чеке после ввода со сканера штрих-кода,...

Тип параметра в Торговля+склад 9.2
1С семёрка. Редактирую карточку товара. Добавил новое поле с типом -...

Товарная накладная, торговля и склад
Плииз помогите, при печати товарной накладной без НДС, прога указывает что ставка 0, а должен...

17
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
26.07.2007, 21:01 2
Для: dyman_ob_304

15$
0
dymom_ob_304
0 / 0 / 0
Регистрация: 23.07.2007
Сообщений: 3
27.07.2007, 11:00 3
Гы, за 15 баков, я выучу язык

Тут типа, только за вознограждение делается?
0
tsh
0 / 0 / 0
Регистрация: 10.07.2017
Сообщений: 350
27.07.2007, 13:25 4
Нет тут типа помогают людям разобраться с 1С, а не сделать какую-то хрень забесплатно.
Причем, код сюда постить можно только по запросу. Я, например, его даже не читал, да и никто не будет.
Дмай сам, а если не получится - с конкретными вопросами сюда.
0
27.07.2007, 13:25
dymom_ob_304
0 / 0 / 0
Регистрация: 23.07.2007
Сообщений: 3
27.07.2007, 14:31 5
Ок, понял, не мир дурак бы не понял.
0
Typhoom
0 / 0 / 0
Регистрация: 10.05.2004
Сообщений: 209
28.07.2007, 10:28 6
Опять такое впечатление что все сами до всего доходили или потратили уже порядка 1 баксов на то чтобы им решали их проблема!

dyman_ob_304 вот аська отвечу и помогу чем смогу БЕСПЛАТНО! 160592725
0
Dryvyr
0 / 0 / 0
Регистрация: 27.06.2010
Сообщений: 4
30.06.2010, 11:36 7
[

Добавлено: Ребята а подскажите как добавит еше один столбик ценников когда он распечатывает? Выходит так, когда распечатываю там два столбика в каждом столбике по три ценника и еше места много остается пестова на буиаге. Как сделать три столбика? Подскажите плиз
0
vytfyt
0 / 0 / 0
Регистрация: 28.03.2004
Сообщений: 1,913
30.06.2010, 11:47 8
Посмотреть в коде, как выводится 3 столбика и по образу добавить четвертый!
0
Dryvyr
0 / 0 / 0
Регистрация: 27.06.2010
Сообщений: 4
30.06.2010, 13:59 9
Цитата Сообщение от vitfil
Посмотреть в коде, как выводится 3 столбика и по образу добавить четвертый!
Спосибо большое за подсказку :discard:
0
yvkymyotom
0 / 0 / 0
Регистрация: 15.02.2008
Сообщений: 173
30.06.2010, 15:48 10
Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)

Столбик = ?(Столбик = 1, 0 , 1 );
Ряд = ?(Столбик = 0, Ряд + 1, Ряд);

Если Ряд > 3 Тогда
Таб.НоваяСтраница();
Ряд = 1;
КонецЕсли;

все вычисленеия в этом коде. а вообще то код достаточно заумный
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
30.06.2010, 16:43 11
вместо
Столбик = ?(Столбик = 1, 0 , 1 );

надо
Столбик = Столбик+1;
Столбик = ?(Столбик = 3, 0 , Столбик);


а в другом месте вместо
Столбик = 1;

надо
Столбик = 2;
0
Dryvyr
0 / 0 / 0
Регистрация: 27.06.2010
Сообщений: 4
01.07.2010, 09:40 12
Нет Ребята там нужно было добавить одну строчку. Я выделил ее здесь жирным шрифтом.

Если Столбик = 0 Тогда
Таб.ВывестиСекцию("Товар|Ценник");
Иначе
Таб.ПрисоединитьСекцию("Товар|Ценник");
Таб.ПрисоединитьСекцию("Товар|Ценник");

КонецЕсли;
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
01.07.2010, 14:26 13
Driver, если сделать как ты, то второй и третий столбцы будут одинаковыми


ты хотябы попробовал то, что я предложил?
0
Sosshot
0 / 0 / 0
Регистрация: 19.12.2009
Сообщений: 39
05.07.2010, 09:43 14
Используй функцию, присоединить секцию, так будет проще, сам так сделал когда писал обработку по распечатке ценников для компьютерного магазина.
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
05.07.2010, 10:28 15
Цитата Сообщение от SaschaL
Используй функцию, присоединить секцию, так будет проще
... и тем самым можно создать универсальную печать от двух до десяти ценников в ряд (спец. бумага для ценников и спец.принтеров бывает разной ширины)
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
05.07.2010, 10:39 16
может я чего-то не догоняю, но код приведенный в начале темы заточен под то, что КАЖДЫЙ ЦЕННИК РАЗНЫЙ
добавляя ПрисоединитьСекцию будут иолучаться по НЕСКОЛЬКО ОДИНАКОВЫХ ЦЕННИКОВ (при этом первый будет отличаться от второго и остальных в этой строке )

разве это корректное решение задачи?
0
Dryvyr
0 / 0 / 0
Регистрация: 27.06.2010
Сообщений: 4
05.07.2010, 15:10 17
Hryv ты был прав, а я просто копию столбика сделал, попробовал по твойму все получилось спосибо большое.
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
05.07.2010, 15:20 18
Незачто
0
05.07.2010, 15:20
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.07.2010, 15:20

Перенос справочников. Торговля и Склад.
Есть такая проблемма, вернее проблемма для нее это громко сказанно.:D Есть конфигурация &quot;Торговля...

Торговля+Склад 9.2 -> Бухгалтерский учет 4.5
Привет Всем! необходимо перенести из &quot;Торговля+Склад&quot; в &quot;Бух.учет&quot; некоторые справочники, типа...

Конфигурирование С1 7.7 Бухгалтерия.Торговля.Склад
Уважаемые форумчане, доброе время суток! С 1С работала давно и немного в другом направление. При...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
18
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru