Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.90/58: Рейтинг темы: голосов - 58, средняя оценка - 4.90
Romom
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 59
1

Цена

20.05.2010, 15:12. Просмотров 10458. Ответов 4
Метки нет (Все метки)

Код ( (Unknown Language)):
//*******************************************
Процедура Сформировать()
СпрН = СоздатьОбъект("Справочник.Номенклатура");
СпрН.ВыбратьЭлементы();
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Шапка");
Цена="";
Цена = глПолучитьЦену(СпрН.ТекущийЭлемент(),ТипыЦен,РабочаяДата());
Пока СпрН.ПолучитьЭлемент() = 1 Цикл
Если СпрН.ЭтоГруппа() = 0 Тогда
Таб.ВывестиСекцию("Строка");
КонецЕсли;
КонецЦикла;
Таб.Показать(1);
КонецПроцедуры
Цену выдает равной нулю.
Вопрос- почему.
ТипыЦен = Выбираю в диалоге.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.05.2010, 15:12
Ответы с готовыми решениями:

Не отображаетса цена
Стандартная база для Украины, в табличную часть документов Счет и Росходная...

УТ.Не заполняется цена
Установил УТ. Все нормально, только при попытки вручную установить цену или...

Цена номенклатуры
Скажите пожалуйста у нас 1с Предприниматель, я создала документ накладная,...

Цена в этикетке
Доброе время суток Как в 7.7 тис в стандартную этикетку с штрих-кодом...

Форма.ПолучитьАтрибут("Цена"+к)
Как-то столкнулся с этой ерундой. На форме отчета несколько реквизитов: Цена1,...

4
puh14
0 / 0 / 0
Регистрация: 07.07.2008
Сообщений: 1,401
20.05.2010, 19:17 2
Ошибка в моменте определения цены.
0
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
20.05.2010, 19:38 3
puh14 проповедует принцип "Дам направление". Во времена моего обучения гигантские компьютеры часто "висли". Тогда препод говорил: "Отлаживайте всухую". Этот значит нарисовать на бумаге набор исходных данных, потом поводить пальцем по распечатке и высчитать результат.
До сих пор помогает.
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
20.05.2010, 19:44 4
Цитата Сообщение от Дайнеко
Во времена моего обучения гигантские компьютеры часто "висли".
А мне доводилось лазать по дампу, выведенному на АЦПУ. Длина распечатки достигала нескольких метров :unsure:
А вообще-то, принцип "Дам направление" правилен. Ошибка видна сразу, и задаватель вопроса мог легко сам ее
обнаружить, если бы не ленился.
0
Romom
0 / 0 / 0
Регистрация: 11.11.2005
Сообщений: 59
20.05.2010, 19:57 5
Цитата Сообщение от vbs
А вообще-то, принцип "Дам направление" правилен. Ошибка видна сразу, и задаватель вопроса мог легко сам ее
обнаружить, если бы не ленился.
Хм.Вообще-то я тему закрыл, кому-то делать просто не фиг. Взял и открыл тему.
0
20.05.2010, 19:57
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.05.2010, 19:57

Списание материалов по фактической цена
Проблема такая: необходимо написать конфигурацию учета материалов на складе....

Не та цена номенклатуры в Торговля + склад 9.2
Не могу понять почему, но почемуто так происходит.... При оформлении Чека...

1с8.1. Цена последнего поступления номенклатуры.
Как получить по всей номенклатуре последние поступления? Собственно сложность...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru