Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.78/63: Рейтинг темы: голосов - 63, средняя оценка - 4.78
mydmykhtyr
0 / 0 / 0
Регистрация: 03.04.2010
Сообщений: 3
1

Отчет по справочнику Цены

07.04.2010, 00:30. Просмотров 11403. Ответов 4
Метки нет (Все метки)

Доброго времени суток всем читающим сие.

У меня возникла проблема с казалось бы простой задачей - создать отчет, строками которого были бы записи из справочника Цены.
По форумам походил, прежде погуглил - все как полагется - не помогло. Нашел примеры (отдельные кусочки кода) как это сделать, готовых запросов не нашел. На основе найденного состряпал свое:


Код ( (Unknown Language)):
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");

Цн=СоздатьОбъект("Справочник.Цены");
Цн.ИспользоватьВладельца("Алиот"); // Алиот - это да, хардкод. Используется что бы не усложнять и не описывать всю задачу
Цн.ВыбратьЭлементы();
Пока Цн.ПолучитьЭлемент() = 1 Цикл
Таб.ВывестиСекцию("Цен");
КонецЦикла;

Таб.Опции(0);
Таб.ТолькоПросмотр(1);
Таб.Показать();
КонецПроцедуры
Проблема заключается в том, что после работы отчета получаю пустые строки. Отладчик показал, что Цн.ПолучитьЭлемент() = 0, то есть выборка по Контрагенту "Алиот" пустая, хотя в ручном режиме, выборка цен по нему формируется.

Всем кто поможет или просто проявит интерес - заранее огромное спасибо!
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.04.2010, 00:30
Ответы с готовыми решениями:

Внешний отчет по справочнику
Вопрос вот в чем: есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь...

Упр. приложение. Простой отчет по справочнику
Помогите пожалуйста! Покажите отчет по справочнику Контрагенты. Должен выбираться номер бригады и...

Подставление вида цены и цены из регистра сведений
Такое дело... Есть док - Продажи. ТЧ - Товары. Нужно, чтобы При Изменении Номенклатуры в ВидЦены...

Запросы к справочнику
Здравствуйте. У меня следующая ситуация. Мне нужно с помощью запроса, который находиться в модуле...

Вопрос по документу и справочнику
1C:Предприятие v8. Есть документ1. На его форме заполняются несколько полей: название дисциплины,...

4
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
07.04.2010, 00:54 2
Цитата Сообщение от midnighter
Цн.ИспользоватьВладельца("Алиот"); // Алиот - это да, хардкод. Используется что бы не усложнять и не описывать всю задачу
Подсказка: использовать надо не наименование владельца, а ссылку на элемент справочника, созданную функцией "СоздатьОбъект()"
0
mydmykhtyr
0 / 0 / 0
Регистрация: 03.04.2010
Сообщений: 3
07.04.2010, 01:12 3
Цитата Сообщение от unknown181538
Подсказка: использовать надо не наименование владельца, а ссылку на элемент справочника, созданную функцией "СоздатьОбъект()"
Вот так?

Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");
Контр = СоздатьОбъект("Справочник.Контрагенты");
Контр.НайтиПоНаименованию("Алиот",0,0);

Цн=СоздатьОбъект("Справочник.Цены");
Цн.ИспользоватьВладельца(Контр.ПолнНаименование);
Цн.ВыбратьЭлементы();
Пока Цн.ПолучитьЭлемент() = 1 Цикл
Таб.ВывестиСекцию("Цен");
КонецЦикла;

Таб.Опции(0);
Таб.ТолькоПросмотр(1);
Таб.Показать();
КонецПроцедуры

Контрагент нашелся, Цены по нему - нет ;)


ЗЫ: я 1С только начинаю осваивать, поэтому так туго идет...
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
07.04.2010, 01:17 4
Цитата Сообщение от midnighter
Цн.ИспользоватьВладельца(Контр);
0
mydmykhtyr
0 / 0 / 0
Регистрация: 03.04.2010
Сообщений: 3
07.04.2010, 01:27 5
Отработало!

unknown181538, спасибо! Сам я б еще долго думал (второй вечер трачу на это)
0
07.04.2010, 01:27
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.04.2010, 01:27

1с V8 обращение к подчиненному справочнику
v8.1 ЗиК ,8.1.15.14 Скажите,пожалуйста, как правильно обратиться к подчиненому справочнику и...

вопрос по справочнику Склады в УП
Народ подскажите, где теперь храниться приказ в 1С 8 по документу "реализация товаров и услуг " ?,...

Запрос к Иерархическому справочнику
Доброго времени суток! Вопрос такого плана. Есть Иерархический справочник «Фирмы» структура:...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.