Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.51/63: Рейтинг темы: голосов - 63, средняя оценка - 4.51
ytty
0 / 0 / 0
Регистрация: 09.08.2008
Сообщений: 42
1

Ненулевые сальдо на конец по 2 счетам

29.03.2010, 17:13. Просмотров 11382. Ответов 5
Метки нет (Все метки)

Код
    Ит.ВыбратьСубконто(ВидыСубконто.Контрагенты);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Контрагенты) = 1 Цикл
Контрагент=Ит.Субконто(ВидыСубконто.Контрагенты);
Ит.ВыбратьСчета();
к_скд="";
к_скк="";
к_скд_к="";
к_скк_к="";
Пока Ит.ПолучитьСчет()=1 Цикл

Если Ит.Счет.Код=сч_1 Тогда
к_скд=Формат(Ит.СКД(),"Ч014.2.,");
к_скк=Формат(Ит.СКК(),"Ч014.2.,");
Иначе
к_скд_к=Формат(Ит.СКД(),"Ч014.2.,");
к_скк_к=Формат(Ит.СКК(),"Ч014.2.,");
КонецЕсли;
КонецЦикла;
Если (к_скд<>0) И (к_скк_к<>0) Тогда

Т.ВывестиСекцию("Секция_2");
Иначе
Продолжить;
КонецЕсли;
Ит.ВыбратьСубконто(ВидыСубконто.Договора);
Пока Ит.ПолучитьСубконто(ВидыСубконто.Договора) = 1 Цикл
Договор=Ит.Субконто(ВидыСубконто.Договора);
Ит.ВыбратьСчета();
д_скд="";
д_скк="";
д_скд_к="";
д_скк_к="";

Пока Ит.ПолучитьСчет()=1 Цикл
Если Ит.Счет.Код=сч_1 Тогда
д_скд=Формат(Ит.СКД(),"Ч014.2.,");
д_скк=Формат(Ит.СКК(),"Ч014.2.,");
Иначе
д_скд_к=Формат(Ит.СКД(),"Ч014.2.,");
д_скк_к=Формат(Ит.СКК(),"Ч014.2.,");
КонецЕсли;
КонецЦикла;
Т.ВывестиСекцию("Секция_5")

КонецЦикла;
КонецЦикла;
Нужно выводить только тех контрагентов в которых есть по двум счетам сальдо на конец. А выводит всех контрагентов. На что сменить условие отбора?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.03.2010, 17:13
Ответы с готовыми решениями:

Сальдо на конец месяца отличается от сальдо на начало в расчетках,что делать?Откуда оно и как убрать?
Добрый день,форумчане!:) Сталкиваюсь с такой задачей в первый раз.Начала как обычно начислять з/п...

Сальдо по балансовым счетам
Добрый день! Не подскажите,что нужно изменить в процедуре,что бы выводил остатки ненулевого сальдо...

Получение сальдо
Здравствуйте. Версия программы : 1С 7.7 Комплексная конфигурация, редакция 4.5 (7.70.502). ...

Сальдо дебетовое на начало периода
Пожалуйста, помогите получить остаток на начало периода по счету 41.2 и второму субконто. Если...

Осуществление поиска Сальдо на начало месяца по счету
Здравствуйте! Помогите пожалуйста, я начинаю только изучение языка 1С и у меня появились...

5
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
29.03.2010, 17:26 2
Попробуйте вместо
="";
везде написать
=0;

А вообще алгоритм какой-то мутный
Хотя может это только кажется, потому-что не видно, что осталось за кадром
0
ytty
0 / 0 / 0
Регистрация: 09.08.2008
Сообщений: 42
29.03.2010, 17:53 3
Цитата Сообщение от Hryv
Попробуйте вместо
="";
везде написать
=0;

А вообще алгоритм какой-то мутный
Хотя может это только кажется, потому-что не видно, что осталось за кадром
я уже так пробовала - отображает всех контрагентов!!!
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
29.03.2010, 18:00 4
Ну, вот такое условие точно не работает


Цитата Сообщение от Elle
Если (к_скд<>0) И (к_скк_к<>0) Тогда
уж тогда надо
Если (ПустоеЗначение(к_скд) =0) И (ПустоеЗначение(к_скк_к) = 0) Тогда
0
ytty
0 / 0 / 0
Регистрация: 09.08.2008
Сообщений: 42
29.03.2010, 18:06 5
Цитата Сообщение от vbs
уж тогда надо
Если (ПустоеЗначение(к_скд) =0) И (ПустоеЗначение(к_скк_к) = 0) Тогда
Таки Вы правы)))) спасибо - работает)))
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
29.03.2010, 18:34 6
Правильно Vytfil ругает неявное объявление типов в 1С.
Вот отсюда и сравнение непустой строки с числом 0 :discard:
Конечно, она никогда не будет равна 0 :bequiet:
0
29.03.2010, 18:34
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.03.2010, 18:34

Остатки по счетам
задача: есть 3 счета 012.1 , 012.2 , 10.1 во всех трех ведется учет материалов, их места...

Простой запрос по Счетам
Добрый день! Суть в следующем: 1С 7.7., документ - СчетВходящий, добавлено два реквизита , Срок...

1C 7.7 Запрос на получение остатков по счетам
Добрый день! Так получилось, что пути с семеркой пересеклись впервые. Пишу обработки для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.