Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.93/127: Рейтинг темы: голосов - 127, средняя оценка - 4.93
Tomshyk
0 / 0 / 0
Регистрация: 06.03.2010
Сообщений: 7
1

Вопрос по форме справочника

09.03.2010, 12:19. Просмотров 22942. Ответов 15
Метки нет (Все метки)

Привет Всем!!
Помогите пожалуйста разобраться.
Как програмно реализовать условие. Дан справочник "Номенклатура" с реквизитами в форме справочника "Тип расчета"(связан с Перечислением Типы Расчета со значениями Задается и Рассчитывается), "ЦенаПродажи", "ПроцентНаценки". Надо сделать так чтобы при выборе в реквизите справочника ТипРасчета значения "Задается" поле ввода реквизита справочника "ПроцентНаценки" становилось недоступным.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.03.2010, 12:19
Ответы с готовыми решениями:

Вопрос: О копировании элемента справочника
Есть необходимость, чтобы при копировании элемента справочника "Номенклатура" (конфа ТиС),...

Отображение реквизита справочника в форме
Здравствуйте, интересует как можно реализовать отображение какого либо реквизита справочника при...

Отбор в форме выбора справочника
Есть документ, в нем есть поля контрагент и договор контрагента. Хочу сделать следующее, чтоб при...

О быстром выборе в форме списка справочника
Если в форме списка справочника в 1С 7.7 использовать быстрый поиск, допустим, по наименованию ,и...

Как изменить тип справочника на форме?
Привет! На вызываемой форме как изменить тип справочника? Пытаюсь прописать в ПриОткрытии() ...

15
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
09.03.2010, 12:23 2
Если ТипРасчета = Перечисление.ТипыРасчета.Задается Тогда
Форма.ПроцентНаценки.Доступность(0)
КонецЕсли
0
Tomshyk
0 / 0 / 0
Регистрация: 06.03.2010
Сообщений: 7
10.03.2010, 17:44 3
Да в том то и дело что ввожу код


Процедура СправочникСписокТипРасчетаПриИзменении(Элемент)
// Вставить содержимое обработчика
РеквизитФормыСправочника = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
Если РеквизитФормыСправочника.ТипРасчета = Перечисления.ТипРасчета.Задается Тогда
РеквизитФормыСправочника.ПроцентНаценки.Доступность(0)
КонецЕсли
КонецПроцедуры

А когда открываю справочник в режиме отладки выдает ошибку:

Значение не является значением объектного типа (Доступность)
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
10.03.2010, 18:20 4
Ну так написала бы, что в 8ке работаешь, я для 7.7 пример написал
0
10.03.2010, 18:20
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
10.03.2010, 21:04 5
Эк тебя на семерке заклинило (как и меня). Надо:
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
0
Tomshyk
0 / 0 / 0
Регистрация: 06.03.2010
Сообщений: 7
14.03.2010, 10:32 6
Цитата Сообщение от vbs
Ну так написала бы, что в 8ке работаешь, я для 7.7 пример написал :whoareyou?:
Да и на том спаибо)) буду разбираться

Добавлено:


Цитата Сообщение от Дайнеко
Эк тебя на семерке заклинило (как и меня). Надо:
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
да и с этим кодом ошибку выдает "Значение не является значением объектного типа (Доступность)"
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
14.03.2010, 11:40 7
Цитата Сообщение от Tamchik
Доступность
вроде надо Доступность(параметр)
0
yvkymyotom
0 / 0 / 0
Регистрация: 15.02.2008
Сообщений: 173
15.03.2010, 19:57 8
Цитата Сообщение от Tamchik
РеквизитФормыСправочника.ПроцентНаценки.Доступность = Ложь;
неверно.


Цитата Сообщение от vbs
Доступность(параметр)
верно только для семерки
для восьмерки : ЭлементыФормы.ПроцентНаценки.Доступность = Ложь;
а точнее в вашем случае ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
собственно ТекущиеДанные возвращает ссылку на элемент справочника, а он не визуальный.
0
Дийнеки
0 / 0 / 0
Регистрация: 15.11.2009
Сообщений: 947
18.03.2010, 22:43 9
Цитата Сообщение от evgenyatam
ТекущиеДанные возвращает ссылку на элемент справочника, а он не визуальный.
Замечание принято. Невнимательно посмотрел.
0
Tomshyk
0 / 0 / 0
Регистрация: 06.03.2010
Сообщений: 7
19.03.2010, 11:56 10
Цитата Сообщение от evgenyatam
неверно.

верно только для семерки
для восьмерки : ЭлементыФормы.ПроцентНаценки.Доступность = Ложь;
а точнее в вашем случае ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
собственно ТекущиеДанные возвращает ссылку на элемент справочника, а он не визуальный.
Спасибо канешь за подсказки, но что то не выходит
Процедура СправочникСписокТипРасчетаПриИзменении(Элемент)
// Вставить содержимое обработчика
РеквизитФормыСправочника = ЭлементыФормы.СправочникСписок.ТекущиеДанные;
Если РеквизитФормыСправочника.ТипРасчета = Перечисления.ТипРасчета.Задается Тогда
ЭлементыФормы.СправочникСписок.ПроцентНаценки.Доступность = Ложь;
КонецЕсли
КонецПроцедуры

Все равно выдает ошибку и поле ПроцентНаценки все равно доступно для редактирования
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
20.03.2010, 15:22 11
ЭлементыФормы.СправочникСписок.ТекущаяСтрока.ПроцентНаценки.Доступность = Ложь; ?
0
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
21.03.2010, 03:52 12
ЭлементыФормы.СправочникСписок.ТекущаяСтрока.ПроцентНаценки.РедактированиеТекста = Ложь; Может просто редактирование текста попробовать отрубить?
Может у вас условие не проходит?
0
tomot
0 / 0 / 0
Регистрация: 02.03.2007
Сообщений: 272
21.03.2010, 08:28 13
дак может всетаки видимость у колонки нужно поменять, а не у реквизита?)
Попробуйте: ЭлементыФормы.СправочникСписок.Колонка.имяКолонки.Видимость=Ложь;
0
Wytdomthyr
0 / 0 / 0
Регистрация: 03.06.2009
Сообщений: 116
21.03.2010, 09:39 14
А я думал реквизит надо заблокировать=)
0
tomot
0 / 0 / 0
Регистрация: 02.03.2007
Сообщений: 272
21.03.2010, 13:38 15
Ну доступность). Разницы в синтаксе - минимум). А на отдельную ячейку таблицы помоему накладывать ограничения доступности нельзя ( по крайней мере как на элементы формы) .

Вообще автор виноват сам: ввел людёф в заблуждение, ибо не понимает разницу между формой элемента и формой справочника.
Для формы справочника можно изменить доступность у всей колонки но никак не у отдельной ячейки таблицы, а вот в форме элемента всеми реквизитами нетабличных частей играйте как можете. Вроде нигде ничего не напутал).
0
Tomshyk
0 / 0 / 0
Регистрация: 06.03.2010
Сообщений: 7
28.03.2010, 14:22 16
Цитата Сообщение от tanat
Для формы справочника можно изменить доступность у всей колонки но никак не у отдельной ячейки таблицы, а вот в форме элемента всеми реквизитами нетабличных частей играйте как можете. Вроде нигде ничего не напутал).
Спасибо большое))) а то я сижу с этой ячейкой и думаю почему ничего не получается, а тут вся колонка , теперь буду знать))


Еще раз всем БОЛЬШОЕ СПАСИБО))
0
28.03.2010, 14:22
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.03.2010, 14:22

Динамический список в форме списка справочника
Доброго дня! Стоит задача на форму списка справочника вывести данные из самого справочника и...

Цена и Остаток в форме списка справочника Номенклатура, УТ 11
Здравствуйте! В конфигурации УТ 11 нужно добавить колонки Остаток и Цена на форму списка...

Выбрать элемент справочника на форме выбора
У меня есть документ, я из него открываю форму выбора справочника, при выборе элемента, т.е. при...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.