Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/90: Рейтинг темы: голосов - 90, средняя оценка - 4.83
kymy2010
0 / 0 / 0
Регистрация: 01.03.2010
Сообщений: 5
1

может кто делал?

04.03.2010, 11:59. Просмотров 16293. Ответов 10
Метки нет (Все метки)

Здравствуйте!! Есть справочник Номенклатура куда забивается процент НДС , с нового года он стал 20%, оч нужна внешняя обработка по смене НДС во всех элементах справочника (Ставка НДС - периодический реквизит) , а то бухам приходится это делать руками и они звереют - может кто-нить делал уже?? ООООч прошу :ya_lamo:
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.03.2010, 11:59
Ответы с готовыми решениями:

Очень хочется узнать, кто может так делал?
Версия 1с 8.1 Можно ли сделать, чтобы в документе При выборе и нажатии на...

Кто Ни Будь Так Делал
Вопросик такого плана. Слышал краем уха что можно из БД некоторые таблицы...

Кто нибудь делал перенос сотрудников из .dbf в 1с?
написал код но понять не могу как с полом определиться

Кто может по 1с
Добрый день! Кто может поделится вопросами и ответами для подготовки сдачи...

ПОМОГИТЕ КТО МОЖЕТ
При построении запроса мне нужно: вывести поле неограниченой длинны и при этом...

10
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
04.03.2010, 12:12 2
Какая хоть 1С у вас?
такая обработка в принципе 10 строк от силы
за пару минут сделать можно
0
kymy2010
0 / 0 / 0
Регистрация: 01.03.2010
Сообщений: 5
04.03.2010, 12:28 3
1с 7.7 )) Понимаю, что 7 строк и легко и жду, что будут гнобить))) Но нашла ваш форум и вдруг кто-нить поможет - я не программист))
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
04.03.2010, 12:45 4
дело в том, что "1с 7.7" - этого недостаточно
Надо знать что такое у вас НДС - справочник или перечисление, а может просто число (мало ли что)
как реквизит справочника называется тоже неизвестно

Добавлено: а что за 2 месяца не успели руками перебить?
0
kymy2010
0 / 0 / 0
Регистрация: 01.03.2010
Сообщений: 5
04.03.2010, 12:49 5
НДС - это Справочник - Ставки НДС; реквизит в нем - ставка; В справочнике Номенклатура - реквизит - Ставка НДС;
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
04.03.2010, 12:50 6
В бухгалтерии есть стандартная обработка
SetTaxes
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
04.03.2010, 13:07 7
Если стандартную не найдете, то примерно так


Код
Процедура Сформировать()
СпрНДС = СоздатьОбъект("Справочник.СтавкиНДС");
Если СпрНДС.НайтиПоКоду("")=0 Тогда //внутри кавычек код нужной ставки
Сообщить("Не найдена ставка НДС");
Возврат;
КонецЕсли;

Спр = СоздатьОбъект("Справочник.Номенклатура");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент()=1 Цикл
Если Спр.ЭтоГруппа()=0 Тогда
Спр.СтавкаНДС.Установить(Дата(2010,1,1), СпрНДС.ТекущийЭлемент());
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Но в любом случае советую сначала сделать копию базы
0
kymy2010
0 / 0 / 0
Регистрация: 01.03.2010
Сообщений: 5
04.03.2010, 13:19 8
)))) не успели)) Видели бы вы этих бухгалтеров Ещё вопрос - сохраняю обработку как внешний отчет - когда пытаюсь открыть в 1с - ниче не грузится вообще , форма не появляется - не ругайтесь сильно))) почему это??? :KillMe: и когда в интерфейс добавляю - тоже самое((
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
04.03.2010, 14:01 9
может прав нет?
хотя я точно не понял вопроса
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
04.03.2010, 14:13 10
Цитата Сообщение от Hryv
может прав нет?
хотя я точно не понял вопроса
очень похоже
0
kymy2010
0 / 0 / 0
Регистрация: 01.03.2010
Сообщений: 5
04.03.2010, 14:27 11
с правами все ок)) открываешь внешний отчет в 1с и оно секунду думает и ничего - может код поможет

Перем ТипПоля;


Процедура ОК()
Форма.Параметр.Установить("ОК", 1);
Форма.Параметр.Установить("Дата", Д);
Если ТипПоля = "" Тогда
Форма.Параметр.Установить("Значение", Значение);
ИначеЕсли ТипПоля = "ФЛАЖОК" Тогда
Форма.Параметр.Установить("Значение", Флажок);
ИначеЕсли ТипПоля = "ПОЛЕСОСПИСКОМ" Тогда
Форма.Параметр.Установить("Значение", ПолеСосписком.ТекущаяСтрока());
КонецЕсли;
КонецПроцедуры


Процедура ПриОткрытии()
Если (ТипЗначенияСтр(Форма.Параметр) = "СписокЗначений") Тогда
Реквизит = Форма.Параметр.Получить("Реквизит");
Тип = Форма.Параметр.Получить("Тип");
Счет = Форма.Параметр.Получить("Счет");
НомерСубконто = Форма.Параметр.Получить("НомерСубконто");
Д = Форма.Параметр.Получить("Дата");
ТипПоля = Форма.Параметр.Получить("ТипПоля");
Если ТипПоля = "" Тогда
Если ТипЗначенияСтр(Счет) = "Счет" Тогда
Тип = Счет.ВидСубконто(НомерСубконто);
КонецЕсли;
Форма.Значение.НазначитьТип(Тип);
Значение = Форма.Параметр.Получить("Значение");
Если ТипЗначенияСтр(Значение) = "Справочник" Тогда
Значение.ИспользоватьВладельца(Форма.Параметр.Получить("Владелец"));
Форма.Значение.ВыборГруппы(0);
ИначеЕсли ТипЗначенияСтр(Значение) = "Счет" Тогда
Форма.Значение.ВыборГруппы(0);
КонецЕсли;
ИначеЕсли ТипПоля = "ФЛАЖОК" Тогда
Форма.Значение.Видимость(0);
Форма.ОчиститьЗначение.Видимость(0);
Форма.Текст.Видимость(0);
Форма.Флажок.Видимость(1);
Флажок = Форма.Параметр.Получить("Значение");
ИначеЕсли ТипПоля = "ПОЛЕСОСПИСКОМ" Тогда
Форма.Значение.Видимость(0);
Форма.ОчиститьЗначение.Видимость(0);
Форма.Текст.Видимость(0);
Значения = Форма.Параметр.Получить("ЗначенияСписка");
Для А=1 По Значения.РазмерСписка() Цикл
ПолеСоСписком.ДобавитьЗначение(Значения.ПолучитьЗначение(А));
КонецЦикла;
Форма.ПолеСоСписком.Видимость(1);
ПолеСоСписком.ТекущаяСтрока(Форма.Параметр.Получить("Значение"));
КонецЕсли;
Форма.Заголовок("Реквизит: "+Реквизит);
Иначе
СтатусВозврата(0);
КонецЕсли;
КонецПроцедуры
0
04.03.2010, 14:27
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.03.2010, 14:27

Может кто сталкивался с этой проблемой
Нам выставили счёт за услугу сторонних организаций в феврале, проплатить...

Может кто поможет с реестром Windows
Есть задача. я создаю инсталлер для собственной конфигурации. Хочется чтобы...

народ кто может помочь я связал 1с и MS qutlook
народ кто может помочь я связал 1с и MS qutlook у меня считывает данные из 1с в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru