Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/166: Рейтинг темы: голосов - 166, средняя оценка - 4.83
SyvyrBop
0 / 0 / 0
Регистрация: 14.09.2007
Сообщений: 428
1

Итератор для значения не определен

06.10.2009, 12:42. Просмотров 29963. Ответов 1
Метки нет (Все метки)

Ситуация такая: имеется документ с реквизитом типа Хранилище значений, у документа нет табличной части. как я понял она хранится в хранилищезначений. В основной форме сделано очень просто все значения вбиваются в таблицу значений потом призаписи копирутся сначало в хранилищезначений срабатывает обработка проведения и там делается обход по строкам
прмерно так

Код
    ВыборкаПоЗапросу = ВыборкаДляСозданияДвижений.Получить();
Для Каждого Строка Из ВыборкаПоЗапросу Цикл
Движение = Движения.ЦеныПродажи.Добавить();
Движение.Период = Дата;
Движение.Регистратор = Ссылка;
Движение.Номенклатура = Строка.Номенклатура;
Движение.ДопИзмерение = Строка.ДопИзмерение;
Движение.Единица  = Строка.Единица;
Движение.КатегорияЦен = Строка.КатегорияЦен;
Движение.Цена        = Строка.Цена;
КонецЦикла;
далее повторно делается запись движений:

Код
    Для каждого ТипДвижения Из Движения Цикл
ТипДвижения.Записать();
КонецЦикла;
тоесть все нормально!
я написал обработку по исправлению значений (в документе редактировать записи заприщено написал внешнюю обработку)
с таким кодом при записи:

Код
    Если Не глЗначениеНеЗаполнено(ДокументРедактирования) Тогда
ДокументОбработки=ДокументРедактирования.ПолучитьОбъект();
ВыборкаПоЗапросу = ДокументОбработки.ВыборкаДляСозданияДвижений.Получить().Скопировать();
ДокументОбработки.ВыборкаДляСозданияДвижений=ТЗ.Скопировать();
ДокументОбработки.Записать(РежимЗаписиДокумента.Проведение);
КонецЕсли;
и пишит Итератор для значения не определен!!!!
как решить эту проблему??
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.10.2009, 12:42
Ответы с готовыми решениями:

Опять Итератор
Добрый день. Конфигурация ""Управление торговлей", редакция 10.3...

Итератор и печать
Здраствуйте!У нас на работе общем отделе сменили версию 1С, с 8.0 на 8.2....

Итератор значения не определён
Делаю расчёт пени по кнопке Обновить. При нажатии на кнопку запускается цикл по...

Тип не определен
Здравствуйте, в процедуре выходит ошибка: Тип не определен кол =...

Итератор для значения не определён
И снова привет.:)))) Пытаюсь удалить строку по фамилии... Нажимаю на кнопку...

1
Djotyx
0 / 0 / 0
Регистрация: 20.06.2009
Сообщений: 20
08.10.2009, 15:09 2
А не пробовали через:
ДокументОбработки.ВыборкаДляСозданияДвижений = Новый ХранилищеЗначения(ТЗ);
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.10.2009, 15:09

XDTO - Тип свойства не определен
Всем привет. Камраден, подскажите кто знает. Конфы самопильные. Ситуация:...

Реализовать двусвязный список (list), итератор (iterator) и константный итератор (сonst_iterator) для списка
не могу понять что должно быть результатом. может подскажете примеры?...

Реализовать итератор с параметром типа double для перебора статей с рейтингом больше заданного значения
Только начала разбираться с итераторами,еще не совсем понимаю как их...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru