Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.79/76: Рейтинг темы: голосов - 76, средняя оценка - 4.79
myyroromomtyk
0 / 0 / 0
Регистрация: 17.09.2009
Сообщений: 5
1

Вывод результатов в новом столбце.

08.10.2009, 05:28. Просмотров 13636. Ответов 5
Метки нет (Все метки)

Доброго времени суток. Есть задача - разбить на небольшие интервалы выбранный пользователем через диалог период. На даты программы разбивает правильно. Вопрос по выводу результатов в таблицу.
Для итая=1 по даталист.РазмерСписка Цикл // список содержит начальные даты месяцев.
НомерДаты=ПолучитьЗначение(Итая);
Таб.ВывестиСецию("НомерДаты"); //выводится секция, содержащая переменную НомерДаты
Ит.ВыбратьПериоды;
Ит.ПолучитьПериод(, НомерДаты);
Ит.ВыбратьСубконто;
Пока Ит.ПолучитьСубконто()=1 Цикл
// здесь вычисляется средняя цена за период.
.....................................

Таб.ВывестиСецию("Основная"); //здесь выводится номенклатура и средняя цена
КонецЦикла ;
КонецЦикла;
В итоге получается таблица следующего вида.

дата начала месяца.
номенклатура | средняя цена.

дата начала месяца.
номенклатура | средняя цена.

и т.д.
А нужно чтобы дата начала каждого месяца и результаты по нему выводились в новом столбце.
Например, так.
дата начала месяца. | дата начала месяца.
номенклатура | средняя цена. | номенклатура | средняя цена.

Как вывести результат в новом столбце не хватает воображения. Помогите, пожайлуста.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.10.2009, 05:28
Ответы с готовыми решениями:

Различный вывод результатов в консли запросов и в отчете СКД
Здравствуйте.В Собственной конфигурации 1С 8.3. Делаю отчет на основе запроса: ВЫБРАТЬ...

Вывод результатов в каждом новом консольном окне
Здравствуйте) Меня интересует две вещи: я вот хочу сделать так, чтобы в моем консольном приложении...

Автоматическое изменение даты в новом столбце
Добрый день! Прошу помощи по избитой теме! Сформировал макрос по автоматическому добавлению...

Собрать в новом столбце непустые значения из соседнего
Добрый день. Есть некий список в столбце С, составленный путём ВПР из других листов . и в...

Отображение результатов запроса в другом столбце таблицы
Вот имеется главная страница сайта. Мне нужно чтоб, нажав на ссылку Авторизация и регистрация...

5
thymkfost
0 / 0 / 0
Регистрация: 23.07.2009
Сообщений: 91
08.10.2009, 10:33 2
Для 8-ки вот рабочий пример, на его примере все поймешь:

ТабДок = Новый ТабличныйДокумент;
Секция = ТабДок.ПолучитьОбласть("R1C1");
ТабДок.НачатьАвтогруппировкуКолонок();
Секция.Область("R1C1").Текст = "Параметр";
ТабДок.Вывести(Секция,1,"Группа 1",Ложь);
Для К=1 По 10 Цикл
Секция = ТабДок.ПолучитьОбласть("R1C1");
Секция.Область().Текст = "А"+К;
Секция.Область().ГоризонтальноеПоложение = ГоризонтальноеПоложение.Право;
ТабДок.Присоединить(Секция,2,"Группа 2",Истина);
КонецЦикла;
Секция.Область("R1C1").Текст = "Итого:";
ТабДок.Присоединить(Секция,1,"Группа 2",Ложь);
Секция.Область("R1C1").Текст = "Значение";
ТабДок.Вывести(Секция,1,"Группа 2",Ложь);
Цена = 10; Итог = Цена;
Для К=1 По 10 Цикл
Секция = ТабДок.ПолучитьОбласть("R1C1");
Секция.Область().Текст = Цена;
ТабДок.Присоединить(Секция,2,"Группа 2",Истина);
Цена = Цена + 10;
Итог = Итог + Цена;
КонецЦикла;
Секция.Область("R1C1").Текст = Итог;
ТабДок.Присоединить(Секция,1,"Группа 2",Ложь);
ТабДок.ЗакончитьАвтогруппировкуКолонок();
ТабДок.ИтогиСправа = Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.Показать("Пример использования гор. автогруппировки");
0
kyr
0 / 0 / 0
Регистрация: 04.12.2005
Сообщений: 1,588
08.10.2009, 10:36 3
neiroromantik, не совсем понял - тебе получается нужно чтобы строки присоеденялись не по вертикали, а по горизонтали?
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
08.10.2009, 13:05 4
Я в 7.7 делаю так :
Детализация по периодам устанавливается в вариантах : день, неделя, декада, месяц, квартал, год
Далее вывожу итоги в ТЗ и добавляю к ней колонку НомерПериода, заполняю ее процедуркой, вычисляющей его значение.
Для дня и года тривиально, для месяца - только учесть случай, когда даты начала и конца в разных годах
Далее группирую ТЗ, перебираю ее и присоединяю горизонтальные секции столько раз, сколько нужно
0
myyroromomtyk
0 / 0 / 0
Регистрация: 17.09.2009
Сообщений: 5
08.10.2009, 14:01 5
Спасибо всем за рекомендации. Ссори, нужно было сразу написать, что работаю с 7-кой. Нужно, чтобы строки выводились слева направо в таком порядке.
Месяц1 Месяц2 Месяц 3 и т.д.
Номенклатура1 Цена Цена Цена
Номенклатура2 Цена Цена Цена
НоменклатураN Цена Цена Цена

Если не трудно, напишите сразу код, который будет это делать. Сейчас уже времени нет вникать в тонкости. Нужно еще по периодам
написать код для вариантов выбора. В данный момент получить нужный результат я пытался так.
Таб.ВывестиСекцию("гор|верт");
Для итая=1 по даталист.РазмерСписка Цикл // список содержит начальные даты месяцев.
НомерДаты=ПолучитьЗначение(Итая);
Таб.ВывестиСецию("НомерДаты"); //выводится секция, содержащая переменную НомерДаты
Ит.ВыбратьПериоды;
Ит.ПолучитьПериод(, НомерДаты);
Ит.ВыбратьСубконто;
Пока Ит.ПолучитьСубконто()=1 Цикл
// здесь вычисляется средняя цена за период.
.....................................
Таб.ПрисоединитьСекцию("гор|верт");

КонецЦикла ;
КонецЦикла;
В итоге все выводится в одну строку с огромным числом колонок (
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
08.10.2009, 14:33 6
Посмотри обработку для торговли - в ней указано, как вычисляется нужный период.
Идеология станет понятна, для бухгалтерии легко сможешь адаптировать
0
08.10.2009, 14:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.10.2009, 14:33

Поиск в столбце и запись результатов на другой лист
Добрый день! Нужен макрос, который работает через 'элемент управления формы' (поле) Суть в том...

Как исключить из результатов запроса записи с определенным значением в одном столбце?
день добрый! подскажите как можно реализовать: нужно выбрать все записи из базы рецептов но...

Вывод текста в новом UI (Unity 5)
Добрый день помогите, уже второй день не могу разобраться. У меня в скрипте есть переменная тина...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru