Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.87/70: Рейтинг темы: голосов - 70, средняя оценка - 4.87
SyvyrBop
0 / 0 / 0
Регистрация: 14.09.2007
Сообщений: 428
1

Простой запрос с условием

28.09.2009, 14:34. Просмотров 12692. Ответов 7
Метки нет (Все метки)

Подскажите как исправить этот запрос:

Код
    Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ШтрихКод", ШК);
Запрос.Текст = "
|ВЫБРАТЬ
|   ШтрихКоды.Ссылка
|ИЗ
|   Справочник.ШтрихКоды КАК ШтрихКоды
|ГДЕ
|   ШтрихКоды.Наименование = &ШтрихКод
|";

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();

Если Выборка.Следующий() Тогда
Возврат Выборка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;
где ШК - это наименование справочника...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.09.2009, 14:34
Ответы с готовыми решениями:

Запрос с условием
Добрый денёк. Есть DBF-ка, и есть справочник, нужно выбрать (найти) те записи которых нет в...

Запрос с условием
Есть справочник клиенты, с реквизитами Имя, Фамилия, а так же документ с реквизитами Имя, Фамилия с...

запрос с условием по тексту
Имеется ситуация - написал обработку загрузки номенклатуры в из одной ТИС 7.7 в другую Тис 7.7....

простой запрос
есть простенький запрос |Код = Справочник.Номенклатура.Код; |Наименование =...

Простой запрос по Счетам
Добрый день! Суть в следующем: 1С 7.7., документ - СчетВходящий, добавлено два реквизита , Срок...

7
thymkfost
0 / 0 / 0
Регистрация: 23.07.2009
Сообщений: 91
29.09.2009, 10:22 2
мб так:
|ГДЕ | ШтрихКоды.Наименование = &ШтрихКод.Наименование
или
|ГДЕ | ШтрихКоды.Ссылка= &ШтрихКод.Ссылка
0
hos
2 / 2 / 0
Регистрация: 06.11.2012
Сообщений: 9
29.09.2009, 10:56 3
Bap пробелы в наименовании посмотри. Точнее сократи пробелы
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
29.09.2009, 23:31 4
Может, если поле одно, то и так сойдет, а вообще:
Если Выборка.Следующий() Тогда
Возврат Выборка.ссылка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
30.09.2009, 00:57 5
ПС. А не устроит ? :
возврат Справочники.ШтрихКоды.НайтиПоНаименованию(ШК);
0
SyvyrBop
0 / 0 / 0
Регистрация: 14.09.2007
Сообщений: 428
30.09.2009, 14:48 6
Хочется через запрос! Сейчас у меня и так по наименованиею ищит!
0
puh14
0 / 0 / 0
Регистрация: 07.07.2008
Сообщений: 1,401
30.09.2009, 14:59 7
Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ШтрихКод", ШК);
Запрос.Текст = "
|ВЫБРАТЬ
| ШтрихКоды.Ссылка
| ШтрихКоды.Наименование как СтрокаПоиска
|ИЗ
| Справочник.ШтрихКоды КАК ШтрихКоды
|ГДЕ
| Строкапоиска ПОДОБНО ""%"" + &ШтрихКод + ""%""
|";

Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
Возврат Выборка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;



что-то такое... А то с пробелами действительно нехорошо может получится. Наименование в отдельную переменную вытащил на всякий случай - мож и с ШтрихКоды.Наименование прокатит.
0
umkmowm181538
0 / 0 / 0
Регистрация: 24.12.2008
Сообщений: 1,399
30.09.2009, 21:31 8
Цитата Сообщение от Bap
Хочется через запрос! Сейчас у меня и так по наименованиею ищит!
Сомневаюсь, что будет быстрее. Поиск одного элемента по строке через запрос это очень странно, имхо.
0
30.09.2009, 21:31
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.09.2009, 21:31

Запрос с условием сравнения значений перечисления с именем текущего пользователя
1С:Предприятие 8.3 (8.3.6.1999). Управляемые формы. Здравствуйте. Есть справочник "Сотрудники" с...

Запрос с множественным условием
Конфигурация самописная, не пытайтесь понять где это и что это ) просто вопрос Есть РС в котором...

Запрос с заполнением данных( с двойным условием выборки)
Доброго времени суток. Есть задача следующего плана: Составляется документ "Разность...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru