Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.61/207: Рейтинг темы: голосов - 207, средняя оценка - 4.61
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
1

документ в журнале проводки не отображаеться

15.09.2009, 13:43. Просмотров 37364. Ответов 31
Метки нет (Все метки)

Здраствуйте!

Я к вам обращаюсь за помощью!

Создовая новый документ для авто сервисса "заказНарядыАкты" в конфигурации 1с 7,7 редакции 4,5(7.70.483).
Я придусмотрел как я думал всё!
Но послего его тестирования. Вскрылась недоработка, решения которой я не знаю!
Суть праблеммы при провидения документа - в журнале операции он отображается но в калонке сумма и содержание пусто. В журнале проводок он вовсе не отображает ни чего!

Я сам только не давно стал изучать 1с и всех тонкостей не знаю!
MD программы можно скачать сдесь http://files.mail.ru/K6ZOXF
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.09.2009, 13:43
Ответы с готовыми решениями:

1с 7.7 как в журнале РН, сразу открывать значение в графе "документ основание"
Добрый день, имеется 1с 7.7 и журнал расходных накладных. При двойном нажатии у нас естественно...

Создание общей проводки на документ
Здравствуйте, помогите пожалуйста с заданием. Документ Расходная накладная делает проводки Дт...

Нужна схема электро проводки.Духовой шкаф BOSCH HBN43W350/03 FD8511 334682, Нужна схема электро проводки
Нужна схема электро проводки.Духовой шкаф BOSCH HBN43W350/03 FD8511 334682.Обрезаны провода на...

В биосе не отображаеться ЖД
В биосе не отображаеться ЖД (seagate st3500320as sata II). По звуку и теплоотдачи видно что ЖД...

Капча не отображаеться
Добрый день у меня проблема с капчей для входа в личный кабинет, вся проблема в том что капча не...

31
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
15.09.2009, 13:51 2
а документ проводится вообще?

1. В документе должна быть установлена птичка "бухгалтерский учет"
2. В модуле документа должна быть процедура ОбработкаПроведения()
3. ОбработкаПроведения() должна создавать проводки и сохранять операцию: (Операция.Записать())
0
kyr
0 / 0 / 0
Регистрация: 04.12.2005
Сообщений: 1,588
15.09.2009, 14:13 3
я бы еще добавил пункт
4. В обработке проведения Операция.Сумма = ПеременнаяСодержащаяСуммуОперации;
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
16.09.2009, 11:30 4
Цитата Сообщение от Hryv
а документ проводится вообще?

1. В документе должна быть установлена птичка "бухгалтерский учет"
2. В модуле документа должна быть процедура ОбработкаПроведения()
3. ОбработкаПроведения() должна создавать проводки и сохранять операцию: (Операция.Записать())

там и так была процедура ОбработкаПроведения() но я всё ровно ещё кое что подделал и вот что получилось:
вроде всё должно работать НО документ ЗаказНарядАкт отображаеться в журнале операции но у него нет ни одной проводки! когда нажимаешь провести он говорит что документ проведён! Но ни одного счёта он при этом не выстовляет!
по это му я как считаю что и из за это в калонке суммы не выстовляеться сумма документа!

Процедура ОбработкаПроведения(ВидыДвижений)

// Проверка заполненности обязательных реквизитов.
Если глВсеРеквизитыДокументаЗаполнены(Контекст,
"Фирма,Склад,Валюта,Контрагент,Договор")=0 Тогда
Возврат;
КонецЕсли;

Если (Склад.РозничныйСклад = 1) Тогда
глНеПроводить(Контекст,"Документ """+ глНазваниеДокументаВЖурнале(Контекст)+""" можно
|оформлять только с оптового склада!");
Возврат;
КонецЕсли;

// Проведение по регистрам оперативного учета.
Если (ПустоеЗначение(ВидыДвижений) = 1) ИЛИ (Найти(ВидыДвижений, "Регистр") <> 0) Тогда
ПроведениеПоРегистрам();

Если СтатусВозврата() = 0 Тогда
Возврат;
КонецЕсли;
КонецЕсли;

Если ДатаДок >= глДатаПоПриказу147 Тогда
СкорретироватьДвиженияПартийПоАвансам();
КонецЕсли;

глПриПроведении(Контекст, ВидыДвижений);

Попытка
Операция.Записать();
Исключение
глНеПроводить(Контекст, ОписаниеОшибки());
КонецПопытки;

КонецПроцедуры //ОбработкаПроведения()

короче проблему это ен решило!



Цитата Сообщение от KiR
я бы еще добавил пункт
4. В обработке проведения Операция.Сумма = ПеременнаяСодержащаяСуммуОперации;
А вот эту мысль я не совсем понял!
Можно поточнее!???
0
16.09.2009, 11:30
puh14
0 / 0 / 0
Регистрация: 07.07.2008
Сообщений: 1,401
16.09.2009, 11:40 5
ага - у тебя по сути все движения в другие процедуры выведены, часть из них в глобальнике. весь модуль документа покажи.
и из глобальника глПриПроведении(Контекст, ВидыДвижений);
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
16.09.2009, 11:47 6
Судя по коду твой документ не создает проводок, а только движения по регистрам
(хотя точно не известно что делают вызываемые процедуры)

Кинь сюда вот такой скриншот своего документа
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
16.09.2009, 11:48 7
За проведение документа ЗаказНарядАкт
отвечает процедура глобального модуля
глПриПроведении, в которой, в свою очередь, вызывается
глЗаполнитьОперациюПроводками
Если переменная ТаблицаПроводок заполнена правильно, то и операция с проводками будет создана корректно, и Сумма операции будет присутствовать
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
16.09.2009, 11:52 8
Цитата Сообщение от puh14
ага - у тебя по сути все движения в другие процедуры выведены, часть из них в глобальнике. весь модуль документа покажи.
и из глобальника глПриПроведении(Контекст, ВидыДвижений);
Вот смотри: глобальный модуль
Посмотреть вложение GlobalModyl.txt

И модуль формы
Посмотреть вложение ZakazNarydAkt.txt
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
16.09.2009, 11:58 9
В документе ЗаказНарядАкт
ошибка в модуле формы - вместо переменной
ОблагаетсяЕНВД
надо вставить
_ОблагаетсяЕНВД
и не хватает еще одного
КонецЕсли в процедуре ПриИзмененииСклада
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
16.09.2009, 12:03 10
Цитата Сообщение от Hryv
Судя по коду твой документ не создает проводок, а только движения по регистрам
(хотя точно не известно что делают вызываемые процедуры)

Кинь сюда вот такой скриншот своего документа

0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
16.09.2009, 12:08 11
И еще проверь, как заполнен реквизит
Фирма.ЮрЛицо.ФормированиеПроводок
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
16.09.2009, 12:29 12
tarakan, птички правильно стоят
проверяй тогда саму программу: то что vbs тебе пишет
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
16.09.2009, 14:21 13
Цитата Сообщение от vbs
В документе ЗаказНарядАкт
ошибка в модуле формы - вместо переменной
ОблагаетсяЕНВД
надо вставить
_ОблагаетсяЕНВД
и не хватает еще одного
КонецЕсли в процедуре ПриИзмененииСклада
Я сделаю проще уберу все эти процедуры!
Но веть не в этом праблемма! ты сам это понимаешь!




Цитата Сообщение от vbs
И еще проверь, как заполнен реквизит
Фирма.ЮрЛицо.ФормированиеПроводок
а вот этот пункт я не совсем понял?
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
16.09.2009, 14:38 14
У Фирмы есть реквизит ЮрЛицо (Справочник.СвоиЮрЛица), для проведения у этого ЮрЛица должен быть установлен режим формирования проводок
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
21.09.2009, 14:41 15
Цитата Сообщение от vbs
У Фирмы есть реквизит ЮрЛицо (Справочник.СвоиЮрЛица), для проведения у этого ЮрЛица должен быть установлен режим формирования проводок

Так так подожди!
Во первых доукмент Реализация проводиться

А во вторых Где это режим я его найти не могу!??? :(
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
21.09.2009, 15:18 16
Цитата Сообщение от vbs
За проведение документа ЗаказНарядАкт
отвечает процедура глобального модуля
глПриПроведении, в которой, в свою очередь, вызывается
глЗаполнитьОперациюПроводками
Если переменная ТаблицаПроводок заполнена правильно, то и операция с проводками будет создана корректно, и Сумма операции будет присутствовать
Залезь в отладчик и пройдись по процедуре глПриПроведении
Если не поможет, зашли хотя бы неполную базу (если это не коммерческая тайна), а то возишься уже неделю, а там наверняка все не так сложно
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
23.09.2009, 12:03 17
да!:(
вот ссылка на базу http://files.mail.ru/ZD6DO9
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
23.09.2009, 14:12 18
1. В модуле формы ЗаказНарядАкт есть синтаксические ошибки
Для их устранения заменить в тексте процедуры ПриИзмененииСклада()

ОблагаетсяЕНВД на _ОблагаетсяЕНВД
И перед
КонецПроцедуры // ПриИзмененииСклада()
Добавить
КонецЕсли
2. КодОперации в ЗаказНарядАкт не заполнен.
Поскольку у тебя один склад, то процедура ПриИзмененииСклада() ни разу не отрабатывает - а КодОперации устанавливается именно в ней.
Этот код
Если _ОблагаетсяЕНВД = 1 Тогда
КодОперации = глКО.РозничнаяПродажаЕНВД;
Иначе
КодОперации = глКО.РозничнаяПродажа;
КонецЕсли;
стоит перенести в Процедуру ВводНового()
Какой КодОперации поставить - на свое усмотрение. Но именно из-за пустого значения КодОперации не формируется ТаблицаПроводок в глобальном модуле
3. Если уж хотел делать по аналогии с Реализацией (а не с РеализацияРозница - ни одного документа в базе нет и проведение его совсем не такое !)
то измени строку 13025 в глобальном модуле на
ВидДокумента="Реализация";
Проводки будут сформированы по аналогии с Реализацией.
В общем, именно там формируется таблица проводок по документу.
Но, похоже, это не твой случай (проводки явно будут не те).
Попробуй вместо вызова из модуля документа "ЗаказНарядАкт" процедуры ГлПриПроведении
сам написать проводки по типу (это только для примера)

Операция.НоваяПроводка();
Операция.Кредит.Счет = СчетПоКоду(НужныйСчет);
Операция.Кредит.Контрагенты = Контрагент;
Операция.Кредит.Договоры = Договор;
Операция.Сумма = Сумма;
Операция.Записать();
и т.д.
А вот какие счета и субконто задействовать в проводках - это к бухгалтерам, иначе получишь "Вещь в себе"
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
23.09.2009, 22:45 19
Кстати, и НДС у тебя не считается, если НеЕНВД = 0
0
torokom
0 / 0 / 0
Регистрация: 28.08.2009
Сообщений: 56
24.09.2009, 11:05 20
Хм.... Всё сделал кроме 2ого пункта я перенёс процедуру!
только не понял где ставить год операции!?и что за код опирации?

Да и последний пункт мне совсем не нравиться!
Ведь формирования проводок и так должна проводиться в глобальном модуле!

Да и я спрашивал у бухгалтера! она сказала что проводки должны быть всё теже что и в ДокументеРеализация.
Как она мне обьяснила что там так же идёт списания товара! и так же идут продажи услуг!
0
24.09.2009, 11:05
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.09.2009, 11:05

Не отображаеться сайт
Шаблон Newspress. Хотел изменить отображение метаданных под заголовком и видимо что то лишнее...

Не отображаеться диск д и е
При включении компа виден только локальный диск с. Для того чтобы появились остальные диски ( д и е...

некоректно отображаеться изображение
Суть такая, изображения по задумке на главной странице должны былть круглые, это я добился...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru