Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.62/77: Рейтинг темы: голосов - 77, средняя оценка - 4.62
mMokz
0 / 0 / 0
Регистрация: 25.09.2009
Сообщений: 5
1

Проводки документов

28.09.2009, 13:00. Просмотров 13952. Ответов 8
Метки нет (Все метки)

Добрый день! Поставили задачу но так глубоко с 1С еще незнаком.

Стандартная Конфигурация Бухгалтерия 7.7 редакция 4.5

Документ "Услуги сторонних организаций" требуеться чтобы при Субконто1 = некоторым наименованиям с видом "Прочие операционные доходы и расходы" проводкой по налоговому учету падало на счет Н01.05 (Прямые расходы)...

Наведите на мысль либо ткните на мануал который можно покурить
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.09.2009, 13:00
Ответы с готовыми решениями:

Проводки документов
Что значит провести документы 1С оперативно и не оперативно?

Проводки
Помогите создать конфигурацию на основание данных проводок Дт 10 Кт 60...

Не отображаются проводки
проблема в следующем: я провожу документы (пример выписки банка)у меня написано...

Пропали проводки
Добрый день! В программе комплексная автоматизация пропали проводки в...

7.7 Сложные проводки
Всем доброго дня! Никогда не пользовалась сложными проводками, а тут решила...

8
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
28.09.2009, 13:10 2
Изучай в модуле документа процедуру

СформироватьПроводкиДляЦелейНалоговогоУчета(ОбъектыАналитикиНУ, СтоимостьУслуг, Услуга)
0
mMokz
0 / 0 / 0
Регистрация: 25.09.2009
Сообщений: 5
28.09.2009, 14:25 3
Вот кусок кода


Если Субконто1.ВидПрочихДоходовИРасходов=Перечисление.ВидыПрочихДоходовИРасходов.Проч
иеОперационныеДоходыРасходы Тогда
ОбъектыАналитикиНУ.Установить("Счет", СчетПоКоду("Н01.5"));
ОбъектыАналитикиНУ.Установить("ВидыНоменклатуры", Субконто1);
ОбъектыАналитикиНУ.Установить("ГруппыВидыРасходов", Перечисление.ВидыРасходов.ПрямыеРасходы);
КонецЕсли;
но при запуске выдает ошибку Значение не представляет агрегатный объект (ВидПрочихДоходовИРасходов)

Каким образом можно узнать что Субконто1 при проводке именно то
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
28.09.2009, 15:20 4
Скорее всего Субконто1 пустое, либо другого типа, чем вы ожидаете и у Субконто1 нет такого реквизита ВидПрочихДоходовИРасходов

Можно проверить пройдя в отладчике
0
mMokz
0 / 0 / 0
Регистрация: 25.09.2009
Сообщений: 5
29.09.2009, 09:29 5
Дело в том что Субконто1 является реквизитом неопределенного типа табличной части документа, каким образом можно узнать что значение этого реквизита (в данной ситуации это Справочник ПрочиеДоходыИРасходы) именно того вида

Субконто1.ВидПрочихДоходовИРасходов = Перечисление.ВидыПрочихДоходовИРасходов.ПрочиеОперационныеДоходыРасходы
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
29.09.2009, 10:50 6
1 вариант


Код
Попытка
//Ваш код
Исключение
//ничего или какой-то код, когда Субконто1 не имеет реквизита ВидПрочихДоходовИРасходов
Конец попытки;
2 вариант


Код
Если ТипЗначения(Субконто1)=11 Тогда // то есть это Справочник
Если Субконто1.Вид()="ПрочиеДоходыИРасходы" Тогда
Если ПустоеЗначение(Субконто1)=0 Тогда
//ваш код
КонецЕсли;
КонецЕсли;
КонецЕсли;
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
29.09.2009, 12:49 7
Или изначально проверить Субконто1 на Непустое значение
0
Hryv
0 / 0 / 0
Регистрация: 24.07.2008
Сообщений: 658
29.09.2009, 13:26 8
vbs, если


Цитата Сообщение от nMagz
Субконто1 является реквизитом неопределенного типа
то чисто теоретически Субконто1 может быть строкой или числом и не быть пустым
Тогда проверка на ПустоеЗначение ничего полезного не даст, и для полной надежности ее не хватит
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
29.09.2009, 13:32 9
Цитата Сообщение от Hryv
Тогда проверка на ПустоеЗначение ничего полезного не даст, и для полной надежности ее не хватит
Да, пожалуй, погорячился, невнимательно прочитал.
Тип значения, конечно, важнее
0
29.09.2009, 13:32
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.09.2009, 13:32

Двойные Проводки
Здравствуйте! Есть простой документ в 1сv8.2 с табличной частью. В...

сумма проводки
Народ, подскажите, пожалуйста, такой вопрос Документ у меня формирует проводки...

Проводки в 1c7
Здраствуйте. Работаю в конфигураторе 1с7, конфигурация "Бухгадтерский Учёт для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru