Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.82/68: Рейтинг темы: голосов - 68, средняя оценка - 4.82
ytyysh747
0 / 0 / 0
Регистрация: 24.09.2009
Сообщений: 6
1

Помогите новичку!

28.09.2009, 11:01. Просмотров 12272. Ответов 4
Метки нет (Все метки)

1С 7.7 Конфигурация "Бухгалтерский учет, редакция 4.5" 7.70.504
В документе "Отгрузка товаров, продукции" в пункте "Налоги" можно выбрать только 2 пункта из 4-х: "Без налогов" и "НДС сверху".
Как сделать, чтобы выбирались все пункты справочника "Варианты расчета налогов"? Как например в документе "Поступление ОС"...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.09.2009, 11:01
Ответы с готовыми решениями:

Помогите новичку!
1. Где в 1с бухгалтерия выставляются ставки по налогам? 2. Что делать если в 1с бухгалтерия не...

Помогите новичку
Добрый день всем! При попытке создать новый документ или отчет, не хочет записывать конфигурацию -...

Помогите новичку
Встал вопрос об автоматизации заполнения ТТН. Так как я столкнулся с программированием 1с впервые и...

Помогите новичку
Всем привет!! я только проштудировал два самоучителя =) нехотелось бы на етом останавливаться взял...

помогите новичку
1с Производство 7.7 Надо сделать заполнение документа методом подбора, написал следующий код....

4
ytyysh747
0 / 0 / 0
Регистрация: 24.09.2009
Сообщений: 6
28.09.2009, 13:03 2
Выкладываю текст процедуры "ПриВыбореВариантаРасчетаНалогов()" из модуля формы документа, которая вызывается при раскрытии списка "Вариант расчета налогов". Идентификатор этого поля "ВариантРасчетаНалогов".

// ПриВыбореВариантаРасчетаНалогов()
//
// Вызывается из формул элементов диалога:
// Поле ввода "ВариантРасчетаНалогов".
//
// Описание:
// Пересчитывает суммы в документе при смене варианта расчета налогов.
//
Процедура ПриВыбореВариантаРасчетаНалогов()

Если ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов Тогда
Возврат
КонецЕсли;

Если КоличествоСтрок() > 0 Тогда
Ответ = Вопрос("Пересчитать суммы налогов в существующих строках
|табличной части (суммы налогов будут
|обновлены в соответствии с выбранным вариантом)?", "Да+Нет+Отмена");
Если Ответ = "Да" Тогда

ОбщееКоличество = КоличествоСтрок();
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
РассчитатьНалоги();
Состояние("Обработано: " + Окр(НомерСтроки/ОбщееКоличество*100, 0, 1) + "%");
КонецЦикла;

ИначеЕсли Ответ = "Отмена" Тогда
ВариантРасчетаНалогов = ТекущийВариантРасчетаНалогов;
КонецЕсли;

КонецЕсли;
УчитыватьНП = глПризнакУчетаНалога(Контекст, "НП");
УчитыватьНДС = глПризнакУчетаНалога(Контекст, "НДС");
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1 Цикл
НДС = ?(УчитыватьНДС = 0, 0, НДС);
НП = ?(УчитыватьНП = 0, 0, НП);
КонецЦикла;
Форма.НДС.Видимость(УчитыватьНДС);
Форма.НП.Видимость(УчитыватьНП);

КонецПроцедуры // ПриВыбореВариантаРасчетаНалогов()

Также в модуле формы есть процедура "ВариантРасчетаНалогов()", название которой совпадает с идентификатором.

Выкладываю текст этой процедуры:

// ВариантРасчетаНалогов()
//
// Вызывается из формул элементов диалога:
// Нет.
//
// Описание:
// Подбирает вариант расчета налогов.
//
Процедура ВариантРасчетаНалогов(ВРН)
Если (ВРН.СтавкаНП.Ставка = 0) и
(ВРН.СтавкаНДС.Ставка = 0) Тогда
ВариантРасчетаНалогов = ВРН;

Иначе // попробуем найти подходящий из существующих вариантов расчета налогов

СпрВариант = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
СпрВариант.ВыбратьЭлементы();
Пока СпрВариант.ПолучитьЭлемент() = 1 Цикл

Если ((ВРН.СтавкаНДС.Ставка = 0)
и (СпрВариант.СтавкаНДС = ВРН.СтавкаНДС)
и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС))

или ((ВРН.СтавкаНДС.Ставка <> 0)
и (СпрВариант.СтавкаНДС.Выбран() = 0)
и (СпрВариант.СуммаВключаетНДС = ВРН.СуммаВключаетНДС)) Тогда

Если ((ВРН.СтавкаНП.Ставка = 0)
и (СпрВариант.СтавкаНП = ВРН.СтавкаНП)
и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП))

или ((ВРН.СтавкаНП.Ставка <> 0)
и (СпрВариант.СтавкаНП.Выбран() = 0)
и (СпрВариант.СуммаВключаетНП = ВРН.СуммаВключаетНП)) Тогда

ВариантРасчетаНалогов = СпрВариант.ТекущийЭлемент();
Прервать;
КонецЕсли;
КонецЕсли;

КонецЦикла;

КонецЕсли;
// Форма.НДС.Видимость(УчитыватьНДС);
// Форма.НП.Видимость(УчитыватьНП);
КонецПроцедуры // ВариантРасчетаНалогов()

Други!!!!!!!!!!!!!
ПОДСКАЖИТЕ ГДЕ КОПАТЬ!!!
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
28.09.2009, 13:21 3
В расходной накладной допускается выбор только тех вариантов налогов, где ставка = 0,
Т.е, если в справочнике "ВариантыРасчетаНалогов" явно указана ставка, то данный элемент не попадает в список
допустимых вариантов для выбора.
Возможный подход - в справочнике "ВариантыРасчетаНалогов" поставить переключатель в вид "Использовать ставку из справочника"
0
ytyysh747
0 / 0 / 0
Регистрация: 24.09.2009
Сообщений: 6
28.09.2009, 14:13 4
Для какого налога переключатель поменять?
У меня переключатель стоит на пункте "Использовать ставку из справочника" только для "НДС сверху"...
Остальные : "Без налогов", "НДС в сумме 18%" и "НДС Сверху 18%" - переключатель стоит в "Использовать ставку...."

Понял!!!!
Теперь пункт появляется ...
Сейчас буду смотреть как считать будет....

;) Работает..Но налоги не пересчитывает... :(
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
28.09.2009, 14:35 5
Цитата Сообщение от iliych747
Работает..Но налоги не пересчитывает
Это - вряд ли
0
28.09.2009, 14:35
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.09.2009, 14:35

Помогите новичку
Есть справочник, в котором созданы несколько групп, глубина каждой группы 5 уровней. Нужно создать...

помогите новичку
Всем привет! недавно заинтересовался платформой 1С предприятие 8.0 помогите пожалуйста где можно...

Помогите новичку!
Я в 1С не шурупаю, и стараюсь туда не лазить, но сталкнулся с такой проблемкой! Мне нужно создать...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru