Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.93/82: Рейтинг темы: голосов - 82, средняя оценка - 4.93
ky4r
0 / 0 / 0
Регистрация: 25.07.2009
Сообщений: 29
1

Внешний отчет по справочнику

28.07.2009, 15:27. Просмотров 14858. Ответов 9
Метки нет (Все метки)

Вопрос вот в чем:
есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь ему подчинен справочник условия договора аренды...
вся информация в отчете берется из "условия договора аренды"...и теперь инфо для одного столбца должна браться из "контрагенты"
что делаю я:
в запрос добавляю строку


Код
Контрагент = Справочник.Контрагенты.Наименование
и в таблице в нужной ячейке прописываю Запрос.Контрагент

но при выводе отчета ячейка контрагент пуста...в чем косяк?

вот весь код:


Код
//*******************************************
Процедура Проверить_Дату() //Проверка заданного периода
Если НачДата>КонДата Тогда
Предупреждение("Неправильно задан период формирования отчета!"+РазделительСтрок+
"Дата начала больше даты окончания периода.");
КонецЕсли;
КонецПроцедуры

Процедура Сформировать()
Перем Запрос, Таб, ТекстЗапроса, Итер, Спр;
Проверить_Дату();
Запрос = СоздатьОбъект("Запрос");   //Запрос к справочнику
ТекстЗапроса = "
|Контрагент = Справочник.Контрагенты.Наименование;
|Аренда = Справочник.УсловияДоговораАренды.ТекущийЭлемент;
|ТорговаяТочка = Справочник.УсловияДоговораАренды.ТорговаяТочка;
|Площадь = Справочник.УсловияДоговораАренды.Площадь;
|СуммаОплаты = Справочник.УсловияДоговораАренды.СуммаОплаты;
|ДатаНачала = Справочник.УсловияДоговораАренды.ДатаНачалаДействия;
|ДатаКонца = Справочник.УсловияДоговораАренды.ДатаКонцаОплаты;
|Комментарий = Справочник.УсловияДоговораАренды.Комментарий;
|Группировка ТорговаяТочка Упорядочить по ТорговаяТочка.Наименование без групп;
|";
Спр = СоздатьОбъект("Справочник.УсловияДоговораАренды");
Запрос.Выполнить(ТекстЗапроса);
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию ("Шапка");
Итер = 0;
Пока Запрос.Группировка(1) = 1 Цикл
Если (НачДата<= Запрос.ДатаНачала) И (Запрос.ДатаКонца<=КонДата) Тогда  //Вывод договоров соответствующих периоду
Таб.ВывестиСекцию("Строка");
Итер = Итер + 1 ;
КонецЕсли;
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,0,0);
Таб.ПараметрыСтраницы(2,,,,,,,,,1);
Если Итер > 0 Тогда
Таб.Показать();
Иначе
Предупреждение ("Нет договоров на данный период");
КонецЕсли;

КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.07.2009, 15:27
Ответы с готовыми решениями:

Отчет по справочнику Цены
Доброго времени суток всем читающим сие. У меня возникла проблема с казалось бы простой задачей...

Упр. приложение. Простой отчет по справочнику
Помогите пожалуйста! Покажите отчет по справочнику Контрагенты. Должен выбираться номер бригады и...

Внешний отчет 1С 8.1
Народ, помогите!!!! работаю в 1С 8.1 &quot;Управление торговлей&quot;, в программировании совершенно не шарю....

Не работает внешний отчет
1С:Бухгалтерия 8.2 Создаю внешний отчет для выгрузки документов Списание с расчетного счета в...

Составить внешний отчет 1с-8.2
Ребята, подскажите последовательность действий для создания внешнего отчета. Реализация по...

9
kyr
0 / 0 / 0
Регистрация: 04.12.2005
Сообщений: 1,588
28.07.2009, 15:36 2
во-первых можно отладчиком посмотреть содержит не пустое ли значение у Запрос.Контрагент. скорее всего пустое. тогда хотя бы посмотрнеть тип. но мне кажется строчка неверно добавлена в запрос.
0
ky4r
0 / 0 / 0
Регистрация: 25.07.2009
Сообщений: 29
28.07.2009, 16:03 3
а чем неверно такое добавление в запрос?
0
kyr
0 / 0 / 0
Регистрация: 04.12.2005
Сообщений: 1,588
28.07.2009, 18:17 4
сейчас с ходу не скажу - эт посмотреть в програме надо. но кое что в коде вызывает у мя неуверенность... отладчиком проверено?
P.S. еще можно воспользоваться конструктором запросов...
0
vbs
0 / 0 / 1
Регистрация: 22.06.2013
Сообщений: 9
28.07.2009, 19:24 5
Цитата Сообщение от ge4r
а чем неверно такое добавление в запрос?
Непонятно, с какой радости значение "контрагент" будет попадать в запрос
Навскидку, в запросе его нужно обозначить как владельца договора аренды или что-то в этом роде
0
ottyxyy
0 / 0 / 0
Регистрация: 27.04.2008
Сообщений: 371
29.07.2009, 03:37 6
Мне кажется что лутше сделать что то типа запроса в запросе. Как я понимаю связь идет примерно такая Контрагент-> Договор->Торговая точка. Что мешает сделать запрос по контрагентам в этом запросе запрос по договорам с тем условием что договор принадлежит текущему контрагенту а в потом внутри запроса по договарам запрос по торговым точкам связана с текущим договором . В результате будет таблице контрогентов у которых есть договора у которых есть торговые точи.
0
hos
2 / 2 / 0
Регистрация: 06.11.2012
Сообщений: 9
29.07.2009, 11:11 7
а может попробовать вместо Контрагент = Справочник.Контрагенты.Наименование написать так?

Контрагент = Справочник.УсловияДоговораАренды.Владелец.Владелец.Наименование;
0
puh14
0 / 0 / 0
Регистрация: 07.07.2008
Сообщений: 1,401
31.07.2009, 10:45 8
Владельцев н7адо обозначить в условиях, типа

ТекстЗапроса = "
|Контрагент = Справочник.Контрагенты.ТекущийЭлемент;
|Договор = Справочник.Договоры.ТекущийЭлемент;
|Аренда = Справочник.УсловияДоговораАренды.ТекущийЭлемент;
|ТорговаяТочка = Справочник.УсловияДоговораАренды.ТорговаяТочка;
|Площадь = Справочник.УсловияДоговораАренды.Площадь;
|СуммаОплаты = Справочник.УсловияДоговораАренды.СуммаОплаты;
|ДатаНачала = Справочник.УсловияДоговораАренды.ДатаНачалаДействия;
|ДатаКонца = Справочник.УсловияДоговораАренды.ДатаКонцаОплаты;
|Комментарий = Справочник.УсловияДоговораАренды.Комментарий;
|Группировка ТорговаяТочка Упорядочить по ТорговаяТочка.Наименование без групп;
|Условие (Договор.Владелец = Контрагент);
|Условие (Аренда.Владелец = Договор);
|";




а может попробовать вместо Контрагент = Справочник.Контрагенты.Наименование написать так?

Контрагент = Справочник.УсловияДоговораАренды.Владелец.Владелец.Наименование;
А вот это точно пошлет - итак обращение к владельцу в запросе идет через условие в основном, ежли хочешь как ты написал - тогда данное условие должно обязательно участвовать в группировке и точек все-таки максимум три насколько я помню
0
ky4r
0 / 0 / 0
Регистрация: 25.07.2009
Сообщений: 29
31.07.2009, 15:41 9
Контрагент = Справочник.УсловияДоговораАренды.Владелец.Владелец.Наименование;
нормально работает,спасибо
0
ky4r
0 / 0 / 0
Регистрация: 25.07.2009
Сообщений: 29
04.08.2009, 10:41 10
разобрался [deleted]
0
04.08.2009, 10:41
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.08.2009, 10:41

Внешний регламентированный отчет
Всем привет! Написал свой регламентированный отчет, формируется и записывается в документ...

Внешний отчет о скидках
С Новым Годом! Подскажите пожста как реализовать отчет о скидках которые были поставлены в ручную....

Нужен внешний отчет
Срочно понадобился отчет (внешний) задача которого состоит в том, чтобы показать пользователю форму...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru