Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Oleg Shewczow
0 / 0 / 0
Регистрация: 16.05.2017
Сообщений: 8
1

Как вывести результат 2 запросов в 1 файл

07.12.2017, 20:35. Просмотров 214. Ответов 4
Метки нет (Все метки)

В общем есть два запроса, при нажатии кнопки один выгружает результаты запроса в файл, как добавить выгрузку результатов 2 запроса после выгрузки данных из первого
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.12.2017, 20:35
Ответы с готовыми решениями:

Как На Языке Запросов Узнать Тип Объекта
Ситуация: нужен отчет при помощи механизма "Универсальных отчетов", в котором...

Как объединить результат двух запросов
Всем доброго времени суток. Есть два запроса в пакете. Никак не соображу, как...

Как работать с Консолью ЗАПРОСОВ?
Добрыйд день, подскажите разбираюсь с запросом, не получается, выдает пустой...

Консоль запросов - как запустить в УТ 10.3, КА 1.1
Подскажите, пожалуйста, кто нибудь. Скачал обработку "Консоль запросов". Как её...

УнФ 1.4.6.19 Как в консоле запросов посчитать себестоимость продукции
Сложилась ситуация что нужно перед тем как проводить реализацию товаров, можно...

4
polax
851 / 548 / 185
Регистрация: 16.01.2015
Сообщений: 1,998
07.12.2017, 21:17 2
Oleg Shewczow, Написать код, выгружающий и второй запрос. А, если серьезно, то телепатов здесь кажется нет. Покажите код что у вас выгружается, что вы хотите и что не получается
0
Oleg Shewczow
0 / 0 / 0
Регистрация: 16.05.2017
Сообщений: 8
08.12.2017, 00:02  [ТС] 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
&НаКлиенте
Процедура Команда1(Команда)
    // Вставить содержимое обработчика.
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    //Ворд = Новый COMОбъект("Application.word");
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        Файл = Новый ЗаписьТекста(ДиалогОткрытияФайла.ПолноеИмяФайла);
 
            Стр = ВынутДанные(); 
            Для каждого М Из Стр Цикл
            Файл.ЗаписатьСтроку(М.Название);    
            КонецЦикла;
    Файл.Закрыть();
    Реквизит1 = Стр;
    КонецЕсли;
    
    
КонецПроцедуры
 
&НаСервере
Функция ВынутДанные()
    Запрос = Новый Запрос("ВЫБРАТЬ
                          | УчебныеПланыУчебныйПлан.Ссылка,
                          | УчебныеПланыУчебныйПлан.Наименование,
                          | УчебныеПланыУчебныйПлан.IDСтроки КАК IDСтроки
                          |ПОМЕСТИТЬ циклы
                          |ИЗ
                          | Справочник.УчебныеПланы.УчебныйПлан КАК УчебныеПланыУчебныйПлан
                          |ГДЕ
                          | ТИПЗНАЧЕНИЯ(УчебныеПланыУчебныйПлан.Наименование) = ТИП(Справочник.Циклы)
                          | И УчебныеПланыУчебныйПлан.Ссылка = &УП
                          | И НЕ УчебныеПланыУчебныйПлан.Наименование.Наименование ПОДОБНО ""%Блок%""
                          |
                          |ИНДЕКСИРОВАТЬ ПО
                          | IDСтроки
                          |;
                          |
                          |////////////////////////////////////////////////////////////////////////////////
                          |ВЫБРАТЬ
                          | циклы.Ссылка,
                          | циклы.Наименование КАК Цикл,
                          | циклы.IDСтроки,
                          | УчебныеПланыУчебныйПлан.Наименование КАК Блок,
                          | УчебныеПланыУчебныйПлан.IDСтроки КАК IDСтрокиБлок
                          |ПОМЕСТИТЬ Блоки
                          |ИЗ
                          | циклы КАК циклы
                          |     ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.УчебныеПланы.УчебныйПлан КАК УчебныеПланыУчебныйПлан
                          |     ПО циклы.IDСтроки = УчебныеПланыУчебныйПлан.Родитель
                          |ГДЕ
                          | УчебныеПланыУчебныйПлан.Ссылка = &УП
                          |
                          |СГРУППИРОВАТЬ ПО
                          | УчебныеПланыУчебныйПлан.Наименование,
                          | УчебныеПланыУчебныйПлан.IDСтроки,
                          | циклы.Наименование,
                          | циклы.IDСтроки,
                          | циклы.Ссылка
                          |
                          |ИНДЕКСИРОВАТЬ ПО
                          | IDСтрокиБлок
                          |;
                          |
                          |////////////////////////////////////////////////////////////////////////////////
                          |ВЫБРАТЬ
                          | Блоки.Ссылка,
                          | Блоки.Цикл,
                          | Блоки.IDСтроки,
                          | Блоки.Блок,
                          | Блоки.IDСтрокиБлок,
                          | УчебныеПланыУчебныйПлан.Наименование,
                          | УчебныеПланыУчебныйПлан.Часы КАК Часы1,
                          | УчебныеПланыУчебныйПлан.Кафедра
                          |ПОМЕСТИТЬ Дисциплины
                          |ИЗ
                          | Блоки КАК Блоки
                          |     ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.УчебныеПланы.УчебныйПлан КАК УчебныеПланыУчебныйПлан
                          |     ПО Блоки.IDСтрокиБлок = УчебныеПланыУчебныйПлан.Родитель
                          |ГДЕ
                          | УчебныеПланыУчебныйПлан.Ссылка = &УП
                          |;
                          |
                          |////////////////////////////////////////////////////////////////////////////////
                          |ВЫБРАТЬ
                          | Дисциплины.Ссылка,
                          | Дисциплины.Цикл,
                          | Дисциплины.Блок,
                          | Дисциплины.Наименование,
                          | Дисциплины.Часы1,
                          | Дисциплины.Кафедра,
                          | РабочиеПрограммыДисциплины.Ссылка КАК Ссылка1
                          |ПОМЕСТИТЬ РПД
                          |ИЗ
                          | Дисциплины КАК Дисциплины
                          |     ЛЕВОЕ СОЕДИНЕНИЕ Справочник.РабочиеПрограммыДисциплины КАК РабочиеПрограммыДисциплины
                          |     ПО Дисциплины.Наименование = РабочиеПрограммыДисциплины.Владелец
                          |         И Дисциплины.Ссылка = РабочиеПрограммыДисциплины.УчебныйПлан
                          |         И Дисциплины.Кафедра = РабочиеПрограммыДисциплины.ОбеспечивающаяКафедра
                          |ГДЕ
                          | НЕ РабочиеПрограммыДисциплины.СтатусРазработки В (&СтатусРазработки)
                          |;
                          |
                          |////////////////////////////////////////////////////////////////////////////////
                          |ВЫБРАТЬ
                          | РПД.Ссылка,
                          | РПД.Цикл,
                          | РПД.Блок,
                          | РПД.Наименование,
                          | РПД.Часы1,
                          | РПД.Кафедра,
                          | РПД.Ссылка1 КАК РПД,
                          | Блоки.Ссылка КАК РПДБЛОК,
                          | Разделы.Ссылка КАК РПДРАЗДЕЛ,
                          | Лекции.Ссылка КАК РПДЛЕКЦИЯ
                          |ПОМЕСТИТЬ Лекции
                          |ИЗ
                          | РПД КАК РПД
                          |     ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Блоки КАК Блоки
                          |         ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Разделы КАК Разделы
                          |             ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Лекции КАК Лекции
                          |             ПО Разделы.Ссылка = Лекции.Владелец
                          |         ПО Блоки.Ссылка = Разделы.Владелец
                          |     ПО РПД.Ссылка1 = Блоки.Владелец
                          |;
                          |
                          |////////////////////////////////////////////////////////////////////////////////
                          |ВЫБРАТЬ
                          | Лекции.Ссылка КАК Ссылка,
                          | Лекции.Цикл КАК Цикл,
                          | Лекции.Блок КАК Блок,
                          | Лекции.Наименование КАК Наименование,
                          | Лекции.Кафедра,
                          | Лекции.РПД,
                          | Лекции.РПДЛЕКЦИЯ,
                          | ""устный"" КАК Поле1,
                          | Лекции.Часы1
                          |ИЗ
                          | Лекции КАК Лекции
                          |ИТОГИ ПО
                          | Ссылка,
                          | Цикл,
                          | Блок,
                          | Наименование");
    
    Запрос.УстановитьПараметр("УП",УП);
    Запрос.УстановитьПараметр("СтатусРазработки",СтатусРазработки);
    Выборка = Запрос.Выполнить();
    ВыборкаУП = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Ссылка");
    Стр="";    
    М = Новый Массив();
    Пока ВыборкаУП.Следующий() Цикл
        ВыборкаЦиклы = ВыборкаУП.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Цикл");
        Пока ВыборкаЦиклы.Следующий() Цикл
            ВыборкаБлоки = ВыборкаЦиклы.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Блок");
            Пока ВыборкаБлоки.Следующий() Цикл
                  Стр = Стр + ВыборкаБлоки.Блок + " " + ВыборкаЦиклы.Цикл +Символы.ПС;
                  А = Новый Структура("Название,ТипСтроки");
                  А.Вставить( "Название",ВыборкаБлоки.Блок.Метаданные().Имя + " " + ВыборкаЦиклы.Цикл.Наименование); 
                  А.Вставить( "ТипСтроки","0");
                  М.Добавить(А); 
                ВыборкаНаименование = ВыборкаБлоки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"Наименование");
                Пока ВыборкаНаименование.Следующий() Цикл
                    Стр = Стр + ВыборкаНаименование.Наименование +Символы.ПС;
                    А = Новый Структура("Название,Вид,Часы");
                    А.Вставить( "Название",ВыборкаНаименование.Наименование); 
                    М.Добавить(А);
                    Индекс = М.Количество()-1;
                    ВыборкаТемы = ВыборкаНаименование.Выбрать(М);
                    Пока ВыборкаТемы.Следующий() Цикл
                         М[Индекс].Вставить( "Вид",ВыборкаНаименование.Поле1);
                         М[Индекс].Вставить( "Часы",ВыборкаНаименование.Часы1);
                    А = Новый Структура("Название");
                    А.Вставить( "Название",ВыборкаТемы.РПДЛЕКЦИЯ);
                    М.Добавить(А);
                    КонецЦикла;
                    
                КонецЦикла;
            КонецЦикла;
        КонецЦикла;
        
    КонецЦикла;
Возврат М;  
КонецФункции
 
//Функция ВынутьЛитературу()
//      Запрос = Новый Запрос("ВЫБРАТЬ
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Ссылка,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Ссылка.ОбеспечивающаяКафедра,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.Автор КАК НаименованиеАвтор,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.Наименование КАК НаименованиеНаименование,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.Издательство КАК НаименованиеИздательство,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.ГодИздания КАК НаименованиеГодИздания,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.Объем КАК НаименованиеОбъем,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.ПолноеНаименование КАК НаименованиеПолноеНаименование,
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Наименование.ISBN КАК НаименованиеISBN
//      |ИЗ
//      |Справочник.РабочиеПрограммыДисциплины.ОсновнаяЛитература КАК РабочиеПрограммыДисциплиныОсновнаяЛитература
//      |ГДЕ
//      |РабочиеПрограммыДисциплиныОсновнаяЛитература.Ссылка.УчебныйПлан В(&УП)
//      |И НЕ РабочиеПрограммыДисциплиныОсновнаяЛитература.Ссылка.СтатусРазработки В (&СтатусРазработки)
//      
//      |ОБЪЕДИНИТЬ ВСЕ
//      
//      |ВЫБРАТЬ
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Ссылка,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Ссылка.ОбеспечивающаяКафедра,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.Автор,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.Наименование,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.Издательство,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.ГодИздания,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.Объем,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.ПолноеНаименование,
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Наименование.ISBN
//      |ИЗ
//      |Справочник.РабочиеПрограммыДисциплины.ДополнительнаяЛитература КАК РабочиеПрограммыДисциплиныДополнительнаяЛитература
//      |ГДЕ
//      |РабочиеПрограммыДисциплиныДополнительнаяЛитература.Ссылка.УчебныйПлан В(&УП)
//      |И НЕ РабочиеПрограммыДисциплиныДополнительнаяЛитература.Ссылка.СтатусРазработки В (&СтатусРазработки)" );
//КонецФункции
0
_ЕГОР_
Тест
Эксперт 1С
367 / 154 / 50
Регистрация: 26.02.2010
Сообщений: 1,129
08.12.2017, 08:10 4
Вонючие помидоры как много текста!!!
Читать его что то не хочется, так что на вскидку предложу два варианта:
1. Выгрузить первый запрос в тз, выгрузить второй запрос в тз2. Перенести данные из тз2 в тз. Сохранить данные куда там нужно.
2. Объединить запросы, на выходе получать нужные данные и выгружать куда нужно.
0
Anna9379
0 / 0 / 0
Регистрация: 13.12.2017
Сообщений: 1
14.12.2017, 13:20 5
Здравствуйте! У меня тоже была такая проблема. Обратись за помощью к этому специалисту https://www.1cp-msk.ru/!!! Очень мне помог. Решил эту проблему и еще у меня не открывалась форма справочника. Реально не дорого и быстро решает проблему и еще подскажет, что надо.
0
14.12.2017, 13:20
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.12.2017, 13:20

Как правильно вывести результат запроса в список?
подскажите как правильно вывести результат запроса в список Процедура...

Как вывести результат в документ по процедуре Завершить
&НаСервере Процедура ВпередНаСервере()...

СКД вывести результат в нужной форме
Добрый день. Возникла такая проблем. С СКД я не очень пока ознакомился и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru