Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
1

Из модуля ВПФ открыть форму ВПФ

25.03.2018, 16:30. Просмотров 1044. Ответов 15
Метки нет (Все метки)

Добрый день.
Подскажите каким макаром открыть форму внешней печтаной формы (далее ВПФ) из модуля этой внешней печатной формы.

Спасибо за ответы
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
25.03.2018, 16:30
Ответы с готовыми решениями:

ВПФ Счет-фактуры
Проблема с печатной формой. Выводится на 2-ую страницу шапка таблицы после строки (на скрине...

ВПФ для ПТУ
Здравствуйте, уважаемые форумчане. Такой вопрос - надо сделать доп форму в 11 УТ, чтобы там были и...

ВПФ для РеализацииТоваровУслуг
Здравствуйте! Делаю ВПФ для Реализации. Конфа БП 3.0. Раньше никогда не работал с упр. приложением....

Создание ВПФ Счет на оплату для УТ 11
Тренируюсь на создании ВПФ. Делаю Счет на оплату для УТ 11 под УП. Дошел до момента //Вывести...

Нужна помощь в создании ВПФ для УТ 8.1 ред.10.3 - Расходная накладная
Необходимо создать для УТ 8.1 (версия 10.3.1.17) внешнюю печатную форму для документа «Реализация...

15
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
25.03.2018, 17:45 2
Цитата Сообщение от McGoblin Посмотреть сообщение
открыть форму внешней печтаной формы (далее ВПФ) из модуля этой внешней печатной формы
так?
1C
1
2
ФормаОбработки = ЭтотОбъект.ПолучитьФорму("Форма");
ФормаОбработки.Открыть();
0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
26.03.2018, 15:23  [ТС] 3
Цитата Сообщение от GreenkA Посмотреть сообщение
так?
1CВыделить код
1
2
ФормаОбработки = ЭтотОбъект.ПолучитьФорму("Форма");
ФормаОбработки.Открыть();
Не, так не катит.
Если сделать так, то он ругается на то что "ПолучитьФорму" только для тонкого клиента, а если сделать в модуле обработки функцию с директивой &НаКлиенте, то он просто не увидит эту функцию.


Наверное надо было уточнить что это управляемые формы платформа 8.3.11
0
_ЕГОР_
Тест
Эксперт 1С
373 / 158 / 52
Регистрация: 26.02.2010
Сообщений: 1,152
26.03.2018, 15:35 4
А почему нельзя из формы то открыть? Там можно написать НаКлиенте
0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
26.03.2018, 15:39  [ТС] 5
Я нахожусь в модуле, из модуля мне надо открыть форму обработки, если бы я был в форме, то вопроса бы не было бы
0
_ЕГОР_
26.03.2018, 15:43
  #6

Не по теме:

ой удалите этот позорный пост

0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
26.03.2018, 15:46  [ТС] 7
Есть модуль формы там можно менять директивы сервера и клиента
Есть модуль обработки, там все работает из сервера
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
26.03.2018, 21:52 8
McGoblin, Никак.
0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
27.03.2018, 08:52  [ТС] 9
В общем единственное что я нашел, так это что бы в первую очередь у ВПФ открывалась форма обработки для этого в регистрации обработки надо прописать
в качестве индификатора - имя формы
в качестве действия - "открытиеФормы"

1C
1
ДобавитьКоманду(ТаблицаКоманд, "Трудовой договор/Служебный контракт", "ОсновнаяФорма", "ОткрытиеФормы", Ложь, "");
А дальше получается работать из формы =(
Иного способа не нашел=(((
0
polax
896 / 584 / 194
Регистрация: 16.01.2015
Сообщений: 2,104
27.03.2018, 16:31 10
McGoblin, А зачем форма в ВПФ? Может есть какое-то другое решение, без формы?
0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
28.03.2018, 11:43  [ТС] 11
polax, есть параметры, которые нигде нельзя указать заранее.
Т.е. в зависимости от человека кадровику надо поставить параметры и от них будет формироваться печатная форма.
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,138
28.03.2018, 16:54 12
McGoblin, объясните внятно, какую перед Вами поставили задачу.
объясните так, чтобы каждый в этой теме понял, что Вы хотите сделать.
0
McGoblin
5 / 5 / 2
Регистрация: 18.05.2012
Сообщений: 61
28.03.2018, 19:03  [ТС] 13
Phil, я в самом начале объяснил что мне нужно.
Управляемые формы.
Мне нужно из модуля обработки - ВПФ, открыть форму этой обработки.
И уже выяснилось что этого никак не сделать, кроме как
1C
1
ДобавитьКоманду(ТаблицаКоманд, "Трудовой договор/Служебный контракт", "ОсновнаяФорма", "ОткрытиеФормы", Ложь, "");
Т.е. когда впф сразу открывает форму.
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,138
28.03.2018, 23:21 14
McGoblin, это не постановка задачи, вы пишите что Вам надо, а не какую конечную цель преследуете.
Возможна выбранный путь реализации изначально неверный.

Постановка задачи выглядит так:
Из документа Реализация товаров и услуг необходимо распечатать список товаров, при нажатии кнопки печать, пользователю открывается форма выбора склада, (ввода комментария, что угодно), на который необходимо отгрузить реализованные товары, выбранный склад также передается в макет на печать.
1
fanast
10 / 10 / 1
Регистрация: 09.01.2016
Сообщений: 70
23.04.2018, 07:21 15
Недавно реализовал похожую задачу. Не знаю, поможет ли вам.

Смысл такой: в подменю печати добавляется своя команда "Печать с параметрами". При нажатии открывается вн. обработка, в которой выбираются уже нужные параметры и в которой содержатся требуемые макеты. Ну и уже в ней мы выбираем макет, параметры и печатаем.

Реализовано так:
(В модуле ВПФ)
1C
1
ДобавитьКоманду(ТаблицаКоманд, "ПечатьКП", "ПечатьКП", "ВызовКлиентскогоМетода", Ложь, "ПечатьКП");
В модуле основной формы обработки процедура (туда приходим при открытии по кнопке):
1C
1
2
3
4
5
6
7
8
9
10
11
//Если пришли из команды печати
&НаКлиенте
Процедура Печать(Идентификатор,ОбъектыНазначения) Экспорт
    
    Если ОбъектыНазначения.Количество() < 1 Тогда
        Сообщить("Отказ. Не выбрано заказов для печати!");
    Иначе
        ЗаказКлиента = ОбъектыНазначения[0];
        ЭтаФорма.Открыть();
    КонецЕсли;
КонецПроцедуры
Ну и дальше приОткрытии() вставляем то что нужно при открытии.
Кстати, кто не знает как быстро и удобно отлаживать Внешние обработки и печатные формы:
https://infostart.ru/public/573461/
0
Law_Of_Evi1
11 / 11 / 0
Регистрация: 22.12.2011
Сообщений: 96
24.04.2018, 17:21 16
Цитата Сообщение от McGoblin Посмотреть сообщение
Phil, я в самом начале объяснил что мне нужно.
Управляемые формы.
Мне нужно из модуля обработки - ВПФ, открыть форму этой обработки.
И уже выяснилось что этого никак не сделать, кроме как
Это можно сделать.
Пример заполнения сведений о внешней обработки в модуле объекта:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Функция СведенияОВнешнейОбработке() Экспорт     
    МассивИсполняемыхДокументов = Новый Массив;
    МассивИсполняемыхДокументов.Добавить("Документ.ПриемНаРаботуСписком");
    
    ТзКоманды = Новый ТаблицаЗначений;
    ТзКоманды.Колонки.Добавить("Представление");
    ТзКоманды.Колонки.Добавить("Идентификатор");
    ТзКоманды.Колонки.Добавить("Использование");
    ТзКоманды.Колонки.Добавить("ПоказыватьОповещения");
    ТзКоманды.Колонки.Добавить("Модификатор");
    
    НСтрКоманд = ТзКоманды.Добавить();
    НСтрКоманд.Представление = "Доп соглашение РФ (Свежар)";
    НСтрКоманд.Идентификатор = "ДопСменаРФ";
    НСтрКоманд.Использование ="ВызовКлиентскогоМетода";
    НСтрКоманд.ПоказыватьОповещения = Ложь;
    НСтрКоманд.Модификатор = "ПечтатьMXL";
    
    ДанныеОбработки = новый Структура;
    ДанныеОбработки.Вставить("Наименование", "Доп соглашение РФ (Свежар))");
    ДанныеОбработки.Вставить("Информация", "Law_Of_Evi1");
    ДанныеОбработки.Вставить("Назначение", МассивИсполняемыхДокументов);
    ДанныеОбработки.Вставить("Вид", "ПечатнаяФорма");
    ДанныеОбработки.Вставить("Версия", "1.0");
    ДанныеОбработки.Вставить("БезопасныйРежим", Ложь);
    
    ДанныеОбработки.Вставить("Команды", ТзКоманды);
    
    Возврат ДанныеОбработки;
КонецФункции
В том случае, когда используешь НСтрКоманд.Использование ="ВызовКлиентскогоМетода";
при вызове ВПФ используется не Процедура модуля объекта, которая находится на сервере, а процедура "Печать" модуля формы с дерективой &НаКлиенте и теперь ты можешь вызвать любую клиентскую функцию/процедуру, в том числе и открыть форму.
0
24.04.2018, 17:21
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.04.2018, 17:21

ВПФ
теперь нужно тоже самое но только на 8.3. Кто может помочь? Добавлено через 7 часов 10 минут...

УТ 11, создание ВПФ ТТН
Всем привет! Помогите пожалуйста сделать внешнюю печатную форму &quot;Товарно-транспортная...

ВПФ счета от поставщика
Здравствуйте, 1С Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.64.54) Есть везде счета...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
16
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru