Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Bessondo
0 / 0 / 0
Регистрация: 19.09.2016
Сообщений: 16
1

Заполнение макета структурой

19.07.2018, 17:05. Просмотров 353. Ответов 7
Метки нет (Все метки)

Всем привет. Ребят, помогите разобраться. В документе есть табличная часть, с двумя колонками. Как мне вывести значения этих колонок в макет печатной формы. Чтобы, если у одной не заполнено, то брало значение из другой.
Приложил скрин колонок.
Пока набросал это:
1C
1
2
3
4
5
6
7
8
9
Для Каждого Стр Из СтруктураДоп Цикл
        Сообщить(Стр.Ключ);
        Сообщить(Стр.Значение);
        //здесь условие будет на проверку заполненности  Стр.Значение
        //если то..........иначе получаем по текущему ключу соттветствующее значение второй структуры
        СоотвЗначениеДоп2 = "";
        СтруктураДоп2.Свойство(Стр.Ключ,СоотвЗначениеДоп2);
        Сообщить(СоотвЗначениеДоп2);
КонецЦикла;
0
Миниатюры
Заполнение макета структурой  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.07.2018, 17:05
Ответы с готовыми решениями:

Заполнение макета отчета
Здравствуйте! есть макет, значения в который подставляются из регистра сведений (который...

Заполнение параметров у макета
Всем Доброго времени суток!У меня такой вопрос..совсем просто не давно начал программировать и не...

Заполнение поля макета
Доброго времени суток! Решила создать базу данных и столкнулась с проблемой: как сделать так, чтобы...

Заполнение макета отчета
Процедура ДействияФормыСформировать(Кнопка) ПостроительОтчетаОтчет = Новый ПостроительОтчета; ...

Запрос и заполнение макета
Функция Печать() Экспорт ТабДокумент = Новый ТабличныйДокумент; запрос = новый запрос; ...

7
polax
1081 / 690 / 243
Регистрация: 16.01.2015
Сообщений: 2,654
20.07.2018, 00:08 2
Bessondo, 1. Нет у вас никакой структуры, есть ТЧ. Поэтому Ключ и Значение выдадут ничего, NULL.
2."СтруктураДоп2.Свойство(Стр.Ключ,СоотвЗначениеДоп2);"© Смотри СП, метод Свойство возвращает Булево - Да/Нет. Эта строка кода бессмысленна в такой интерпритации
3. Примерно так:
1C
1
2
3
Для инд = 0 По ТЧ.Количество()-1 Цикл // Вместо ТЧ имя таб части 
НужноеЗначение = ?(ЗначениеЗаполнено(ТЧ[инд].НаМоментОценки),ТЧ[инд].НаМоментОценки,ТЧ[инд].НаМоментПриема);
КонецЦикла;
0
Dethmontt
Модератор
Эксперт 1С
2741 / 2498 / 443
Регистрация: 10.03.2011
Сообщений: 9,104
Записей в блоге: 1
Завершенные тесты: 1
20.07.2018, 01:23 3
Цитата Сообщение от polax Посмотреть сообщение
2."СтруктураДоп2.Свойство(Стр.Ключ,СоотвЗначениеДоп2);"© Смотри СП, метод Свойство возвращает Булево - Да/Нет. Эта строка кода бессмысленна в такой интерпритации
Как раз то нет...
Второй параметр как раз и придуман для передачи в него значения проверяемого свойства...
1
polax
1081 / 690 / 243
Регистрация: 16.01.2015
Сообщений: 2,654
20.07.2018, 09:08 4
Dethmontt, Точно. Был не прав
0
20.07.2018, 09:08
Bessondo
0 / 0 / 0
Регистрация: 19.09.2016
Сообщений: 16
20.07.2018, 15:06  [ТС] 5
Выкладываю как примерно заполняется макет:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
        СтруктураДоп = Новый Структура;
    СтруктураДоп.Вставить("МО",   1);//                       обПолучитьСокращенноеФИО(СсылкаНаОбъект.Оценщик));
    СтруктураДоп.Вставить("КТП",2);//                        ПолучитьКИКонтрагентаПФ(СсылкаНаОбъект.ПотенциальныйКлиент));
    СтруктураДоп.Вставить("КТК",3);//                        ПолучитьКИКонтрагентаПФ(СсылкаНаОбъект.Владелец));
 
        СтруктураДоп2 = Новый Структура;
    СтруктураДоп2.Вставить("МО",  11);//                      обПолучитьСокращенноеФИО(СсылкаНаОбъект.Оценщик));
    СтруктураДоп2.Вставить("КТП",22);//                      ПолучитьКИКонтрагентаПФ(СсылкаНаОбъект.ПотенциальныйКлиент));
    СтруктураДоп2.Вставить("КТК",33);//                          ПолучитьКИКонтрагентаПФ(СсылкаНаОбъект.Владелец));
    
    //перебор ключей структуры:
    Для Каждого Стр Из СтруктураДоп Цикл
        Сообщить(Стр.Ключ);
        Сообщить(Стр.Значение);
        СтруктураДоп.Вставить(Стр.Ключ, Стр.Значение);
        //здесь условие будет на проверку заполненности  Стр.Значение
        //если то..........иначе получаем по текущему ключу соттветствующее значение второй структуры
        СоотвЗначениеДоп2 = "";
        СтруктураДоп2.Свойство(Стр.Ключ,СоотвЗначениеДоп2);
        Сообщить(СоотвЗначениеДоп2);
КонецЦикла;
И собственно вопрос, как из этого куска кода, т.е. чтобы если значение не заполнено у одной структуры, он брал значение другой?
0
Dethmontt
Модератор
Эксперт 1С
2741 / 2498 / 443
Регистрация: 10.03.2011
Сообщений: 9,104
Записей в блоге: 1
Завершенные тесты: 1
21.07.2018, 00:02 6
Bessondo, в твоем случае у СТРУКТУРЫ не может быть НЕ ЗАПОЛНЕННОГО значения
0
Bessondo
0 / 0 / 0
Регистрация: 19.09.2016
Сообщений: 16
22.07.2018, 20:56  [ТС] 7
Но каким образом вывести в макет данные по этим двум колонкам?
0
Dethmontt
Модератор
Эксперт 1С
2741 / 2498 / 443
Регистрация: 10.03.2011
Сообщений: 9,104
Записей в блоге: 1
Завершенные тесты: 1
22.07.2018, 23:47 8
Bessondo, вот так
Цитата Сообщение от polax Посмотреть сообщение
Для инд = 0 По ТЧ.Количество()-1 Цикл // Вместо ТЧ имя таб части
НужноеЗначение = ?(ЗначениеЗаполнено(ТЧ[инд].НаМоментОценки),ТЧ[инд].НаМоментОценки,ТЧ[инд].НаМоментПриема);
КонецЦикла;
0
22.07.2018, 23:47
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.07.2018, 23:47

Заполнение таблицы макета
Всем привет!!! Подскажите, пожалуйста, как заполнить таблицу макета (прикрепила скрин). Есть макет...

Заполнение файла структурой
program unt; uses crt; const p = 100; type Base = record LastName : string; ...

Заполнение бинарного файла структурой и вывод его на экран
мне нужно создать бинарник с заполненной структурой. вроде, заполняю правильно, а с выводом на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.