Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
MaryYoko
0 / 0 / 0
Регистрация: 20.01.2019
Сообщений: 5
1

Ошибка при вызове метода контекста по причине испльзование модальных окон в данном режиме запрещено

11.02.2019, 16:11. Просмотров 1152. Ответов 3

Здравствуйте! столкнулась вот с такой ошибкой, понятия не имею, что делать. Сделала все по инструкции с сайта 1c-uroki.
Вот код модуля формы
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаКлиенте
Процедура ДобавитьКартинку(Команда)
    ИмяФайла = "";
ПутьФайла = "";
//Вызываем Диалоговое окно и помещаем файл Картинки из локальной файловой системы во временное хранилище
Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина) = Истина Тогда
 
//в строковый реквизит ФОТО нашей формы сохраняем ссылку на Картинку во временном хранилище
Фото = ПутьФайла;
//для создания нового элемента в Справочнике Файлы и записи Картинки в его реквизит Файл
//переходим на сервер с помощью вызова серверной процедуры
УстановитьКартинку();
КонецЕсли; 
КонецПроцедуры
 
&НаСервере
Процедура УстановитьКартинку()
//создаем новый элемент в Справочнике Файлы
НовыйФайлКартинки = Справочники.Файлы.СоздатьЭлемент();
//в реквизит СправочникаФайлы Файл помещаем выбранную ранее Картинку
НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото));
Фото = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить());
//записываем новый элемент справочника Файлы
НовыйФайлКартинки.Записать();
 
//устанавливаем значение реквизита Картинка Справочника Сотрудники
Объект.Картинка = НовыйФайлКартинки.Ссылка;
КонецПроцедуры
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Фото = ПолучитьНавигационнуюСсылку(Объект.Картинка, "Файл");
 
//устанавливаем автомасштаб для картинки
Элементы.Фото.РазмерКартинки = РазмерКартинки.АвтоРазмер;
КонецПроцедуры
0
Миниатюры
Ошибка при вызове метода контекста по причине испльзование модальных окон в данном режиме запрещено  
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.02.2019, 16:11
Ответы с готовыми решениями:

Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
Что делать с этой ошибкой? Ошибка при вызове метода контекста (Выполнить)...

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста
есть ссылка "e79ba7ae-0747-11db-9244-0011955c22cb"... как присвоить ее новому элементу справочника...

Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста...

Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: При выборе...

3
_ЕГОР_
Тест
Эксперт 1С
378 / 160 / 55
Регистрация: 26.02.2010
Сообщений: 1,206
11.02.2019, 17:28 2
Лучший ответ Сообщение было отмечено MaryYoko как решение

Решение

У корневого элемента конфигурации существует свойство “Режим использования модальности”, которое определяет, можно ли в конфигурации открывать модальные окна.
Продолжение тут
1
makcon4ick
0 / 0 / 2
Регистрация: 17.05.2016
Сообщений: 20
12.02.2019, 13:30 3
Сообщение удалено.
0
Yulunga
476 / 343 / 86
Регистрация: 22.04.2013
Сообщений: 2,331
Записей в блоге: 1
Завершенные тесты: 1
12.02.2019, 23:47 4
вообще с введением веб-версий 1с предлагает отказываться от модальности
ибо могут всякие вирусные окошки показываться и в браузере либо спецом стоит галочка "не показывать модальные окна", либо браузер сам не кажет иха.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
&НаКлиенте
Процедура ВыполнитьАлгоритм(Команда)
    ОбратныйВызов = Новый ОписаниеОповещения("ВыполнитьАлгоритмОбратныйВызов", ЭтотОбъект);
    ПоказатьВопрос(ОбратныйВызов, "Выполнить быстро или не медленно?", РежимДиалогаВопрос.ДаНет);
КонецПроцедуры
&НаКлиенте
Процедура ВыполнитьАлгоритмОбратныйВызов(Результат, ДополнительныеПараметры) Экспорт
    Если Результат = КодВозвратаДиалога.Да Тогда
        // Первый вариант алгоритма
    Иначе
        // Второй вариант алгоритма
    КонецЕсли;
КонецПроцедуры
взято с сайта итс
0
12.02.2019, 23:47
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.02.2019, 23:47

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений...

Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран
В УТ 8.2 скопировал печатную форму "Сравнительная накладная " из РеализацияТоваровУслуг в Заказ...

Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)
1C 8.2 Документооборот КОРП 1.2 Текст ошибки...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.