Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Pagot
0 / 0 / 0
Регистрация: 23.01.2016
1

Не получается с настройкой дисконта

04.06.2011, 15:55. Просмотров 791. Ответов 2
Метки нет (Все метки)

прошу помочь с настройкой дисконтных карт для 1 с 7.7.
на картах просто напечатан штрих код из 12 цифр. на стандарте первая 0 на VIP 1
база взята от старой компании и там было настроенно все под них. мне же необходими переделать под себя)
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
Процедура ВводНового()
    Автор=глАвтор;
    ПрефБазы=Константа.ПрефиксБазы;
КонецПроцедуры
 
Процедура ПриЗаписи()
    Если (Лев(СокрЛП(Строка(НомКарты)),7)="") 
    И (Прав(СокрЛП(Строка(НомКарты)),8)="") 
    и (СтрДлина(СокрЛП(НомКарты))=36)
    и (Сред(СокрЛП(Строка(НомКарты)),8,1)="") или (Сред(СокрЛП(Строка(НомКарты)),8,1)="")
    тогда  
    Иначе
        Предупреждение("Код введен не верно");
        СтатусВозврата(0);
    КонецЕсли;
    Если СтрДлина(СокрЛП(Строка(ВладелецКарты)))=0 тогда 
        Предупреждение("Укажиде владельца карты"); 
        СтатусВозврата(0);
    КонецЕсли;
    Если ((Сред(СокрЛП(Строка(НомКарты)),12,1)="1") и
    (ТипКарты=Перечисление.ТипКарты.Дисконт2))
    Или ((Сред(СокрЛП(Строка(НомКарты)),12,1)="0") и
    (ТипКарты=Перечисление.ТипКарты.Дисконт1))
    тогда  
    Иначе
        Предупреждение("Код введен не верно");
        СтатусВозврата(0);
    КонецЕсли;
        ВнутреннееВремяИзменения=глПолучитьВнутреннееВремя();
    КонецПроцедуры 
 
Процедура ВыбТипКарты()
    Если Лев(СокрЛП(Строка(НомКарты)),1)=СокрЛП(Строка("9")) тогда
        ТипКарты=Перечисление.ТипКарты.Дисконт2;
    ИначеЕсли Лев(СокрЛП(Строка(НомКарты)),1)=СокрЛП(Строка("1")) тогда
        ТипКарты=Перечисление.ТипКарты.Дисконт1;
    КонецЕсли;
КонецПроцедуры
 
Процедура ИзменитьНаименование();
    Наименование="МДК"+Сред(СокрЛП(Строка(НомКарты)),8,9)+СокрЛП(ВладелецКарты)+"_"+Константа.ПрефиксБазы+глАвтор.Код;
КонецПроцедуры
 
Процедура ВыборВладельца()
    Мыло=ВладелецКарты.Мыло;
    КонецПроцедуры

очень надеюсь на вашу помощь.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.06.2011, 15:55
Ответы с готовыми решениями:

Как организовать хранение соответствия Суммы и Дисконта
Всем привет. Как в модуле формы организовать соответствие суммы покупки и процента дисконта? ...

Подскажите с настройкой
Здравствуйте ситуация такая : Приобрел новый компьютер Asus, решил переустановить винду с 10 на 7...

Помогите с настройкой
У меня на работе одна из касс при включение требует ввести пользователя и пароль, чтобы...

Настройкой сети
У меня на сервере 2003 стоит две сетевые карты, к одной подключен модем на адресе 192,168,1,***, а...

Помогите с настройкой программы
Есть програмка и исполняющие файлы, при открытии программы она разворачивается во весь экран, может...

2
kot-1012
0 / 0 / 0
Регистрация: 01.09.2011
Сообщений: 9
02.09.2011, 12:39 2
в чем именно нужна помощь, что нужно переделать в модуле?
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
02.09.2011, 13:15 3
Процедура ПриЗаписи() Сработает первое условие по Иначе т.к. (СтрДлина(СокрЛП(НомКарты))=36 вместо 12.

НомКарты это строковое поле?
если строковое, тогда
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
Процедура ПриЗаписи()
 
Если ПустаяСтрока(НомКарты) =1) Тогда 
Предупреждение("Не введен код карты");
СтатусВозврата(0);
КонецЕсли;
 
 
Если ПустаяСтрока(ВладелецКарты) = 1 Тогда 
Предупреждение("Не указан владельц карты"); 
СтатусВозврата(0);
КонецЕсли;
 
Если СтрДлина(СокрЛП(НомКарты)) <> 12
Предупреждение("Код введен не верно"); 
СтатусВозврата(0);
КонецЕсли;
 
Если (Лев(СокрЛП(Строка(НомКарты)),1) = "1") ИЛИ (Лев(СокрЛП(Строка(НомКарты)),1 = "0") Тогда
Предупреждение("Код введен не верно"); 
СтатусВозврата(0);
КонецЕсли;
 
 
КонецПроцедуры
 
 
 
Процедура ВыбТипКарты() 
/// Не знаю где висит эта процедура, но надеюсь что на реквизите НомКарты
Если Лев(СокрЛП(НомКарты),1) = "1" Тогда
ТипКарты=Перечисление.ТипКарты.Дисконт2; // Это VIP
ИначеЕсли Лев(СокрЛП(НомКарты),1) = "0" Тогда
ТипКарты=Перечисление.ТипКарты.Дисконт1; // Это Стандартная
КонецЕсли;
КонецПроцедуры
"ТипКарты" лучше поставить запрет на изменение.
Все проверки тоже можно выполнять при изменении номера карты.
Тогда при записи проверять ничего не придется
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.09.2011, 13:15

Проблемы с настройкой Apache 2.2
В общем поставил Apache 2.2. У меня сеть домашняя сеть с роутером. Настроил проброс по 80 му порту...

Помогите с настройкой домена
Проблема в подключении компьютера к контроллеру домен, при попытке подключения выдает следующую...

Помогите с настройкой сети.
Не судите строго если тема заезженная, но вопрос все равно актуален! ))) Имею роутер Д-Линк ДР300...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru