Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.91/11: Рейтинг темы: голосов - 11, средняя оценка - 4.91
Temdj
0 / 0 / 0
Регистрация: 11.03.2011
Сообщений: 26
1

Выбор документов из списка

08.07.2011, 12:21. Просмотров 1976. Ответов 1
Метки нет (Все метки)

Подскажите пожалуйста, как проверить список документов за определённый период (месяц) на одинаковые реквизиты (сотрудник), чтобы после запретить проведение нового документа в этом месяце?

Как бы так:
Док = Документы.Документ.Выбрать(НачалоМесяца(ТекущаяДата()),Конецмесяца(ТекущаяДата())),<<?>>Сотрудник)
Если Док.<<?>>количество() > 1 тогда
Сообщить("Вы уже создали документ в этом месяце, отредактируйте ранее созданный документ");
Отказ=Истина;
КонецЕсли;

<<?>> - не пойму что писать тут.

Выложил проблему как мог, надеюсь поймёте...

Добавлено через 19 часов 21 минуту
Решено:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
    Док = Документы.Документ.Выбрать(НачалоМесяца(Дата),КонецМесяца(Дата));
    Счетчик =0;
    Пока Док.Следующий() Цикл
        Если Док.Сотрудник = ЭтотОбъект.Сотрудник тогда
            Счетчик = Счетчик+1
        КонецЕсли;
    КонецЦикла;
            
    Если Счетчик>1 тогда
        Отказ=Истина;
        Предупреждение("Вы уже создавали документ записи рабочего времени в этом месяце! Пожалуйста, вносите изменения в ранее созданный документ.",,"Ошибка проведения");
        
    КонецЕсли;
Теперь вопрос, как убрать сообщение "Операция не выполнена", которое появляется, как я понял, из-за Отказ=Истина?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.07.2011, 12:21
Ответы с готовыми решениями:

Удалить строку из формы списка журнала документов
Не УФ. Вопрос немного глупый. Как удалить строку в форме списка в обработчике ПриВыводеСтроки, если...

У меня стоит вопрос: как сделать Выбор операций из документов по элеме
У меня стоит вопрос: как сделать Выбор операций из документов по элементу справочника? Более...

Выбор из списка
Добрый день. Если возможность при выборе поля ввода допустим Наименование, что будут преложены уже...

Выбор документа из списка
Добрый день! Нужна помощь в решении данной задачи: Как мне реализовать в конфигураторе, на...

1с отчет СКД выбор данных из 2-х документов
Здравствуйте. Платформа 1С: Предприятие 8.3. Управляемая форма. Формирую запрос с помощью СКД на...

1
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
08.07.2011, 12:41 2
Запросом.
Опять же, если конфига самописная и не большая, тогда шли мылом.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.07.2011, 12:41

Где хранится информация какую форму документа следует открывать из списка документов?
Есть сильно дописанная (можно сказать самописная) конфигурация. Есть Документ. Если в конфигураторе...

Форма списка документов
Добрый день! Имеется документ с табличной частью. Возможно ли в форме Списка в отдельном поле...

Выбор в списке документов
Есть такая задача: на форме есть элемент ТабличноеПоле. В нем есть столбец &quot;Материалы&quot; тип строка....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru