Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/8: Рейтинг темы: голосов - 8, средняя оценка - 5.00
2402Andrew
Заблокирован
1

Кто нибудь делал перенос сотрудников из .dbf в 1с?

31.08.2011, 13:13. Просмотров 1421. Ответов 4
Метки нет (Все метки)

написал код но понять не могу как с полом определиться
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.08.2011, 13:13
Ответы с готовыми решениями:

может кто делал?
Здравствуйте!! Есть справочник Номенклатура куда забивается процент НДС , с...

Кто Ни Будь Так Делал
Вопросик такого плана. Слышал краем уха что можно из БД некоторые таблицы...

Очень хочется узнать, кто может так делал?
Версия 1с 8.1 Можно ли сделать, чтобы в документе При выборе и нажатии на...

перенос данных из Dbf
//******************************************* Процедура Выполнить() ДатаОбр =...

Помогите с документом кто-нибудь!
Ребята нужна помощь сам не справлюсь мелочь а не могу но не программер я 1С а...

4
Танцор_С_Бубном
34 / 34 / 3
Регистрация: 31.03.2011
Сообщений: 197
31.08.2011, 17:01 2
А поподробнее в чем проблема?
А то пока что кроме низкопробных шуток про смену пола никаких мыслей.
2
2402Andrew
Заблокирован
01.09.2011, 07:31  [ТС] 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
     Для Каждого Стр из ФизическиеЛица цикл
        Спр = ФизическиеЛица.Получить(ФизическиеЛица.Индекс(Стр));
        Сообщить(Спр.Наименование);
        Сообщить(Спр.ИНН);
        ТСпр = Справочники.ФизическиеЛица;
        ТекЭлем = ТСпр.СоздатьЭлемент();
        ТекЭлем.Наименование  = Спр.Наименование;
        ТекЭлем.ИНН = Спр.ИНН;
         
        
          ТекЭлем.Записать();
          Сообщить("Элемент записан");
     КонецЦикла;                        
КонецПроцедуры
 
Процедура ИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)
    // Вставить содержимое обработчика.
    Режим = РежимДиалогаВыбораФайла.Открытие;
    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    Фильтр = "Таблицы баз данных *.dbf (*.dbf)|*.dbf";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите таблицу базы данных *.dbf";
    
    Если ДиалогОткрытияФайла.Выбрать() Тогда
        ИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
    КонецЕсли;
КонецПроцедуры
 
Процедура ОсновныеДействияФормыЗаполнить(Кнопка)
Если ПустаяСтрока(ИмяФайла) = Ложь тогда
        Путь =  ИмяФайла;
        База= Новый XBase;
        База.Кодировка = КодировкаXBase.ANSI;
        //Открываем файл для чтения
        
        База.ОткрытьФайл(ИмяФайла,,Истина);
        Если База.Открыта() = Истина тогда        // проверяем открыта ли база
            Сообщить("База отрыта!");             // выводим сообщение в слечае если база открыта
        КонецЕсли;
        
        
        База.Первая();                            // позиционируем на первой записи открытой базы
        //Цикл по записям DBF файла
        Пока НЕ База.ВКонце() Цикл   
            Стр = ФизическиеЛица.Добавить();
            Стр.Группа = Ложь;
            Стр.Код = База.tabn;        
            Стр.Наименование = СокрЛП(База.fio);
    //      Стр.ГоловнойКонтрагент = "";
            Стр.ДатаРождения = База.datrojden;
            Стр.ИНН = СокрЛП(База.inn);
            Стр.СтраховойНомерПФР = СокрЛП(База.pens_strah);
             Если СокрЛП(База.Pol)="Мужской" Тогда  Стр.Пол = Перечисления.ПолФизическихЛиц.Мужской ;
             ИначеЕсли СокрЛП(База.Pol)="Женский" Тогда Стр.Пол = Перечисления.ПолФизическихЛиц.Женский ;
           //  Иначе
             КонецЕсли ;
            Стр.МестоРождения = СокрЛП(База.me_rozd);
            
            База.Следующая();                     // переходим к следуей записи
        КонецЦикла;
        База.ЗакрытьФайл();                       // закрываем файл базы данных
        Сообщить("База закрыта!");
    иначе 
        ОчиститьСообщения();
        Сообщить("Не выбран файл источник");
        Возврат;
    КонецЕсли;
КонецПроцедуры
вот так вроде что то кидает но не хочет кидать пол,пенсномер и дату рождения почему то
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
01.09.2011, 23:30 4
Куда не кидает то? Давай по подробнее
0
2402Andrew
Заблокирован
02.09.2011, 07:33  [ТС] 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
Куда не кидает то? Давай по подробнее
В 1с физические лица это он фамилию берет и инн тока

Добавлено через 12 минут
я тебе в аське ссобщение кинул ты молчишь!
0
02.09.2011, 07:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.09.2011, 07:33

Помогите с документом кто-нибудь!
Ребята нужна помощь сам не справлюсь мелочь а не могу но не программер я 1С а...

Скиньте кто-нибудь пример тех. задания (ТЗ)
Я начинающий программер в 1С... Дали задание прихреначить готовую конфигурацию...

Может кто-нибудь поможет мне с запросом? Новичок
На забалансовом счету находится график платежей по облигациям. Таким образом я...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru