Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.88/33: Рейтинг темы: голосов - 33, средняя оценка - 4.88
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
1

Значение не является значением объектного типа (ТекущиеДанные)

31.08.2011, 16:07. Просмотров 6207. Ответов 16
Метки нет (Все метки)

Ребята всё с суммой сижу
вот модуль
1C
1
2
3
4
5
&НаКлиенте
Процедура ТабличнаяЧасть2Коэф1ПриИзменении(Элемент)
    СтрокаТабличнойЧасти2 =Элементы.ТабличнаяЧасть2.Подвал.ТекущиеДанные;
    СтрокаТабличнойчасти2.ОсновнаяЗарплатаКоэф1 = Параметры.ВсегоПоТаблице2 * СтрокаТабличнойЧасти2.Коэф1;
КонецПроцедуры
пишет ошибку
{Документ.СправкаКЗаказу.Форма.ФормаДокумента.Форма(29)}: Значение не является значением объектного типа (ТекущиеДанные)
СтрокаТабличнойЧасти2 =Элементы.ТабличнаяЧасть2.Подвал.ТекущиеДанные;

у меня в подвале выводится сумма по документу,мне её нужно умножить на коэффицент
подскажите пожалуйста
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.08.2011, 16:07
Ответы с готовыми решениями:

Значение не является значением объектного типа
Создал новую инфобазу 1c, залил туда имеющуюся конфигурацию... (которая...

Значение не является значением объектного типа
Проблема при попытке взять процедуру вычисления скидки из общего модуля. Вот...

Значение не является значением объектного типа
Помогите! Выдает ошибку! (Значение не является значением объектного типа (Цена)...

Значение Не Является Значением Объектного Типа
Создал новую инфобазу 1c, залил туда имеющуюся конфигурацию... (которая...

Значение не является значением объектного типа (ВключатьВОтчет)
Не могу автоматически заполнить Отчет о прибылях и убытках в Бухгалтерской...

16
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
31.08.2011, 16:36 2
ерунду какую то на написал
какой еще Элементы.ТабличнаяЧасть2.Подвал.ТекущиеДанные; ?
Элементы.ТабличнаяЧасть2.Подвал определяет есть ли у таблицы подвал или нет. Смотри в справку.
Опиши суть задачи, что сделать пытаешься

Добавлено через 6 минут
скрин формы сделай и стрелками укажи что на что должно умножаться и куда устанавливаться значение
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
31.08.2011, 16:49  [ТС] 3
Цитата Сообщение от fimbulwinter Посмотреть сообщение
ерунду какую то на написал
какой еще Элементы.ТабличнаяЧасть2.Подвал.ТекущиеДанные; ?
Элементы.ТабличнаяЧасть2.Подвал определяет есть ли у таблицы подвал или нет. Смотри в справку.
Опиши суть задачи, что сделать пытаешься

Добавлено через 6 минут
скрин формы сделай и стрелками укажи что на что должно умножаться и куда устанавливаться значение
сумму всего в шапке нужно умножить на коэф1
полученное значение должно занестись в реквизит (осн зарплата рекв1)
0
Миниатюры
Значение не является значением объектного типа (ТекущиеДанные)  
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
31.08.2011, 16:51 4
коэффициент для каждой позиции таблицы может быть разным. Как в таком случае? просчитывать среднее значение?
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
31.08.2011, 16:56  [ТС] 5
[QUOTE=fimbulwinter;1951892]коэффициент для каждой позиции таблицы может быть разным. Как в таком случае? просчитывать среднее значение?[/QUO


не будет разного,он один определённый 1.6%
и второй опр 1.1%
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
31.08.2011, 17:09 6
код выполняется на сервере

ТабличнаяЧасть2.Итог(<ИмяКолонки>) * Умножаешь на свой коэффициент

вот и вся песня

Добавлено через 9 минут
только учти что коэффициент тебе придется все равно узнать как то
так что либо просчитывать средний по всем позициям, либо брать коэфф. от первой позиции
1
harmless
147 / 147 / 2
Регистрация: 05.05.2010
Сообщений: 569
01.09.2011, 06:20 7
Цитата Сообщение от sucharik Посмотреть сообщение
не будет разного,он один определённый 1.6%
и второй опр 1.1%
Если в каждом документе один коэффициент, не проще реквизит документа добавить?
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
01.09.2011, 14:21  [ТС] 8
Цитата Сообщение от fimbulwinter Посмотреть сообщение
код выполняется на сервере

ТабличнаяЧасть2.Итог(<ИмяКолонки>) * Умножаешь на свой коэффициент

вот и вся песня

Добавлено через 9 минут
только учти что коэффициент тебе придется все равно узнать как то
так что либо просчитывать средний по всем позициям, либо брать коэфф. от первой позиции
Документ.СправкаКЗаказу.Форма.ФормаДокумента.Форма(30,48)}: Переменная не определена (ТабличнаяЧасть2)
СтрокаТабличнойЧасти2.ОсновнаяЗарплатаКоэф1 = <<?>>ТабличнаяЧасть2.Итог("Сумма") * СтрокаТабличнойЧасти2.Коэф1; (Проверка: Сервер)
да что ей надо((((

Добавлено через 4 минуты
Цитата Сообщение от sucharik Посмотреть сообщение
Документ.СправкаКЗаказу.Форма.ФормаДокумента.Форма(30,48)}: Переменная не определена (ТабличнаяЧасть2)
СтрокаТабличнойЧасти2.ОсновнаяЗарплатаКоэф1 = <<?>>ТабличнаяЧасть2.Итог("Сумма") * СтрокаТабличнойЧасти2.Коэф1; (Проверка: Сервер)
да что ей надо((((

&НаСервере
Процедура ТабличнаяЧасть2СуммаПриИзменении(Элемент)
СтрокаТабличнойЧасти2 =Элементы.ТабличнаяЧасть2.ТекущиеДанные;
СтрокаТабличнойЧасти2.ОсновнаяЗарплатаКоэф1 = ТабличнаяЧасти2.Итог("Сумма") * СтрокаТабличнойЧасти2.Коэф1;
КонецПроцедуры

во весь код
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
02.09.2011, 00:06 9
C
1
2
3
4
5
6
7
&НаКлиенте
Процедура Колонка1ПриИзменении(Элемент)
    
    Строка = Элементы.ТЧ.ТекущиеДанные;
    Строка.Колонка3 = ТЧ.Итог("Колонка1") * Строка.Колонка2;
    
КонецПроцедуры
Добавлено через 17 минут
Вот тут примет СКАЧАТЬ ПРИМЕР
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
02.09.2011, 08:33  [ТС] 10
Цитата Сообщение от Dethmontt Посмотреть сообщение
C
1
2
3
4
5
6
7
&НаКлиенте
Процедура Колонка1ПриИзменении(Элемент)
    
    Строка = Элементы.ТЧ.ТекущиеДанные;
    Строка.Колонка3 = ТЧ.Итог("Колонка1") * Строка.Колонка2;
    
КонецПроцедуры
Добавлено через 17 минут
Вот тут примет СКАЧАТЬ ПРИМЕР
&НаКлиенте
Процедура ТабличнаяЧасть2СуммаПриИзменении(Элемент)
СтрокаТабличнойЧасти2 =Элементы.ТабличнаяЧасть2.ТекущиеДанные;
СтрокаТабличнойЧасти2.ОсновнаяЗарплатаКоэф1 =ТабличнаяЧасть2.Итог ("Сумма") * СтрокаТабличнойЧасти2.Коэф1;
КонецПроцедуры

ну вот как то так
вроде бы всё правильно
{Документ.СправкаКЗаказу.Форма.ФормаДокумента.Форма(30,50)}: Переменная не определена (ТабличнаяЧасть2)
СтрокаТабличнойЧасти2.ОсновнаяЗарплатаКоэф1 = <<?>>ТабличнаяЧасть2.Итог ("Сумма") * СтрокаТабличнойЧасти2.Коэф1; (Проверка: Тонкий клиент)
но без ошибки никуда
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
02.09.2011, 10:25 11
ТабличнаяЧасть2.Итог ("Сумма") может выполниться только на сервере.
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
02.09.2011, 17:28 12
Мой пример работает????
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
05.09.2011, 08:28  [ТС] 13
Цитата Сообщение от Dethmontt Посмотреть сообщение
Мой пример работает????
нет,не работает

Добавлено через 22 секунды
Цитата Сообщение от fimbulwinter Посмотреть сообщение
ТабличнаяЧасть2.Итог ("Сумма") может выполниться только на сервере.
на Сервере тоже не работает
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
05.09.2011, 09:08 14
конфигу мылом кинь
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
05.09.2011, 09:18  [ТС] 15
Цитата Сообщение от fimbulwinter Посмотреть сообщение
конфигу мылом кинь
мыло дай скину
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
05.09.2011, 09:19 16
mogul13@mail.ru
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
05.09.2011, 09:24  [ТС] 17
Цитата Сообщение от fimbulwinter Посмотреть сообщение
ошибка,не скидывается

596712778
ICQ
0
05.09.2011, 09:24
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.09.2011, 09:24

Значение не является значением объектного типа (Метаданные)
Здравствуйте. Создала новый документ копированием документа &quot;Реализация...

Значение не является значением объектного типа (Записать)
Как правильно записать результат сравнения в базу? На этот код ругается...

Ошибка Значение не является значением объектного типа (Правила)
Добрый вечер! У меня такая проблема: Обновила ЗУП платформа 1С:Предприятие...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
17
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru