Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/10: Рейтинг темы: голосов - 10, средняя оценка - 4.60
virus555
3 / 3 / 0
Регистрация: 09.03.2011
Сообщений: 61
1

Как сделать НаименованиеПолное = Наименование???

04.09.2011, 11:39. Просмотров 1991. Ответов 2
Метки нет (Все метки)

У меня 1С 8.2 Конфигурация УТ 11.0.4.6
Задача: надо во всех товарах справочника Номенклатура назначить Объект.НаименованиеПолное = Объект.Наименование.

В ФормеЭлемента вставляю код:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
&НаСервере
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
 
Сообщить("Обработка начата");
Спр = Справочники.Номенклатура;
Выборка = Спр.Выбрать( , , , "Код");
        
Пока Выборка.Следующий() Цикл
Объект = Выборка.Ссылка.ПолучитьОбъект();
Если Объект.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;
        
Наименование = СокрЛП(Объект.Наименование);
        
Сообщить("До " + Объект.Наименование);
Сообщить("До " + Объект.НаименованиеПолное);
        
Объект.НаименованиеПолное = Наименование;
Объект.Записать();
                                                               
Сообщить("После " + Объект.Наименование);
Сообщить("После " + Объект.НаименованиеПолное);        
КонецЦикла;
 
Сообщить("Обработка завершена");
КонецПроцедуры
В Конфигураторе Синтаксических ошибок не обнаружено, а в 1С вылазит ошибка:
"{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(128)}: Ошибка при установке значения атрибута контекста (Объект)
Объект = Выборка.Ссылка.ПолучитьОбъект();
по причине: Нельзя изменять поле, содержащее объект данных формы"

Подскажите пожалуйста, что в коде неправильно?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.09.2011, 11:39
Ответы с готовыми решениями:

Получить поле НаименованиеПолное из справочника Контрагенты
Здравствуйте. Создаю документ в конфигурации Бухгалтерия предприятия, редакция 2.0 (2.0.43.6) на...

1С Розница 2.0.7.6 Как сформированить полное наименование номенклатуры?
Добрый день! 1С Розница 2.0.7.6 Слышала, что есть возможность настройки автоматического...

Как изменить Наименование Номенклатуры?
Необходимо изменить Наименования Номенклатур в базе. Штрих-код и соответствующее ему Наименование...

Как получить ПОЛНОЕ наименование организации
Доброго времени суток, простите за идиотский вопрос, как получить полное наименование организации...

Для чего ссылка.наименование как организация в 1с запросах ?
Читал книгу но не понял на том моменте где это объяснялось .Что значит ссылка.наименование как...

2
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
05.09.2011, 09:16 2
где выполняется этот код?
Вместо Объект напиши Товар
1
virus555
3 / 3 / 0
Регистрация: 09.03.2011
Сообщений: 61
05.09.2011, 09:35  [ТС] 3
Да спасибо, но после переименования всё равно не переименовывалась вся номенклатура. Сделал всё с помощью Универсальные Подбор И Обработка Объектов. Всё равно спасибо за ответ.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.09.2011, 09:35

Как при выборе элемента справочника сделать отображение кода, а не наименование?
имеется таб. часть, в ней поле с типом справочникссылка. как при выборе элемента в этом поле...

Как добавить наименование в заголовок макета
Всем привет, такая проблема: Есть справочники "Ученики" и "Классы", в классах есть печать, в...

Как сделать, так чтобы программа выводила наименование цвета, как здесь?
http://colors.aeio.ru/color/fffffe Я создал базу из 1002 цветов но это вообще не то. Я подгрузил...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru