Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.85/55: Рейтинг темы: голосов - 55, средняя оценка - 4.85
temi4444
0 / 0 / 0
Регистрация: 17.05.2011
Сообщений: 27
1

Ошибка при вызове метода контекста (ПолучитьОбъект)

05.09.2011, 12:53. Просмотров 10315. Ответов 6
Метки нет (Все метки)

Привет народ Программа ругается что:
{Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста (ПолучитьОбъект)
лОбъект = ДокументПересчета.ПолучитьОбъект();

не пойму почему ошибка при вызове

вот код
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Процедура КнопкаВыполнитьНажатие(Кнопка)
    
 
    лОбъект = ДокументПересчета.ПолучитьОбъект("VM-00000002");   
    Для Каждого СтрТабл Из лОбъект.Товары Цикл
        Если СтрТабл.Количество > 0 Тогда
            СтрТабл.КоличествоФакт = СтрТабл.Количество;
            СтрТабл.Количество = 0;
        КонецЕсли;
        Если СтрТабл.Количество < 0 Тогда 
            СтрТабл.Количество = СтрТабл.Количество*(-1);
            //СтрТабл.Количество = 0;
        КонецЕсли;
    КонецЦикла;
    лОбъект.Записать(РежимЗаписиДокумента.Запись);     
КонецПроцедуры
1с запущена в режиме совместимости с 8.1

Просветите пожалуйста как победить эту ошибку
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.09.2011, 12:53
Ответы с готовыми решениями:

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста
есть ссылка &quot;e79ba7ae-0747-11db-9244-0011955c22cb&quot;... как присвоить ее новому элементу справочника...

Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: При выборе...

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений...

Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран
В УТ 8.2 скопировал печатную форму &quot;Сравнительная накладная &quot; из РеализацияТоваровУслуг в Заказ...

6
Dethmontt
Модератор
Эксперт 1С
2745 / 2502 / 443
Регистрация: 10.03.2011
Сообщений: 9,118
Записей в блоге: 1
Завершенные тесты: 1
05.09.2011, 13:33 2
ДокументПересчета - Что это такое???

Добавлено через 29 секунд
C
1
лОбъект = ДокументПересчета.ПолучитьОбъект(); //Вот так
0
temi4444
0 / 0 / 0
Регистрация: 17.05.2011
Сообщений: 27
05.09.2011, 14:15  [ТС] 3
Так тоже пробовал выдает ошибку такую же
0
Dethmontt
Модератор
Эксперт 1С
2745 / 2502 / 443
Регистрация: 10.03.2011
Сообщений: 9,118
Записей в блоге: 1
Завершенные тесты: 1
06.09.2011, 00:40 4
Во первых - какая платформа???
во вторых - управляемые формы или нет???
В третьих - Что за переменная ДокументПересчета??? Какой тип у этой переменной?
Ответ начала на эти вопросы
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
06.09.2011, 13:52 5
прежде чем получить объект необходимо иметь на него ссылку
ДокументПересчета скорее всего документ менеджер
0
anateron
20 / 21 / 3
Регистрация: 04.09.2011
Сообщений: 185
08.09.2011, 09:27 6
Сначала ты должен получить ссылку на объект, а уже потом сам объект.
ПРИМЕР: Справочники. Номенклатура.НайтиПоКоду("0000001").ПолучитьОбъект;
Естественно он ругнется ведь он не понимает какой объект ты хочешь получить
0
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
08.09.2011, 09:32 7
Цитата Сообщение от anateron Посмотреть сообщение
Сначала ты должен получить ссылку на объект, а уже потом сам объект.
ПРИМЕР: Справочники. Номенклатура.НайтиПоКоду("0000001").ПолучитьОбъект;
Естественно он ругнется ведь он не понимает какой объект ты хочешь получить
1. ПолучитьОбъект это метод, так что скобки забыл
2. Может и не покатить. Все зависит от ситуации.

ТоварСсылка = Справочники. Номенклатура.НайтиПоКоду("0000001");

Если НЕ ТоварСсылка = Справочники.Номенклатура.ПустаяСсылка() Тогда
Товар = ТоварСсылка.ПолучитьОбъект();
КонецЕсли;
0
08.09.2011, 09:32
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.09.2011, 09:32

Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)
1C 8.2 Документооборот КОРП 1.2 Текст ошибки...

Ошибка при вызове метода контекста по причине испльзование модальных окон в данном режиме запрещено
Здравствуйте! столкнулась вот с такой ошибкой, понятия не имею, что делать. Сделала все по...

Не удалось сформировать внешнюю печатную форму(толстую)! Ошибка при вызове метода контекста (Выполнить): {(14, 1)}: Синтаксическая ошибка "ИЗ" <<?>>ИЗ
Подскажите, пожалуйста. Выбрал для счета только услуги, написал: Шапка =...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.