Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
МагаМ
0 / 0 / 0
Регистрация: 28.09.2011
Сообщений: 16
1

Дата в модуле отчета

03.10.2011, 08:59. Просмотров 922. Ответов 3
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура Сформировать()
    БИ = СоздатьОбъект("БухгалтерскиеИтоги");
    БИ.ИспользоватьСубконто("Контрагенты");
    БИ.ВыполнитьЗапрос(,ТекущаяДата(),"60");
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    БИ.ВыбратьСубконто();
    Пока БИ.ПолучитьСубконто() = 1 Цикл
        СуммаЗадолженности = БИ.СКК();
        Если СуммаЗадолженности > 0 Тогда
            Наименование = БИ.Субконто(); 
            КонецЕсли;
            Если СуммаЗадолженности > МаксимальнаяСумма Тогда
            Таб.ВывестиСекцию("СтрокаЦветная"); 
        Иначе
            Таб.ВывестиСекцию("Строка");
            
        КонецЕсли;
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,0,0);
    Таб.Показать("Печать справки о задалженности поставщикам");       
    
КонецПроцедуры
при запуске в 1с пишет
"БИ.ВыполнитьЗапрос(,ТекущаяДата(),"60");
{Отчет.ЗадолженностьПоставщикам.Форма.Модуль(5)}: За данный период бухгалтерские итоги не рассчитаны!"
а мне нужно показоть что он работаетю Что делать? плиииииз
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.10.2011, 08:59
Ответы с готовыми решениями:

Помогите найти ошибки в модуле отчета
//******************************************* Процедура Сформировать() БИ =...

Текущая дата в запросе отчета
Здравствуйте, у меня такая проблема: нужно вывести в отчете список сотрудников, которые прошли...

1C 8.1 Редактирование отчета созданного с помощью универсального отчета
Создал отчет с помощью универсального отчета, все работает, не получается сделать его "красивым"...

Передать данные из настроек отчета в поле ввода формы отчета
Всем привет! Подскажите, пожалуйста, вот есть: Внешний отчет, реквизит ДатаНачало с типом Дата...

Дается две даты: дата начала и дата окончания. Высчитать между ними часы, минуты, секунды
Здравствуйте многоуважаемые форумчане!!! Прошу Вас помочь новичку сколько бьюсь над этой темой...

3
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
03.10.2011, 09:47 2
расчитать итоги за заданный период
Операции->Управление бухгалтерскими итогами
1
МагаМ
0 / 0 / 0
Регистрация: 28.09.2011
Сообщений: 16
03.10.2011, 10:00  [ТС] 3
А как задать дату в модуле
0
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
04.10.2011, 02:11 4
Дата("20110101000000")
0
04.10.2011, 02:11
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.10.2011, 02:11

Дата формирования отчета
Имеется запрос: SELECT `niveau_hierar` as Тип, year(`create_date`)as Год, count(*)as...

Создание отчета по заданному значению из поля "Дата"
Здравствуйте! Имеется БД со следующими полями: "№" (он же код), "дата", и т.д. и последнее поле -...

Отчет. Как вывести поле из запроса в название отчета, но не выводить его в теле отчета?
Друзья, привет! Помогите плиз советом.. Задача стоит такая: строю отчет на базе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru