Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/5: Рейтинг темы: голосов - 5, средняя оценка - 5.00
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
1

Ошибка в модуле печатной формы

03.10.2011, 10:09. Просмотров 863. Ответов 5
Метки нет (Все метки)

Подскажите пожалуйста вот модуль
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
Процедура РасчётЦены(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(РасчётЦены)
    Макет = Документы.СправкаКЗаказу.ПолучитьМакет("РасчётЦены");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   СправкаКЗаказу.Заказчик,
    |   СправкаКЗаказу.КалькуляционнаяЕдиница,
    |   СправкаКЗаказу.Наименование,
    |   СправкаКЗаказу.НомерЗаказа,
    |   СправкаКЗаказу.ЦехИзготовитель,
    |   СправкаКЗаказу.ОсновнаяЗарплатаВсего,
    |   СправкаКЗаказу.ДополнительнаяЗПлатаПроизвРабочих,
    |   СправкаКЗаказу.СтраховыеВзносы
    |ИЗ
    |   Документ.СправкаКЗаказу КАК СправкаКЗаказу
    |ГДЕ
    |   СправкаКЗаказу.Ссылка В (&Ссылка)";
    
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
 
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьЗаголовок1 = Макет.ПолучитьОбласть("Заголовок1");
    ОбластьПоле1 = Макет.ПолучитьОбласть("Поле1");
    ОбластьПоле2 = Макет.ПолучитьОбласть("Поле2");
    ОбластьПоле3 = Макет.ПолучитьОбласть("Поле3");
    
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Очистить();
 
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
      ОбластьПоле3.Параметры.СтраховыеВзносыРасчёт =(ОбластьПоле3.Параметры.ОсновнаяЗарплатаВсего + ОбластьПоле3.Параметры.ДополнительнаяЗПлатаПроизвРабочих) * ОбластьПоле3.Параметры.СтраховыеВзносы;
        
      ОбластьПоле3.Параметры.Заполнить(Выборка);
     
 
        ТабДок.Вывести(ОбластьЗаголовок1);
        ТабДок.Вывести(ОбластьЗаголовок);
    
        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());
        ТабДок.Вывести(ОбластьПоле1);
        ТабДок.Вывести(ОбластьПоле2);
        ТабДок.Вывести(ОбластьПоле3);
        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры
Выдаёт ошибку
{Документ.СправкаКЗаказу.МодульМенеджера(243)}: Преобразование значения к типу Число не может быть выполнено
ОбластьПоле3.Параметры.СтраховыеВзносыРасчёт =(ОбластьПоле3.Параметры.ОсновнаяЗарплатаВсего + ОбластьПоле3.Параметры.ДополнительнаяЗПлатаПроизвРабочих) * ОбластьПоле3.Параметры.СтраховыеВзносы;
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
03.10.2011, 10:09
Ответы с готовыми решениями:

Ошибка При Создании Внешней Печатной Формы Т - 10а
Здравствуйте! Помогите пожалуйста. Я не программист, только учусь. Нашла в интернете ролик, как...

Закрытие формы документа из внешней печатной формы
Нужно после печати документа, закрыть его форму. Управляемое приложение. Никак не могу понять прошу...

Модуль печатной формы
1)И снова здравствуйте,вчера пол дня просидел не чего не получилось. Есть документ...

Добавление печатной формы
Подскажите пожалуйста,вот у меня есть документ.В этом документе есть макет печатной формы который я...

Создание внешней печатной формы 1с 8.2
Ммм собственно совсем "малыш" в вопросе 1с, только начал изучать, попробовал воспользоваться тут...

5
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
03.10.2011, 10:17 2
посмотри какой тип имеют
ОбластьПоле3.Параметры.ОсновнаяЗарплатаВсего
ОбластьПоле3.Параметры.ДополнительнаяЗПлатаПроизвРабочих
ОбластьПоле3.Параметры.СтраховыеВзносы
0
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
03.10.2011, 10:28  [ТС] 3
Цитата Сообщение от fimbulwinter Посмотреть сообщение
посмотри какой тип имеют
ОбластьПоле3.Параметры.ОсновнаяЗарплатаВсего
ОбластьПоле3.Параметры.ДополнительнаяЗПлатаПроизвРабочих
ОбластьПоле3.Параметры.СтраховыеВзносы
Как посмотреть тип у параметра печатной формы?
0
Миниатюры
Ошибка в модуле печатной формы  
Dethmontt
Модератор
Эксперт 1С
2674 / 2456 / 426
Регистрация: 10.03.2011
Сообщений: 8,805
Записей в блоге: 1
Завершенные тесты: 1
04.10.2011, 02:16 4
"А"+1*"Б" - какой результат будет???????????

Добавлено через 34 секунды
Смотри типы!!!!!!!!!!!!! Макет тут воооообще не причом!!!!!!!!!!!!!!!!!!!!!!!
1
Flamepain
31 / 31 / 0
Регистрация: 19.03.2011
Сообщений: 100
04.10.2011, 04:34 5
Интересный код получается, дословно:
ОбластьПоле3.Параметры.СтраховыеВзносыРасчёт=(ПустоеЗначение+пустоеЗначение)*ПустоеЗначение. Интересно, что получится?
Код
Код
ОбластьПоле3.Параметры.Заполнить(Выборка)
ставтье до Вашей арифметики.
1
sucharik
0 / 0 / 0
Регистрация: 23.08.2011
Сообщений: 134
04.10.2011, 08:09  [ТС] 6
Спасибо всё получилось))))
0
04.10.2011, 08:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.10.2011, 08:09

Создание макета печатной формы
Добрый вечер. Почти доделал макет. Осталось сделать подвал. Не соображу, как сделать так ячейки,...

добавление печатной формы ценника
добрый день! ТОрговля 9.2 Если открыть в справочнике номенклатура какую либо позицию, то там есть...

Перекрытие ячеек печатной формы
Есть такая проблема. В печатной форме документа при выводе вертикальных секций перекрытие текста...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru