Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
anti_angel
0 / 0 / 0
Регистрация: 26.10.2011
Сообщений: 6
#1

Поместить картинки на обновляемую форму - 1С

12.01.2012, 17:29. Просмотров 1126. Ответов 1
Метки нет (Все метки)

Всем здравствуйте!
Столкнулся с такой проблемой: 1с 8.2, необходимо в документе при выборе в ТЧ номенклатуры показывать ее изображение (для этого я добавил на форму ПолеКартинка, в котором ПутьКДанным указал на реквизит АдресКартинки - строка). И добавил такой вот код:
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    АдресКаталога = ПолучитьАдрес();
    ВыбФайл = Новый Файл(АдресКаталога + "" + Элемент.текстредактирования + ".JPG");
        Если ВыбФайл.Существует() Тогда     
            ПоместитьФайл(АдресКартинки, ВыбФайл.ПолноеИмя,,Ложь,)
    Иначе 
        Сообщить("Файл " + ВыбФайл.ПолноеИмя + " не найден");
    КонецЕсли;
КонецПроцедуры
(Все картинки находятся на жестком в одной папке и их имена совпадают с название номенклатуры)
Это в принципе работает (картинка появляется), но только один раз. Как только выбираешь другую номенклатуры выскакивает критическая ошибка "Ошибка при работе с ресурсом". Помогите разобраться!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.01.2012, 17:29
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Поместить картинки на обновляемую форму (1С):

Вывод Картинки На Форму
Ситуация такая - в базе хранится картинка в виде ХранилищеЗначения. Мне нужно...

Вывод картинки на форму
Ситуация такая - в базе хранится картинка в виде ХранилищеЗначения. Мне нужно...

Вывод картинки на печатную форму
Чтобы при нажатии кнопки Печать картинка отображалась на печатной форме.

ЗуП -> добавление картинки в форму списка "справочника сотрудники"
Здравствуйте уважаемые программисты . приму любой совет от знающих людей ....

Вставка картинки на форму документа
Здравствуйте! Конфигурация УТ 10.3. Для документа РеализацияТоваровУслуг...

Рассчитать сумму ВСЕГО документа и поместить её на форму в виде реквизита
Здравствуйте. Помогите, пожалуйста, рассчитать сумму ВСЕГО созданного документа...

1
Dethmontt
Модератор
Эксперт 1С
2582 / 2383 / 393
Регистрация: 10.03.2011
Сообщений: 8,451
Записей в блоге: 1
Завершенные тесты: 1
12.01.2012, 18:06 #2
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
&НаКлиенте
Процедура Команда1(Команда)
    
    Адрес = "";
    Выбфайл = "";
    Если ПоместитьФайл(Адрес,,Выбфайл,,УникальныйИдентификатор) Тогда 
        
        Элементы.Имя.Видимость = Истина;
        мФайл = Новый Файл(Выбфайл);
        имя = мФайл.Имя;
        СсылкаНа = Адрес;
        
        Модифицированность = Истина;
        
    КонецЕсли;
    
КонецПроцедуры
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    Если Объект.ИмяФ <> "" Тогда 
        СсылкаНа = ПолучитьНавигационнуюСсылку(Объект.Ссылка,"Файл");
    КонецЕсли;
        
КонецПроцедуры
 
&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    Если ЭтоАдресВременногоХранилища(СсылкаНа) Тогда 
        Двд = ПолучитьИзВременногоХранилища(СсылкаНа);
        ТекущийОбъект.Файл = Новый ХранилищеЗначения(Двд, Новый СжатиеДанных(9));
        ТекущийОбъект.ИмяФ = Имя;
    КонецЕсли;  
    
КонецПроцедуры
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.01.2012, 18:06
Привет! Вот еще темы с решениями:

Как реализовать загрузку картинки на хостинг через форму и поместить путь к этой картинке в переменную?
Как реализовать загрузку картинки на хостинг через форму и поместить путь к...

Rак можно поместить форму на форму по аналогии с поведением TFrame в Borland
Кто может дать рекомендации как создать окно настроек СИ WINAPI В программе...

Поместить текст поверх картинки
Не могу заставить текст встать в картинку, текст выходит всегда выше фона...

Поместить 4 картинки друг за другом
Здравствуйте, Подскажите пожалуйста как поместить 4 картинки друг за...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru