Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/12: Рейтинг темы: голосов - 12, средняя оценка - 4.67
MaTuAc
0 / 0 / 0
Регистрация: 12.01.2012
Сообщений: 8
1

Внешняя печатная форма

12.01.2012, 18:51. Просмотров 2305. Ответов 7
Метки нет (Все метки)

Здравствуйте.

Я только знакомлюсь с «языком» 1с, поэтому решил обратиться за советом.

Есть внешняя печатная форма для распечатывания накладной. В ней надо сделать так, чтобы если период оказания услуги равнялся одному дню, то эта строка не появлялась бы в печати.

Принципиально задача лёгкая, но с синтаксисом 1с я не знаком вообще, поэтому прошу посмотреть и сказать, сможет ли работать следующий код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
    Если (СсылкаНаОбъект.НачалоПериодаУслуги = СсылкаНаОбъект.ОкончаниеПериодаУслуги)
 
    Тогда
 
        Прервать;
 
    Иначе
 
        Период = "no "+Формат(СсылкаНаОбъект.НачалоПериодаУслуги,"ДЛФ=Д")+" lД«dz "+Формат(СсылкаНаОбъект.ОкончаниеПериодаУслуги,"ДЛФ=Д"); ///
 
    ОбластьШапкаНачало.Параметры.Период = СокрЛП(Период);                      ///
 
    КонецЕсли;
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.01.2012, 18:51
Ответы с готовыми решениями:

Внешняя печатная форма
Товарищи работающие в 1С 7.7 хелп!!! =) Ни разу не работал в 7 поэтому у меня щас жуткая паника!...

Внешняя печатная форма в 1С 7.7
Всем доброго дня! Появилась необходимость добавить в 1С 7.7 Бухгалтерию внешнюю печатную форму для...

Внешняя печатная форма
У меня есть документ СчетФактураВыданный. Когда его распечатываешь то в получившейся форме есть...

Внешняя печатная форма
Делал внешнюю печатная форма к ЗУП к документу "Зарплата к выплате". Там впринципе всё просто....

Внешняя печатная форма КС-2 и КС-3
Здравствуйте, я не программист, а бухгалтер. Очень понадобились внешние печатные формы КС-2 и КС-3...

7
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,793
Записей в блоге: 1
Завершенные тесты: 1
13.01.2012, 02:21 2
А что ты пытаешься прервать?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Если Не ЗначениеЗаполнено(СсылкаНаОбъект) Тогда
Возврат;
КонецЕсли;
Если НачалоДня(СсылкаНаОбъект.НачалоПериодаУслуги) = НачалоДня(СсылкаНаОбъект.ОкончаниеПериодаУслуги)
 
    Тогда
 
        Период = "";
 
    Иначе
 
        Период = "no "+Формат(СсылкаНаОбъект.НачалоПериодаУслуги,"ДЛФ=Д")+" lД«dz "+Формат(СсылкаНаОбъект.ОкончаниеПериодаУслуги,"ДЛФ=Д"); ///
 
    КонецЕсли;
ОбластьШапкаНачало.Параметры.Период = СокрЛП(Период);                      ///
1
MaTuAc
0 / 0 / 0
Регистрация: 12.01.2012
Сообщений: 8
13.01.2012, 12:25  [ТС] 3
Из прочитанного мной «Прервать» прерывает выполнение цикла. Я так понял, что совершается выход из цикла и строка не создаётся вообще, ни пустая, ни заполненная.

А в этом случае будет создаваться пустая строка, так?
0
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,793
Записей в блоге: 1
Завершенные тесты: 1
13.01.2012, 23:27 4
Цитата Сообщение от MaTuAc Посмотреть сообщение
Из прочитанного мной «Прервать» прерывает выполнение цикла. Я так понял, что совершается выход из цикла и строка не создаётся вообще, ни пустая, ни заполненная
Прервать - прерывает цикл, а цикл то у тебя где???

Цитата Сообщение от MaTuAc Посмотреть сообщение
А в этом случае будет создаваться пустая строка, так?
Совершенно верно!
0
13.01.2012, 23:27
MaTuAc
0 / 0 / 0
Регистрация: 12.01.2012
Сообщений: 8
14.01.2012, 12:11  [ТС] 5
Понял. Спасибо.
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
14.01.2012, 21:35 6
Цитата Сообщение от MaTuAc Посмотреть сообщение
Если (СсылкаНаОбъект.НачалоПериодаУслуги = СсылкаНаОбъект.ОкончаниеПериодаУслуги)
PHP
1
Если НачалоДня(СсылкаНаОбъект.НачалоПериодаУслуги) = НачалоДня(СсылкаНаОбъект. ОкончаниеПериодаУслуги) Тогда Прервать;КонецЕсли;
0
Dethmontt
Модератор
Эксперт 1С
2672 / 2455 / 425
Регистрация: 10.03.2011
Сообщений: 8,793
Записей в блоге: 1
Завершенные тесты: 1
14.01.2012, 23:22 7
Почему прервать то? Где вы тут цикл то увидели???
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
15.01.2012, 17:40 8
Это не ко мне
Вообще, буквосочетание "Выборка" предполагает цикл. Надо, конечно, объяснить человеку, что эту выборку надо получить запросом. Но влом, честно говоря. Нерентабельно
0
15.01.2012, 17:40
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.01.2012, 17:40

Внешняя печатная форма
Народ! Помогите, пожалуйста! Делаю ВПФ Торг12 для дока ПередачаТоваров. Конфа БП 2.0. Выскакивает...

Внешняя печатная форма
Подскажите пожалуйста,как привязать внешнюю печатную форму к документу в 1с 8.2

Внешняя печатная форма
Народ! Такая проблема. Делаю впф Торг12 для БП 3.0! До этого уже несколько форм делал на упр...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru