Форум программистов, компьютерный форум, киберфорум
Наши страницы

Войти
Регистрация
Восстановить пароль
 
Tleck
7 / 7 / 0
Регистрация: 11.09.2011
Сообщений: 128
#1

Сортировка по параметру в отчете - 1С

14.01.2012, 17:45. Просмотров 904. Ответов 0
Метки нет (Все метки)

Здравствуйте всем!

В 1С новичок.
Делаю балансовый отчет, необходимо, чтобы сортировка шла по полю КодСтроки, которую я ввожу самостоятельно. В ней числа следующего формата: 10, 10.1, 10.2, 13, 13.4 и т.д. Т.е. не целые. Где нужно задавать условие сортировки или есть ли такая функция.
Вот код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
Процедура КнопкаСформироватьНажатие(Кнопка)
    СуммаМай = 0;
    СуммаИюнь = 0;
    ТабДок = Новый ТабличныйДокумент;
    Макет = Отчеты.Баланс.ПолучитьМакет("МакетБаланс");
    //Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(Область);
    //Выборка
    Выборка = Справочники.Наименование.ВыбратьИерархически();
    Пока Выборка.Следующий() Цикл
        Если Выборка.ЭтоГруппа = Истина Тогда
            ОбластьТабЧасти = Макет.ПолучитьОбласть("Раздел");
            ОбластьТабЧасти.Параметры.Раздел = Выборка.Наименование;
        Иначе
            Если Выборка.КодСтроки<100 Тогда
                ОбластьТабЧасти = Макет.ПолучитьОбласть("Значение");
                ОбластьТабЧасти.Параметры.Уточнение = Выборка.Наименование;
                ОбластьТабЧасти.Параметры.КодСтроки = Выборка.КодСтроки;
                ОбластьТабЧасти.Параметры.НаМай = Выборка.НаМай;
                СуммаМай = СуммаМай + Выборка.НаМай;
                ОбластьТабЧасти.Параметры.НаИюнь = Выборка.НаИюнь;
                СуммаИюнь = СуммаИюнь + Выборка.НаИюнь;
            Иначе ОбластьТабЧасти = Макет.ПолучитьОбласть("Итог");
                ОбластьТабЧасти.Параметры.Итог = Выборка.Наименование;
                ОбластьТабЧасти.Параметры.КодСтроки = Выборка.КодСтроки;
                ОбластьТабЧасти.Параметры.НаМай = СуммаМай;
                ОбластьТабЧасти.Параметры.НаИюнь = СуммаИюнь;
            КонецЕсли;
        КонецЕсли;
        ТабДок.Вывести(ОбластьТабЧасти);
    КонецЦикла;
Как видите отчет формируется из иерархического справочника.

Добавлено через 2 часа 5 минут
Отбой, сделал.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.01.2012, 17:45
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Сортировка по параметру в отчете (1С):

Сортировка в отчете - 1С
Надо сделать интерактивную сортировку по колонке &quot;%&quot;. Чтоб был тип булево и когда ставишь галочку, то сортирует в порядке убывания....

Подсчет количества строк по параметру - 1С
Здравствуйте. У меня есть 2 таблицы - &quot;Пользователи&quot; и &quot;События&quot;. Первую я заполняю с помощью списка выбора из массива пользователей БД....

Ошибка в отчете - 1С
Создал стандартный бухгалтерский отчет через конструктор, т.е. выбирается счет и период анализа - и должен формироваться отчет, но он...

Дата в отчете - 1С
В отчете вмето даты выдает (Задолженность поставщикам на ) чё делать?

период в отчете - 1С
Добрый день. Помогите, пожалуйста. Надо сделать справку о заработной плате. Как правильно сделать период, который будет пользователь...

Данные в отчете - 1С
Добрый день. Есть отчет по суммам доставки, нужно в этом отчете чтобы учитывалась сумма поступления денежных средств, т.к. оплата по...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.01.2012, 17:45
Привет! Вот еще темы с ответами:

Таблица в отчете - 1С
Прошу подсказать Создается печатная форма платежной ведомости При параметрах Табличный документ установленный шрифт размер 8 см...

1C 7.x Условие в отчете - 1С
Добрый День, подскажите пожалуйста...хочу сделать чтобы по чекеру в отчет добовлялись строки документа по Признаку Выполнения...Например...

Сортировка по параметру - Java SE
Подскажите пожалуйста. Есть класс public class el{ int number; String name; Date date; } Если ArrayList:

Сортировка коллекции по параметру - C#
Как произвести сортировку коллекции с несколькими значениями, к примеру в алфавитном порядке авторов, т.е. в данном случае по параметру...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru