Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/7: Рейтинг темы: голосов - 7, средняя оценка - 4.86
Мариночка!
0 / 0 / 0
Регистрация: 19.07.2011
Сообщений: 5
1

Cоздать ссылку на реквизит "Наименование" справочника "Специалисты" из справочника "ЗаявкаНаОбучениеКлиентов"

04.03.2012, 18:29. Просмотров 1287. Ответов 2
Метки нет (Все метки)

Пожалуйста, подскажите. Необходимо создать ссылку на реквизит "Наименование" справочника "Специалисты" из справочника "ЗаявкаНаОбучениеКлиентов". Чтобы можно было выбрать при помощи кнопки выбора выбрать соответствующий реквизит из другого справочника. Это очень похоже на то, что можно сделать на вкладке "Владельцы". Я создала форму элемента, добавила у нужного реквизита кнопку выбора и затем мне необходимо было прописать процедуру НачалоВыбораИзСписка. Она приведена ниже:
1C
1
2
3
4
5
6
7
8
9
&НаСервере
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
КнопкаВыбора = ВыбратьИзСписка(Справочники.Специалисты.НайтиПоНаименованию());
КонецПроцедуры
 
&НаКлиенте
Процедура СсылкаНаРеквизит ()
НаименованиеНачалоВыбораИзСписка (Элемент, СтандартнаяОбработка);
КонецПроцедуры
Ссылку нужно сделать именно таким способом (не через вкладку справочника "Владельцы").

В итоге вышли следующие ошибки:

{Справочник.ЗаявкаНаОбучениеКлиентов.Форма.ФормаЭлемента.Форма(4,35)}: Переменная не определена (Элемент)
НаименованиеНачалоВыбораИзСписка (<<?>>Элемент, СтандартнаяОбработка); (Проверка: Тонкий клиент)
{Справочник.ЗаявкаНаОбучениеКлиентов.Форма.ФормаЭлемента.Форма(4,44)}: Переменная не определена (СтандартнаяОбработка)
НаименованиеНачалоВыбораИзСписка (Элемент, <<?>>СтандартнаяОбработка); (Проверка: Тонкий клиент)

Добавлено через 8 минут
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура СсылкаНаРеквизит ()
НаименованиеНачалоВыбораИзСписка ();
КонецПроцедуры
 
 
&НаСервере
Процедура НаименованиеНачалоВыбораИзСписка()
КнопкаВыбора = ВыбратьИзСписка(Справочники.Специалисты.НайтиПоНаименованию());
КонецПроцедуры
убрала из скобок процедур параметры, в итоге при нажатии на кнопку выбора ничего не происходит. Подскажите, пожалуйста, что я делаю не так....
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.03.2012, 18:29
Ответы с готовыми решениями:

Не получается скопировать выделенные строчки из справочника "Сотрудники" в форму "Выбор"
Здравствуйте! У меня опыта работы с 1С мало поэтому хотел попросить помощи у более опытных коллег....

1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура"
Всем добрый день! Нужна помощь. В Форму элемента &quot;Номенклатура&quot; нужно добавить два поля с выводом...

ЗуП -> добавление картинки в форму списка "справочника сотрудники"
Здравствуйте уважаемые программисты . приму любой совет от знающих людей . стоит задача в ЗуП...

8.3 Упр.приложение - Как "красивее" записать элемент справочника ?
Необходимо при записи нового элемента справочника создать др.элементы с указанием ссылки на этот...

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...

2
fimbulwinter
308 / 308 / 1
Регистрация: 16.01.2011
Сообщений: 1,073
04.03.2012, 20:26 2
во первых очень похоже что НаименованиеНачалоВыбораИзСписка это событие, поэтому
НаименованиеНачалоВыбораИзСписка (Элемент, СтандартнаяОбработка)
во вторых если это все же событие, тогда оно исполняется на клиенте
&НаКлиенте
Процедура НаименованиеНачалоВыбораИзСписка (Элемент, СтандартнаяОбработка)

сл-но полный код должен выглядеть примерно следующим образом
1C
1
2
3
4
5
6
7
8
9
10
&НаКлиенте
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
СсылкаНаРеквизит();
КонецПроцедуры
 
 
&НаСервере
Процедура СсылкаНаРеквизит()
КнопкаВыбора = ВыбратьИзСписка(Справочники.Специалисты.НайтиПоНаименованию()); // Хня, так не заработает.
КонецПроцедуры
0
Мариночка!
0 / 0 / 0
Регистрация: 19.07.2011
Сообщений: 5
04.03.2012, 21:03  [ТС] 3
да, так и не заработало...
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.03.2012, 21:03

Кто может поделиться конфигурацией и базой для "общепита" или "ресторана", хочу потестить
Кто может поделиться конфигурацией и базой для 1с предприятие общепит или ресторан, хочу потестить.

DVD-диском от книги "Профессиональная разработка в системе "1С: Предприятие 8" в двух томах"
Добрый день, товарищи! Есть такая книга: У кого есть от нее DVD? Поделитесь, пожалуйста, если у...

Вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет"
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru