Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/12: Рейтинг темы: голосов - 12, средняя оценка - 4.92
pneumo
0 / 0 / 0
Регистрация: 17.03.2012
Сообщений: 1
1

Не работает внешний отчет

20.03.2012, 16:27. Просмотров 2227. Ответов 8
Метки нет (Все метки)

1С:Бухгалтерия 8.2 Создаю внешний отчет для выгрузки документов Списание с расчетного счета в текстовый файл для дальнейшей загрузки в 1С. Код следующий:
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура КнопкаВыполнитьНажатие(Кнопка)
Путь = "C:\spis.csv"; 
Текст = Новый ЗаписьТекста(Путь, КодировкаТекста.UTF8); 
Выборка = Документы.СписаниеСРасчетногоСчета.Выбрать(Дата(2012, 1, 1)); 
Пока Выборка.Следующий() Цикл
ПеременнаяДляВывода = Формат(Выборка.Дата,"ДФ=dd.MM.yyyy") + ";" + Строка(Выборка.Номер) + ";" + Строка(Выборка.Контрагент) + ";" + Строка(Выборка.СтатьяДвиженияДенежныхСредств) + ";" + Формат(Выборка.СуммаДокумента, "ЧГ=0; ЧРД=,") + ";";
Сообщить(Строка(Выборка.СтатьяДвиженияДенежныхСредств.Наименование));
Текст.ЗаписатьСтроку(ПеременнаяДляВывода);
КонецЦикла; 
Текст.Закрыть();
КонецПроцедуры
Все работает, все пишет, все нормально, единственная проблема пустое место вместо Статьи движения денежных средств, хотя в документах они заполнены. Подскажите как поправить код, чтобы работал. я новичок, не судите строго.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.03.2012, 16:27
Ответы с готовыми решениями:

Внешний отчет 1С 8.1
Народ, помогите!!!! работаю в 1С 8.1 "Управление торговлей", в программировании совершенно не шарю....

Внешний регламентированный отчет
Всем привет! Написал свой регламентированный отчет, формируется и записывается в документ...

Внешний отчет по справочнику
Вопрос вот в чем: есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь...

Составить внешний отчет 1с-8.2
Ребята, подскажите последовательность действий для создания внешнего отчета. Реализация по...

Внешний отчет о скидках
С Новым Годом! Подскажите пожста как реализовать отчет о скидках которые были поставлены в ручную....

8
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
20.03.2012, 17:06 2
Попробуй СДДС.Значение может быть или типа того кажется)
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
20.03.2012, 21:11 3
СтатьяДвиженияДенежныхСредств - это реквизит табличной части
C
1
2
3
Для каждого Строка Из выборка.РасшифровкаПлатежа Цикл
Сообщить(Строка.СтатьяДвиженияДенежныхСредств);
КонецЦикла;
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
20.03.2012, 22:34 4
SQL
1
Выборка.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
20.03.2012, 22:36 5
Цитата Сообщение от duk337 Посмотреть сообщение
Выборка.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств
А если в табличной части ничего нет?
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
20.03.2012, 22:40 6
Цитата Сообщение от Dethmontt Посмотреть сообщение
А если в табличной части ничего нет?
Всегда есть. Зуб даю. Там же шапка содержит реквы строки, которая создаётся принудительно
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
20.03.2012, 22:46 7
Не всегда =)))
Хорошо, а если там 4е элемента или 10ть СДДС? =))))))

Добавлено через 3 минуты
Строка там появляется только при Интерактивном открытии
А документ можно создать еще и програмно... =)))
C
1
2
3
4
5
Процедура ПриОткрытии()
 
    Если РасшифровкаПлатежа.Количество() = 0 Тогда
        РасшифровкаПлатежа.Добавить();
    КонецЕсли;
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
20.03.2012, 22:48 8
Тогда бы человек знал, что это ТЧ. А вообще писать такую штуку - только в реквизитах путаться... Вывод дока (отчёт) конструктором - и золотой ключик в наших руках
0
Gokusa
Заблокирован
20.03.2012, 23:28 9
НЕ МОГУ СОЗДАТЬ ТЕМУ, ПИШЕТ "НАЗВАНИЕ ДОЛЖНО ОТРАЖАТЬ И УСТАНОВИТЕ ПЛАГИНЫ"Создайте кто-нить моё сообщение в новую тему.и ссылочку на новую тему киньте, а то у мну инет 64 кбит
кароч вот, При установке платформы 8.2 на виндовс хр сервис пак 2 два часа назад поставил , выдаёт ошибку "на обнаружен файл data1.cab или к нему нет доступа" .
Что это может означать?
файл существует и доступен.
Также буду благодарен за ссылку на тестовою платформу по экзамену 1С специалист.
а то тест не могу доделать.Очень бесит
з.ы. тест качал по этой ссылке http://files.mail.ru/QX1033, человек предоставивший ссылку- работодатель говорит "всё рабочее"
0
20.03.2012, 23:28
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.03.2012, 23:28

Нужен внешний отчет
Срочно понадобился отчет (внешний) задача которого состоит в том, чтобы показать пользователю форму...

Добавление отбора во внешний отчет
Доброго времени суток форумчане! Очень требуется ваша помощь, кто может откликнетесь! Имется отчет...

Не могу открыть внешний отчет
Не могу открыть внешний отчет с расширением .erf. Конфигуратор пишет "Внешний отчет не может быть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru