Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.98/45: Рейтинг темы: голосов - 45, средняя оценка - 4.98
selenka
0 / 0 / 0
Регистрация: 14.04.2012
Сообщений: 16
1

Как создать в документе ОперацияБух новую проводку?

14.04.2012, 00:54. Просмотров 8799. Ответов 6
Метки нет (Все метки)

Пытаюсь внешней обработкой создать бухгалтерскую справку, но не получается создать проводку. Помогите создать любую простую проводку, чтобы сориентироваться. Спасибо!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.04.2012, 00:54
Ответы с готовыми решениями:

Как создать новую базу в 1с бухгалтерия и перенести данные из старой базы в новую?
Доброго времени суток: подскажите пожалуйста начинающиму администратору: как создать новую ИБ в 1С...

как отменить проводку?
как программно отменить проводку уже проведённого документа?

Добавить новую запись в табличную часть ОперацияБух
Здравствуйте, во внешней обработке создаю новый документ ОперацияБух, заполняю шапку документа:...

Как в 1С Предприятие создать реквизит в документе?
Как в 1С Предприятие создать реквизит в документе с тремя вариантами ответа? На нужный вариант чтоб...

Как отслеживать новую строку в текстовом документе
Читаю текстовый документ так: string path = Application.StartupPath + "\\code.txt"; ...

6
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
14.04.2012, 11:17 2
Примерно так:
1C
1
2
3
4
5
6
7
8
9
ДокОбъект = Документы.ОперацияБух.СоздатьДокумент();
    
Проводка = ДокОбъект.Движения.Хозрасчетный.Добавить();
Проводка.Организация = <Ваша организация>
Проводка.СчетДт = <Ваш счет Дт>
    
...
    
ДокОбъект.Движения.Записать();
1
selenka
0 / 0 / 0
Регистрация: 14.04.2012
Сообщений: 16
15.04.2012, 16:16  [ТС] 3
Спасибо, получилось! Теперь пытаюсь добавить в документ дополнительные проводки. Документ нахожу, но строки со старыми проводками затираются
Может быть в этом коде проблема?

1C
1
2
3
4
5
6
7
8
9
НаборЗаписей=РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Значение=опер.Ссылка;
 
Проводка=НаборЗаписей.Добавить();
Проводка.Организация = орг;
 
....
 
наборзаписей.Записать();
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
15.04.2012, 19:35 4
Цитата Сообщение от selenka Посмотреть сообщение
НаборЗаписей.Отбор.Регистратор.Значение=опер.Ссылка;
Вставьте после:
НаборЗаписей.Прочитать();
0
selenka
0 / 0 / 0
Регистрация: 14.04.2012
Сообщений: 16
16.04.2012, 02:41  [ТС] 5
Большое спасибо! все получилось

Добавлено через 5 часов 18 минут
Наткнулась на новую проблему Надо подчиненный справочник по покупателям подцепить...

1C
1
2
3
4
5
6
7
8
9
10
11
12
контр=справочники.Контрагенты;
контр=контр.найтипокоду(СправочникД);   
Если контр.пустая() тогда   
   Сообщить("Не найден покупатель с кодом " + СправочникД, СтатусСообщения.Внимание);
КонецЕсли;                  
СписокДоговоров=Справочники.ДоговорыКонтрагентов.Выбрать(,контр,,);
Пока СписокДоговоров.Следующий() Цикл
  Если Не СписокДоговоров.Ссылка.Пустая() И Не СписокДоговоров.Ссылка.ПометкаУдаления Тогда
  дог=СписокДоговоров; 
  Прервать;
  КонецЕсли;
КонецЦикла;
Добавлено через 1 час 33 минуты
забыла указать, что не цепляет договор
0
Dethmontt
Модератор
Эксперт 1С
2657 / 2445 / 420
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
16.04.2012, 02:59 6
1C
1
дог=СписокДоговоров.Ссылка;
0
selenka
0 / 0 / 0
Регистрация: 14.04.2012
Сообщений: 16
16.04.2012, 23:56  [ТС] 7
огромное спасибо за помощь
0
16.04.2012, 23:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.04.2012, 23:56

Сохранять данные в новую строку в документе
По нажатию одной кнопки данные сохраняются в документ в одну строку, на другой кнопке в том же...

Как создать картинку в текущем документе?
Собственно вот и весь вопрос. Нужно, чтобы при открытии документа создавалось N-ое (нет, N мало...)...

Как программно создать Url ссылку в документе
Как программно создать url ссылку в документе открытом в клиенте Lotus Notes. Подскажите как...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru