Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.94/64: Рейтинг темы: голосов - 64, средняя оценка - 4.94
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
1

Как спросить. Подразделы. Удалённый доступ. Импорт (и прочие факи)

16.06.2012, 14:18. Просмотров 11762. Ответов 16
Метки нет (Все метки)

Как спросить, чтоб ответили продуктивно.
Указать Ядро и Конфигурацию.
Программа 1с состоит из 2-х частей: Ядро (Платформа) и Конфигурация.
Ядро - это Оъектная База Данных "1С®" с интерпретатором встроенного языка.
Конфигурация - это программа, созданная языком ядра.
Ядра: 4-7, 77, 8х (8.0, 8.1, 8.2, 8.3)
Конфигурации бывают типовые (их больше, чем кажется), редактированные типовые и рукописные.
Для 8.2-8.3 желательно (при наличии знания) режим: управляемый, неуправляемый.

Не забывайте о Поиске. Там есть расширенный режим, где можно выбрать подраздел и включить вывод по сообщениям.

Для "Семёрошников" как особо тянущих лямку сопровождения прицепил абы-какую доку, какую нашёл у себя в сусеках (см. вложения).

Как выбрать подраздел.
Для сисадминов - Администрирование и интеграция. Там же веб, com, ADO и т.п. Лезть в другие БД, лезть из других БД. Аппаратные дела.
Собственные программы. Если допилка в типовой с извратами или собственными объектами. Вопросы по обучению, экзаменам, литературе. Ну и собственные конфы.
Типовые и стандартные решения. Штатное конфигурирование типовых. Остроумные допилки типовых и собственных, достойные стандарта.

Здесь только советы нахаляву, то есть даром. А если Вы хототе результат за деньги, то вот:
Фриланс на этом форуме: http://www.cyberforum.ru/freelance/
http://www.cyberforum.ru/order-program/

Если долго не отвечают или издеваются, или есть подозрение, что начнут:
Азбука 1с: http://v8.1c.ru/overview/dictionary.htm (самое главное, не обижаться )
http://mista.ru/tutor_1c/index.htm
Курсы по инету (спасибо, Fenomen)
1с-факи (спасибо, Dethmontt)
http://Сайт "Хочу знать 1С" (спасибо, Dethmontt)

Весьма советую ещё поиск по разделу сообщений с текстом "http://help1c.com/"

Как почистить кэши. Иногда база начинает работать как бы по другой конфигурации, нежели та, которая сохранена последней,
бывает, что параметры пользователя - особенно установки печати - перестают работать, и т.д. и т.п.
В этом случае наиболее вероятный диагноз - в кэшах зависли не те фрагменты "к действию", а лекарство тут одно: "почистить кэши" (кто не в курсе - КЭШ - это заготовленный фрагмент памяти компа, употребляемый наиболее часто. Эта технология значительно повышает скорость работы). В каталоге учётной записи юзера они и лежат. Чтоб туда не лазить, предлагается следующий вариант:
1.1. Удалить базу из списка запуска (при этом платформа чистит кэши сама)
1.2. Добавить базу в список снова. (при первом запуске будут тормоза, но при наполнении кэшей от запуска к запуску скорость будет ощутимо увеличиваться)
Ещё тем же самым по тому же месту (+ 2 способа)
2. Запуск с ключом /ClearCache
3. В файле ibases.v8i посмотреть id вашей базы, дать в винде по нему поиск и снести 2 найденных каталога.
Ригарды: Dethmontt, OrkVasya

Как работать удалённо (с другого компьютера).
РБД (РИБ) поможет распределить функции между узлами, компилируя действия разных подразделений в одной базе, но Вы потеряете режим реального времени.
Чаще требуется работа пользователя с домашнего компа в "своём" режиме. Вот легко доступные способы:
http://www.teamviewer.com/ru/download/currentversion.aspx
http://ru.wikipedia.org/wiki/Hamachi
http://www.ammyy.com/ru/downloads.html

7 и Win7
http://interface31.ru/tech_it/2009/1...s-7-vista.html

Импорт из Excell и прочих txt
Общепринятый способ - это бэйсик в COM (OLE) приложении, которое приходится открывать из 1с. При записи (экспорте в файл) это необходимо. Но чаще требуется лишь прочитать. Тут вспомните, что существует клипбоард (буфер обмена), который системно экспортирует/импортирует данные из приложения в приложение. Вы можете "копипастой" (^C^V) забросить таблицу в Поле Табличного Документа в 1с 8х или в таблицу-макет (mxl) в 77 и обработать данные, ставшие "родными" для 1с.
Пример и того, и другого внутри обработки "ЗагрузкаДанныхИзТабличногоДокумента". Кроме того, обработку можно использовать для одноразового импорта из DBF, XLS, TXT.

Оснастка для быстрой кодировки в "1С"
http://v8.1c.ru/overview/Term_000000596.htm#1
http://v8.1c.ru/overview/Term_000000599.htm#1
http://v8.1c.ru/overview/Term_000000226.htm#1

ОТЛАДЧИК (он же дибугер, он же Debugger)
Если запустить базу из конфигуратора - она откроется в отладочном режиме. Это значит, что Вы можете остановить программу на любой строке и вывести значение всех переменных и полей. Кроме того, можно просто потренироваться с недостаточно ясными методами, нпр.Формат(), Дата() и др. статья про отладчик (ссылку предоставил OrkVasya)

Кто рвётся получить сертификат (ссылку предоставил wladimir_ui):
Онлайн тестирование

Список баз лежит в учётке, типа здесь (транскрипция хрюши):
c:\Documents and Settings\User\Application Data\1C\1CEStart\ibases.v8i

Попробовать 1с на своём компе: вместо гемора с эмуляторами и кряками 600рублей - это приемлемо теперь халява Получаете платформу в комплектации "только толстый" (локал) с ограничением на число записей в БД и демо-конфигурацию.

Калькулятор стоимости продуктов 1с

PS. Желательно сообщать о результате. Если, конечно, не влом.

Весьма советую ещё поиск по разделу сообщений с текстом "http://help1c.com/"
31
Вложения
Тип файла: rar ЗагрузкаДанныхИзТабличногоДокумента81.rar (62.7 Кб, 106 просмотров)
Тип файла: rar ЗагрузкаДанныхИзТабличногоДокумента82.rar (63.6 Кб, 144 просмотров)
Тип файла: zip 1cv77b1.zip (439.4 Кб, 8 просмотров)
Тип файла: zip 1cv77b2.zip (1.30 Мб, 7 просмотров)
Тип файла: zip tutor_1c_chm.zip (1.28 Мб, 10 просмотров)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.06.2012, 14:18
Ответы с готовыми решениями:

Зависает 1С не могу понять из за чего - при более, чем одном соединении .Удалённый доступ, VPN
Добрый день. Недавно столкнулся с такой проблемой. Есть два офиса, один в...

Как сделать удалённый доступ к системе?
Уважаемые коллеги! У меня дома компьютер с установленной Ubuntu. Хочу с...

Как предоставить безопасный удалённый доступ (SSHv2). И Как обеспечить защиту портов доступа на коммутатроре
Имеется почти законченная схема. В задании имеются ещё три пункта. 1) К...

Удалённый доступ
Здравствуйте у меня есть программа написана на с++ , хотел бы создать...

Удалённый доступ
Есть два офиса. Через инет пользователи (количеством ~10) пдключаются к...

16
Xomych
613 / 547 / 78
Регистрация: 01.11.2012
Сообщений: 1,953
17.10.2013, 19:49 2
Вообщем, базу я открыл.
Проблему решил, очистив таблицу Configsave в файле 1CD (как написано у Гилева) с помощью утилиты Tool_1CD, спасибо хорошему человеку, который её написал. Делюсь, может кому пригодится.

Однако, хоть база и открывается, но почему-то я не смог выгрузить информационную базу в dt файл, 1С просто падает.

Цитата Сообщение от Kolodinivan Посмотреть сообщение
Как вы это сделали??? Можете описать?
С помощью программки Tool_1CD
Убил таблицу Configsave, открыл конфу, сохранил конфигурацию в файл, сделал пустую базу на ней, Экспортировал пустую таблицу Configsave из пустой базы. Потом импортировал её в битую базу и всё заработало.
3
Вложения
Тип файла: 7z Tool_1CD.7z (8.70 Мб, 149 просмотров)
Augusto
69 / 69 / 1
Регистрация: 18.12.2012
Сообщений: 390
22.10.2013, 09:14 3
Более функциональная, чем типовая. Подходит как для обычного, так и для управляемого интерфейса.
0
Augusto
69 / 69 / 1
Регистрация: 18.12.2012
Сообщений: 390
22.10.2013, 09:17 4
Вот еще хорошая обработка для удаления объектов
0
Вложения
Тип файла: rar УдалениеОбъектовУниверсальная.rar (33.3 Кб, 15 просмотров)
Augusto
69 / 69 / 1
Регистрация: 18.12.2012
Сообщений: 390
04.12.2013, 09:31 5
Обработка для быстрого создания внешней печатной формы на основе типовой. Экономит уйму времени. Создание почти любой ВПФ за 2 минуты. Подходит как для обычного так и для управляемого приложения. Есть недоработки, но в целом работает нормально.

Не по теме:

Стянуто с инфостарта.

0
Вложения
Тип файла: rar Конструктор ВПФ.rar (166.7 Кб, 17 просмотров)
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 904
12.12.2013, 19:36 6
Для тех кто забыл пароль.

Примечания: удаляет всех пользователей, и после выполнения операций надо зайти в конфигуратор и создать нового.


Не по теме:

пароль к архиву 123456

0
Вложения
Тип файла: rar ЗабытыйПаролль.rar (222.2 Кб, 18 просмотров)
Xomych
613 / 547 / 78
Регистрация: 01.11.2012
Сообщений: 1,953
15.12.2013, 12:55 7
Не столько обработка сколько полезная функция. Проверяет связь с IP адресом

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Function Ping(IPАдрес)
    Try
        ServicesSet = GetCOMObject("winmgmts:{impersonationLevel=impersonate}");
        Items = ServicesSet.ExecQuery("SELECT StatusCode from Win32_PingStatus WHERE address = '" + IPАдрес + "' AND Timeout=10");
    Except
        Return False;
    EndTry;
    For Each Item In Items Do
        If Item.StatusCode = 0 Then
            Return True;
        Else
            Return False;
        EndIf;
    Enddo;
    Return False;
EndFunction
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
05.02.2014, 00:02 8
Два хороших источника
http://kb.mista.ru/
и
http://help1c.com/faq.html

Добавлено через 1 минуту
З.Ы.
Особенно отмечу ХЕЛП 1С, очень хороший справочник есть примеры работы практически со всеми объектами...
0
wwall
195 / 189 / 13
Регистрация: 29.05.2014
Сообщений: 988
17.07.2014, 12:24 9
Цитата Сообщение от GreenkO Посмотреть сообщение
Привет. Может у кого есть какая обработка для Редактирования внешних печатных форм? Встречала это http://infostart.ru/public/157626/, но скачать не могу.
во вложении
Вложение 420446
0
Вложения
Тип файла: zip РедакторВПФ.ZIP (620.0 Кб, 12 просмотров)
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
25.07.2014, 00:05 10
http://help1c.com/faq/view/1286.html
0
1c-k
331 / 308 / 41
Регистрация: 20.08.2014
Сообщений: 1,217
Записей в блоге: 1
21.08.2014, 10:37 11
Доброе утро.
Есть http://manual1c.ru/test/Platf83. Можно выучить вопросы и идти сдавать. Там же форумы и тематические вещи по разным системам на 1с.
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
24.08.2014, 03:14  [ТС] 12
Литература по 1С.
1
Миниатюры
Как спросить. Подразделы. Удалённый доступ. Импорт (и прочие факи)  
1c-k
331 / 308 / 41
Регистрация: 20.08.2014
Сообщений: 1,217
Записей в блоге: 1
15.09.2014, 18:17 13
Это мое скромное мнение. но возможно поможет.
kosyachok90, RecordSet в помощь и передвигание курсора в нём.
Посмотрите, как из 1с работают с внешними соединениями, аналогично обстоит (насколько помню) и работа с 1с
http://mudritskiy.blogspot.ru/2013/05/1-adodb.html
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
11.10.2014, 23:11 14
http://infostart.ru/public/242824/ Произвольная иерархия в СКД. Так же намёк на рукопашное использование ПроцессорКомпоновки и ПроцессорВывода
0
Heltarion
2 / 2 / 0
Регистрация: 21.11.2011
Сообщений: 57
05.01.2015, 09:38 15
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
Функция ИнициализацияЭкселя()
 
    //Пытаемся подключиться к Excel
    Попытка
        Excel = новый COMОбъект("Excel.Application");
        Сообщить("=====> Загрузка производится через MS Excel...");
        Возврат Истина;
    Исключение
        Возврат Ложь                
    КонецПопытки;     
    
КонецФункции
 
 
Процедура СохранитьНажатие(Элемент) Экспорт
    СтолбЗагр = 1; // задаю номер столбца№1 в эксель
    СтолбБаз = 2;  // задаю номер столбца№2 в эксель
    
    Если ИнициализацияЭкселя() Тогда
        Книга = Excel.WorkBooks.Add(); // создал новый документ
        Sheet = Книга.Sheets(1);          // открыл страницу 1
   
// цикл для заполнения таблицы эксель данными из табличного поля (по двум полям)     
        Для каждого стр из ТПП Цикл
            Sheet.Cells(стр,СтолбЗагр).Value=стр.НоменклатураЗагрузки;
            Sheet.Cells(стр,СтолбБаз).Value=стр.НоменклатураБазы.Наименование;
        КонецЦикла;
 
//выполняю сохранение документа       
        Попытка
            Книга.SaveAs("F:\1CBase\Внешнии обработки\правила12.xlsx");
        Исключение
            Сообщить(ОписаниеОшибки()+" Файл не сохранен!");
            Возврат;
        КонецПопытки;
    КонецЕсли;
    Книга.Application.Quit();
    Сообщить("Готово");
КонецПроцедуры
0
assa62
7 / 7 / 1
Регистрация: 30.10.2014
Сообщений: 55
09.02.2015, 19:41 16
Код для 1С 7.7
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
Процедура ПодключитьсяКFTP(СписокКоманд)
     Текст = СоздатьОбъект("Текст");
     Для Инд = 1 По СписокКоманд.РазмерСписка() Цикл
          Текст.ДобавитьСтроку(СписокКоманд.ПолучитьЗначение(Инд));
     КонецЦикла;
     Текст.Записать(КаталогПользователя() + "par.ftp");
     ФС.УстТекКаталог(КаталогПользователя()); 
     Пауза(2);
     vbs = СоздатьОбъект("Текст");
     vbs.ДобавитьСтроку("Dim oShell");
     vbs.ДобавитьСтроку("Set oShell = WScript.CreateObject ("+ симв(34) + "WSCript.shell"+ симв(34) +")");
     vbs.ДобавитьСтроку("oShell.run " + симв(34) + "ftp.exe -s:" + симв(34) + симв(34)  +  КаталогПользователя() + "par.ftp" + симв(34) + симв(34) + симв(34) + ", 0, -1");
     vbs.ДобавитьСтроку("Set oShell = Nothing"); 
     vbs.Записать(КаталогПользователя() + "ftp.vbs");
     Пауза(1);
     Состояние("Получаю файлы с FTP...");
     WshShell   = СоздатьОбъект("WScript.Shell");
     КодВозвр   = WshShell.Run(Симв(34) + КаталогПользователя() + "ftp.vbs" + симв(34),1,-1);
 
     Состояние("Удаляю временные файлы...");
     ФС.УдалитьФайл(КаталогПользователя() + "par.ftp");
     ФС.УдалитьФайл(КаталогПользователя() + "ftp.vbs");
     ОчиститьОкноСообщений();
КонецПроцедуры
 
//=================================================/
Функция ПолучитьСписокФайловФТП() 
    спФТП.УдалитьВсе();
    Список = СоздатьОбъект("СписокЗначений");
    Список.ДобавитьЗначение("open " + СокрЛП(FTPСервер));
    Список.ДобавитьЗначение(СокрЛП(FTPПользователь));
    Список.ДобавитьЗначение(СокрЛП(FTPПароль));
    Список.ДобавитьЗначение("cd " + СокрЛП(FTPПутьНаСервереДляПолученияФайлов));
    Список.ДобавитьЗначение("dir *.* " + симв(34) + КаталогПользователя() + "dir.ftp" + симв(34));
    Список.ДобавитьЗначение("bye"); 
    Список.ДобавитьЗначение("quit"); 
    ПодключитьсяКFTP(Список);
    Состояние("Получаю файлы...");
    Если ФС.СуществуетФайл(КаталогПользователя() + "dir.ftp") = 1 Тогда 
        тТекст   = СоздатьОбъект("Текст");
        тТекст.Открыть(КаталогПользователя() + "dir.ftp"); 
        Для ы=1 по тТекст.КоличествоСтрок() Цикл
            текСтрока    = тТекст.ПолучитьСтроку(ы);
            спФТП.ДобавитьЗначение(текСтрока);
        КонецЦикла;  
        ФС.УдалитьФайл(КаталогПользователя() + "dir.ftp");
        Возврат 1;
    Иначе
        Возврат 0;
    КонецЕсли;
КонецФункции  
//=================================================/
Процедура ПолучитьФайлыЗаДату(ТипДокумента, Знач НачДата)
    КвоФайловЗаДату = 0;
    спПараметров     = СоздатьОбъект("СписокЗначений");
    Список = СоздатьОбъект("СписокЗначений");
    Список.ДобавитьЗначение("open " + СокрЛП(FTPСервер));
    Список.ДобавитьЗначение(СокрЛП(FTPПользователь));
    Список.ДобавитьЗначение(СокрЛП(FTPПароль));
    Список.ДобавитьЗначение("cd " + СокрЛП(FTPПутьНаСервереДляПолученияФайлов));
    Если ПолучитьСписокФайловФТП() = 1 Тогда
        Для ч=0 по КонДата-НачДата Цикл
            ЗаДату  = НачДата + ч;
            Для ы=1 по спФТП.РазмерСписка() Цикл
                текСтрока    = спФТП.ПолучитьЗначение(ы);
                ДатаВВидеСтроки = Формат(ЗаДату, "ДггггММДД");
                Если Найти(текСтрока, Нрег(ТипДокумента) + "_" + ДатаВВидеСтроки) = 0 Тогда
                    Продолжить;
                КонецЕсли;
                текСтрока   = СтрЗаменить(текСтрока," ","#");
                текСтрока   = СтрЗаменить(текСтрока,"########","#");
                текСтрока   = СтрЗаменить(текСтрока,"#######","#");
                текСтрока   = СтрЗаменить(текСтрока,"######","#");
                текСтрока   = СтрЗаменить(текСтрока,"#####","#");
                текСтрока   = СтрЗаменить(текСтрока,"####","#");
                текСтрока   = СтрЗаменить(текСтрока,"###","#"); 
                текСтрока   = СтрЗаменить(текСтрока,"##","#");
                текСтрока   = текСтрока + "#";
                Парсить(текСтрока, спПараметров, "#"); 
                имяФайлаФТП  =  спПараметров.ПолучитьЗначение(спПараметров.РазмерСПиска());
                Список.ДобавитьЗначение("recv " + имяФайлаФТП + " " +  симв(34) + РабочийКаталогВременныхФайлов + имяФайлаФТП + симв(34));
                КвоФайловЗаДату = КвоФайловЗаДату+1;
            КонецЦикла;  
        КонецЦикла;  
    КонецЕсли;
    Если Список.РазмерСписка() > 4 Тогда
        Список.ДобавитьЗначение("bye");
        Список.ДобавитьЗначение("quit"); 
        ПодключитьсяКFTP(Список)
    КонецЕсли;
    Форма.Обновить();
КонецПроцедуры
        
//=================================================/
Процедура ПолучитьФайлы(ТипДокумента)
    ТекДата = НачДата;
    ПолучитьФайлыЗаДату(ТипДокумента, ТекДата);
КонецПроцедуры
спФТП - список на форме обработки
FTPСервер, FTPПользователь, FTPПароль,FTPПутьНаСервереДляПолученияФайлов - текстовые поля на форме обработки.
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
07.05.2015, 11:21 17
Создать две схемы и программно их вывести (друг под другом)

есть отличный сайт по СКД - http://1cskd.ru/
0
07.05.2015, 11:21
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.05.2015, 11:21

Удалённый доступ
Добрый день. Имеется microsoft visual c# 2010 и sql server 2008 express. Задача...

Удалённый доступ.
Доброго времени суток. У меня такой вопрос. У меня на первом компьтере...

Удалённый доступ
Ребят помогите найти программу удалённого доступа которая не будет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
17
Закрытая тема Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru