Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
znayka
0 / 0 / 0
Регистрация: 22.06.2015
1

В отчете мне не выводит никакого результата(1С)

28.06.2012, 11:28. Просмотров 1166. Ответов 3
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
Процедура КнопкаСформироватьНажатие(Кнопка)
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДатаОкончания));
Запрос.УстановитьПараметр("Организация", Организация);
   Запрос.Текст  = "ВЫБРАТЬ
                    |   ПоступлениеТоваровУслуг.Ссылка,
                    |   ПоступлениеТоваровУслуг.Дата,
                    |   ПоступлениеТоваровУслуг.Организация.Наименование,
                    |   ПоступлениеТоваровУслуг.Товары.(
                    |       СтавкаНДС
                    |   ),
                    |   РеализацияТоваровУслуг.Ссылка КАК Ссылка1,
                    |   РеализацияТоваровУслуг.Дата КАК Дата1,
                    |   РеализацияТоваровУслуг.Организация.Наименование КАК ОрганизацияНаименование1,
                    |   РеализацияТоваровУслуг.Товары.(
                    |       СтавкаНДС
                    |   ) КАК Товары1
                    |ИЗ
                    |   Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг,
                    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
                    |ГДЕ
                    |   ПоступлениеТоваровУслуг.Дата >= &ДатаНачала
                    |   И ПоступлениеТоваровУслуг.Организация = &Организация
                    |   И РеализацияТоваровУслуг.Дата >= &ДатаНачала
                    |   И РеализацияТоваровУслуг.Организация = &Организация
                    |   И ПоступлениеТоваровУслуг.Дата <= &ДатаОкончания
                    |   И РеализацияТоваровУслуг.Дата <= &ДатаОкончания";
Выборка = Запрос.Выполнить().Выбрать();
Макет = ПолучитьМакет("Макет");
//Создаем табличный документ для вывода
ТабДок = Новый ТабличныйДокумент;  
ОбластьЗаголовок=Макет.ПолучитьОбласть("Заголовок");
Шапка=Макет.ПолучитьОбласть("Шапка");
ТабличнаяЧасть=Макет.ПолучитьОбласть("ТабличнаяЧасть");
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(Шапка);         
                             
Пока Выборка.Следующий() Цикл
      СтруктураОтбора = Новый Структура;
      СтруктураОтбора.Вставить("ПометкаУдаления"        , Ложь);
    Если ТипЗнч(Выборка.Ссылка)=Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
         Для Каждого Строка ИЗ Выборка.Ссылка.Товары Цикл
                     Если Строка.СуммаНДС<>0 Тогда 
                           
                           Если УчетНДС.НайтиПодчиненныйСчетФактуру(Выборка.Ссылка.ДокументыОснования[0].ДокументОснование, "СчетФактураВыданный", СтруктураОтбора, Выборка.Ссылка) = ложь Тогда
                             //вывести документ в отчет
                             ТабличнаяЧасть.Параметры.Документ=Выборка.Ссылка;
                             ТабличнаяЧасть.Параметры.Контрагент=Выборка.Ссылка.Контрагент;
                             ТабДок.Вывести(ТабличнаяЧасть);                                                     
                            Прервать;
                         КонецЕсли;
                     КонецЕсли;
         КонецЦикла;  
    ИначеЕсли ТипЗнч(Выборка.Ссылка)=Тип("ДокументСсылка.ПоступлениеТоваровУслуг") Тогда
         Для Каждого Строка ИЗ Выборка.Ссылка.Товары Цикл
                    Если Строка.СуммаНДС<>0 Тогда 
                         
                         //Если //УчетНДС.НайтиПодчиненныйСчетФактуру(Выборка.Ссылка,"СчетФактураПолученный") = ложь Тогда
                           Если УчетНДС.НайтиПодчиненныйСчетФактуру(Выборка.Ссылка,"СчетФактураПолученный",Новый Структура("ПометкаУдаления",Ложь),Выборка.Ссылка)= ложь Тогда
                            //вывести документ в отчет
                             ТабличнаяЧасть.Параметры.Документ=Выборка.Ссылка;
                             ТабличнаяЧасть.Параметры.Контрагент=Выборка.Ссылка.Контрагент;
                             ТабДок.Вывести(ТабличнаяЧасть);
                         Прервать;
 
                         КонецЕсли;                 
                    КонецЕсли;
         КонецЦикла;
     КонецЕсли; 
КонецЦикла;
 
ТабДок.Показать();
 
КонецПроцедуры
Если задам вопрос некорректно извиняюсь...только начала учить...
В общем нужно сформировать отчет по двум документам "Поступление товаров услуг" и "Реализация товаров услуг" нужно чтобы выбирал документ по заданному периоду и организации(это вроде у меня реализовать получилось) В результате должен вывести Документ у которого нет Счета Фактуры и сумма ндс товаров не была равна 0. Он у меня ничего не выводит...Только заголовок и шапку документа... заранее спасибо за помощь!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.06.2012, 11:28
Ответы с готовыми решениями:

Никакого результата при List.Except(list2)
no_rep_room и no_rep_rooms - списки. В конкретном случае каждый имел по одному...

Что не так в запросе? Не выдает никакого результата.
Что не так в запросе? Не выдает никакого результата. SELECT , Стаж...

Что возвращает переменная $row['name'], если запрос не дал никакого результата?
$res2 = mysql_query(&quot;SELECT name FROM Less WHERE day_of_week='Понедельник' and...

функция Reverse которая паспологает строку в обратном положении-никакого результата
//alex.h public: char reverse(char s){ int c,i,j; c=i=j=0;...

Монитор не выводит никакого изображения на экран
Есть потребность реанимировать старый компьютер. Запустил системник никакого...

3
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,594
Записей в блоге: 1
Завершенные тесты: 1
28.06.2012, 22:37 2
Почему нету фотки?
С фото помощь придет быстрее.....
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.06.2012, 01:16 3
Сумбур. Всё спорно, вплоть до постановки задачи
Начните с начала. Создайте новый отчет и в нем воспользуйтесь конструктором формы на закладке "макет".
(Перед этим в консоли отчетов или запросов полезно отработать получение нужного результата).
Запрашивайте ТЧ.Товары. Разберитесь, где поступление, а где реализация относительно СФ полученных и выданных.
Ну, как-то по очереди Как сказал один эстонец: победит постепенность. Быстрее получится

Используйте ГДЕ Дата МЕЖДУ &Дат1 И &Дат2. конструктор подскажет
1
znayka
0 / 0 / 0
Регистрация: 22.06.2015
29.06.2012, 10:37 4
Спасибо большое...вчера разобралась...перестроила запрос, и изменила пару условий, все получилось=)
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.06.2012, 10:37

Объединение полей таблицы и вывод результата в отчете в несколько строк
Здравствуйте! Имеется таблица с полями содержащими название должностей по...

Выводит два результата
Если делить на ноль то выводит и результат и фразу &quot;Na nol delit nelza&quot; ...

Программа не выводит результата
Возможно неправильно вынес данные в подпрограмму (foo1) ,кто в силах исправить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru