Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/10: Рейтинг темы: голосов - 10, средняя оценка - 4.60
lw0v0wl
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 2
1

Внешний отчет 1С 8.1

10.08.2012, 15:57. Просмотров 1832. Ответов 3
Метки нет (Все метки)

Народ, помогите!!!! работаю в 1С 8.1 "Управление торговлей", в программировании совершенно не шарю. но смысл в следующем, есть внешний отчет, необходимо что бы он забивал в определенную ячейку таблицы количество товара, которое переместилось с одного склада на другой с определенным качеством. Заренее спасибо.

Добавлено через 7 минут
Люди, дело срочное. Уволят нафиг))))

Добавлено через 31 минуту
в общем смысл такой...
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
ХарПСО = Справочники.ХарактеристикиНоменклатуры.Выбрать(,Номенклатура);
            
            
            Пока ХарПСО.Следующий() Цикл
                Если ХарПСО.Наименование = "xxx" Тогда
                    ХарXXX = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "yyy" Тогда
                    ХарYYY = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "zzz" Тогда
                    ХарZZZ = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "xyz" Тогда
                    ХарXYZ = ХарПСО.Ссылка;
                КонецЕсли;
            КонецЦикла;
Необходимо провести подобную операцию но с качеством.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.08.2012, 15:57
Ответы с готовыми решениями:

Нужен внешний отчет
Срочно понадобился отчет (внешний) задача которого состоит в том, чтобы показать пользователю форму...

Не работает внешний отчет
1С:Бухгалтерия 8.2 Создаю внешний отчет для выгрузки документов Списание с расчетного счета в...

Внешний регламентированный отчет
Всем привет! Написал свой регламентированный отчет, формируется и записывается в документ...

Внешний отчет по справочнику
Вопрос вот в чем: есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь...

Составить внешний отчет 1с-8.2
Ребята, подскажите последовательность действий для создания внешнего отчета. Реализация по...

3
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
10.08.2012, 22:15 2
Непонятно.
Проблема с ячейкой в макете? поиском поля "Качество" в регистре остатков? локализации операции "Перемещение"?
0
lw0v0wl
0 / 0 / 0
Регистрация: 07.08.2012
Сообщений: 2
13.08.2012, 08:56 3
Сейчас попытаюсь объяснить... не могу выковырнуть данные "Качество" из табличной части перемещения.
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
13.08.2012, 09:13 4
Из ТЧ можно, а из справочника характеристики нельзя.

1C
1
2
3
4
Для Каждого Ик Из Перемещение.Товары Цикл
Качество=Ик.Качество;
Если Качество.Наименование...
КонецЦикла;
Добавлено через 2 минуты
1C
1
2
3
4
5
6
7
8
9
10
11
Пока ХарПСО.Следующий() Цикл
                Если ХарПСО.Наименование = "xxx" Тогда
                    ХарXXX = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "yyy" Тогда
                    ХарYYY = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "zzz" Тогда
                    ХарZZZ = ХарПСО.Ссылка;
                ИначеЕсли ХарПСО.Наименование = "xyz" Тогда
                    ХарXYZ = ХарПСО.Ссылка;
                КонецЕсли;
            КонецЦикла;
По-игроцки - создать структуру или соответствие, или ТЗ или Массив, или стринг с разделителями. Проще редактировать потом будет
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
13.08.2012, 09:13

Внешний отчет о скидках
С Новым Годом! Подскажите пожста как реализовать отчет о скидках которые были поставлены в ручную....

Добавление отбора во внешний отчет
Доброго времени суток форумчане! Очень требуется ваша помощь, кто может откликнетесь! Имется отчет...

Не могу открыть внешний отчет
Не могу открыть внешний отчет с расширением .erf. Конфигуратор пишет "Внешний отчет не может быть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru