Форум программистов, компьютерный форум CyberForum.ru
CyberForum.ru - форум программистов и сисадминов > >
Восстановить пароль Регистрация
 
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 308
17.08.2012, 10:46     Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
  #1
Что делать с этой ошибкой?

Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Ожидается выражение "("
АктКДоговоруТЧУслуги.Ссылка В <<?>>&СписокАктов
в процедуре:

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура ЗаполнитьНаСервере()
    
Запрос = Новый Запрос;
    Запрос.Текст =
("ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В &СписокАктов");
 
СписокАктов = Новый СписокЗначений();
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элементы.ТЧАктыАкты);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецПроцедуры
Кстати эта процедура заполнит ТЧУслуги из списка документов АктКДоговору, который находится в ТЧАкты?
AdAgent
Объявления
17.08.2012, 10:46
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.08.2012, 10:46

Посмотрите здесь:

1С 1C 8.x Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!

1С Ошибка при вызове метода контекста (Выполнить)

1С Ошибка при вызове метода контекста (ПолучитьОбъект)

1С Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран

1С Ошибка при вызове метода контекста

1С 1C 8.x Ошибка при вызове метода контекста (ВыбратьИзСписка)

wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 513
17.08.2012, 11:33
  #2
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В (&СписокАктов)";
Наверное
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 308
17.08.2012, 11:59  [ТС]
  #3
Да, теперь нет ошибки )) Спасибо)

Добавлено через 16 минут
Ох нет. Теперь другая ошибка:
Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Неверные параметры
АктКДоговоруТЧУслуги.Ссылка <<?>>В (&СписокАктов)
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 513
17.08.2012, 12:24
  #4
Что такое список актов? Тип значения какой? Должен быть список значений состоящий из ссылок документов данного типа.
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 308
17.08.2012, 12:32  [ТС]
  #5
Цитата Сообщение от wade25 Посмотреть сообщение
Должен быть список значений состоящий из ссылок документов данного типа.
Ну СписокАктов и есть список значений.

А состоять из ссылок документов данного типа ... это
Код 1C
1
СписокЗначений.Добавить(Документы.АктКДоговору)
или как его заполнить заполнить списком документов?
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 513
17.08.2012, 13:38
  #6
Пробуй так

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
СписокАктов = Новый СписокЗначений;
Если Объект.ТЧАкты.Количество() > 0 Тогда
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элемент..ДОКУМЕНТАКТ.ССЫЛКА);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецЕсли;
 
КонецПроцедуры
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 308
17.08.2012, 13:47  [ТС]
  #7
А в этой строке
Код 1C
1
СписокАктов.Добавить(Элемент.ДОКУМЕНТАКТ.ССЫЛКА);
что значит ДОКУМЕНТАКТ?
Что бы я там не писала, всегда пишет - Поле объекта не обнаружено (ДОКУМЕНТАКТ).
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 513
17.08.2012, 14:08
  #8
Смотри, Табличная часть состоит из колонок. В одной из колонок у тебя должны лежать документы (акты). "Элемент", это строка при обходе ТЧ, а к колонкам ты обращаешься через точку. Т.е. Элемент.ТУТ_НАЗВАНИЕ_КОЛОНКИ.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.08.2012, 14:21

Еще ссылки по теме:

1С Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)

1С 1C 8.x Не удалось сформировать внешнюю печатную форму(толстую)! Ошибка при вызове метода контекста (Выполнить): {(14, 1)}: Синтаксическая ошибка "ИЗ" <<?>>ИЗ

1С 1C 8.x Работа с запросом и ошибка "Ошибка при вызове метода контекста (Выполнить)"

1С 1C 8.x (тонкий) Открытие формы (Ошибка при вызове метода контекста)

Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 308
17.08.2012, 14:21  [ТС]     Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
  #9
Да, по идее так и делала. Реквизит табличной части ТЧАкты называется Акты.
Писала Элемент.Акты, но то же самое... Поле объекта не обнаружено (Акты) \(О_о)/

Добавлено через 2 минуты
А нет. Всё! Ух ты! Работает! Спасибо огромное!!!
Yandex
Объявления
17.08.2012, 14:21
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать новую тему
Опции темы

Текущее время: 12:18. Часовой пояс GMT +4.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.7 PL3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.