Форум программистов и сисадминов CyberForum.ru
Вернуться   Форум программистов и сисадминов CyberForum.ru > Форум Форум программистов > Форум Программирование 1С
Восстановить пароль Регистрация

Ответ Создать новую тему
 
Старый 17.08.2012, 10:46   #1
Titanum
Форумчанин
 
Аватар для Titanum
 
Регистрация: 25.10.2011
Сообщений: 270
Репутация: 0 (0)
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "(" / Программирование 1С

Что делать с этой ошибкой?

Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Ожидается выражение "("
АктКДоговоруТЧУслуги.Ссылка В <<?>>&СписокАктов
в процедуре:

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура ЗаполнитьНаСервере()
    
Запрос = Новый Запрос;
    Запрос.Текст =
("ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В &СписокАктов");
 
СписокАктов = Новый СписокЗначений();
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элементы.ТЧАктыАкты);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецПроцедуры
Кстати эта процедура заполнит ТЧУслуги из списка документов АктКДоговору, который находится в ТЧАкты?
Старый 17.08.2012, 11:33   #2
wade25
Форумчанин
 
Аватар для wade25
 
Регистрация: 25.03.2011
Сообщений: 512
Репутация: 143 (143)
Лучшие ответы: 1
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В (&СписокАктов)";
Наверное
Другие темы раздела Форум программистов и администраторов 1С. Все вопросы и проблемы программирования и настройки систем 1С
Получить доступ к ТЧ другого документа 1С
Нужно написать цикл для табличной части документа и в цикле указать табличную часть другого документа. Что-то типа Документы.ИмяДокумента.ТЧДокумента. Но так записать нельзя. Как это сделать? Для каждого ТекущаяСтрока из Объект.ТЧЭтогоДокументва Цикл ТаблицаЗначений = ТекущаяСтрока.(а здесь...
Учитывать по полной цене 1С
Здравствуйте! При вводе хозинвентаря, спецодежды, спецостнастки в эксплуатацию (МБП) есть учетная политика, где стоит процент аммортизации 50% Но с недавнего времени при вводе посуды требуется проводить операцию по полной цене, т.е. добавляю на форму флажек. Но проблема в том, что не знаю...
Старый 17.08.2012, 11:59  [ТС]   #3
Titanum
Форумчанин
 
Аватар для Titanum
 
Регистрация: 25.10.2011
Сообщений: 270
Репутация: 0 (0)
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Да, теперь нет ошибки )) Спасибо)

Добавлено через 16 минут
Ох нет. Теперь другая ошибка:
Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Неверные параметры
АктКДоговоруТЧУслуги.Ссылка <<?>>В (&СписокАктов)
Старый 17.08.2012, 12:24   #4
wade25
Форумчанин
 
Аватар для wade25
 
Регистрация: 25.03.2011
Сообщений: 512
Репутация: 143 (143)
Лучшие ответы: 1
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Что такое список актов? Тип значения какой? Должен быть список значений состоящий из ссылок документов данного типа.
Старый 17.08.2012, 12:24
Google
Объявления
Старый 17.08.2012, 12:32  [ТС]   #5
Titanum
Форумчанин
 
Аватар для Titanum
 
Регистрация: 25.10.2011
Сообщений: 270
Репутация: 0 (0)
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Цитата Сообщение от wade25 Посмотреть сообщение
Должен быть список значений состоящий из ссылок документов данного типа.
Ну СписокАктов и есть список значений.

А состоять из ссылок документов данного типа ... это
Код 1C
1
СписокЗначений.Добавить(Документы.АктКДоговору)
или как его заполнить заполнить списком документов?
Старый 17.08.2012, 13:38   #6
wade25
Форумчанин
 
Аватар для wade25
 
Регистрация: 25.03.2011
Сообщений: 512
Репутация: 143 (143)
Лучшие ответы: 1
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Пробуй так

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
СписокАктов = Новый СписокЗначений;
Если Объект.ТЧАкты.Количество() > 0 Тогда
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элемент..ДОКУМЕНТАКТ.ССЫЛКА);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецЕсли;
 
КонецПроцедуры
Старый 17.08.2012, 13:47  [ТС]   #7
Titanum
Форумчанин
 
Аватар для Titanum
 
Регистрация: 25.10.2011
Сообщений: 270
Репутация: 0 (0)
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

А в этой строке
Код 1C
1
СписокАктов.Добавить(Элемент.ДОКУМЕНТАКТ.ССЫЛКА);
что значит ДОКУМЕНТАКТ?
Что бы я там не писала, всегда пишет - Поле объекта не обнаружено (ДОКУМЕНТАКТ).
Старый 17.08.2012, 14:08   #8
wade25
Форумчанин
 
Аватар для wade25
 
Регистрация: 25.03.2011
Сообщений: 512
Репутация: 143 (143)
Лучшие ответы: 1
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

Смотри, Табличная часть состоит из колонок. В одной из колонок у тебя должны лежать документы (акты). "Элемент", это строка при обходе ТЧ, а к колонкам ты обращаешься через точку. Т.е. Элемент.ТУТ_НАЗВАНИЕ_КОЛОНКИ.
Старый 17.08.2012, 14:21  [ТС]   #9
Titanum
Форумчанин
 
Аватар для Titanum
 
Регистрация: 25.10.2011
Сообщений: 270
Репутация: 0 (0)
Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "(" / Программирование 1С

Да, по идее так и делала. Реквизит табличной части ТЧАкты называется Акты.
Писала Элемент.Акты, но то же самое... Поле объекта не обнаружено (Акты) \(О_о)/

Добавлено через 2 минуты
А нет. Всё! Ух ты! Работает! Спасибо огромное!!!
Старый 17.08.2012, 14:21
Yandex
Объявления
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать новую тему

Похожие темы
Тема Автор
C# .NET При вызове метода из другого файла ошибка "The type initializer for 'Openxls' threw an exception"
Хелп плиз! Прога работала и вдруг перестала при вызове метода из другого файла пишет The type initializer for 'Openxls' threw an exception аргументы использую правильно коллекции нет в другом файле вот такой код (раньше отлично все работало using System;
broker25
Программирование 1С Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста (ПолучитьОбъект) лОбъект = ДокументПересчета.ПолучитьОбъект(); не пойму почему ошибка при вызове вот кодПроцедура КнопкаВыполнитьНажатие(Кнопка) лОбъект =...
temi4444
Программирование 1С Ошибка при вызове метода контекста (Выполнить)
у меня в ПФР не формирует отчеты а выдает такую ошибку {ОбщийМодуль.ПроцедурыПерсонифицированногоУчета.Модуль(9383)}: Ошибка при вызове метода контекста (Выполнить) ТаблицаСтажаПоДоговорам = Запрос.Выполнить().Выгрузить(); по причине: по причине: {(33, 46)}: Поле не найдено...
Веталина
Программирование 1С 1C 8.x Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи! есть 2 базы: Сервер и Удаленная база розница 8.2. Обмен данными через ftp ресурс, И вот когда выполняется...
k_a_t_y
C# под Web, ASP.NET При вызове метода sqlDataAdapter.Fill(dataSet, "T_Vhod_doc") происходит ошибка "Login failed for user"
Доброго времени суток! При вызове метода sqlDataAdapter.Fill(dataSet, "T_Vhod_doc") происходит ошибка "Login failed for user". Описание: An unhandled exception occurred during the execution of the current web request. В БД никакого логина и пароля нет. Помогите, плз...
Alexei_A
Опции темы

Текущее время: 03:57. Часовой пояс GMT +4.

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.7 PL3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.