Форум программистов, компьютерный форум CyberForum.ru Форум программистов | Компьютерный форум | Форум web-программистов | Форум по электронике и бытовой технике | Форум о софте | Научный форум | Карьера и бизнес
CyberForum.ru - форум программистов и сисадминов > >
Восстановить пароль Регистрация

Ответ Создать новую тему
 
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 280
17.08.2012, 10:46     Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
  #1
Что делать с этой ошибкой?

Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Ожидается выражение "("
АктКДоговоруТЧУслуги.Ссылка В <<?>>&СписокАктов
в процедуре:

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура ЗаполнитьНаСервере()
    
Запрос = Новый Запрос;
    Запрос.Текст =
("ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В &СписокАктов");
 
СписокАктов = Новый СписокЗначений();
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элементы.ТЧАктыАкты);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецПроцедуры
Кстати эта процедура заполнит ТЧУслуги из списка документов АктКДоговору, который находится в ТЧАкты?
AdAgent
Объявления
17.08.2012, 10:46
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 11:33
  #2
Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В (&СписокАктов)";
Наверное
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 280
17.08.2012, 11:59  [ТС]
  #3
Да, теперь нет ошибки )) Спасибо)

Добавлено через 16 минут
Ох нет. Теперь другая ошибка:
Код Code
1
2
3
4
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Неверные параметры
АктКДоговоруТЧУслуги.Ссылка <<?>>В (&СписокАктов)
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 12:24
  #4
Что такое список актов? Тип значения какой? Должен быть список значений состоящий из ссылок документов данного типа.
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 280
17.08.2012, 12:32  [ТС]
  #5
Цитата Сообщение от wade25 Посмотреть сообщение
Должен быть список значений состоящий из ссылок документов данного типа.
Ну СписокАктов и есть список значений.

А состоять из ссылок документов данного типа ... это
Код 1C
1
СписокЗначений.Добавить(Документы.АктКДоговору)
или как его заполнить заполнить списком документов?
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 13:38
  #6
Пробуй так

Код 1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
СписокАктов = Новый СписокЗначений;
Если Объект.ТЧАкты.Количество() > 0 Тогда
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элемент..ДОКУМЕНТАКТ.ССЫЛКА);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецЕсли;
 
КонецПроцедуры
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 280
17.08.2012, 13:47  [ТС]
  #7
А в этой строке
Код 1C
1
СписокАктов.Добавить(Элемент.ДОКУМЕНТАКТ.ССЫЛКА);
что значит ДОКУМЕНТАКТ?
Что бы я там не писала, всегда пишет - Поле объекта не обнаружено (ДОКУМЕНТАКТ).
wade25
Форумчанин
143 / 143 / 1
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 14:08
  #8
Смотри, Табличная часть состоит из колонок. В одной из колонок у тебя должны лежать документы (акты). "Элемент", это строка при обходе ТЧ, а к колонкам ты обращаешься через точку. Т.е. Элемент.ТУТ_НАЗВАНИЕ_КОЛОНКИ.
Titanum
Форумчанин
0 / 0 / 0
Регистрация: 25.10.2011
Сообщений: 280
17.08.2012, 14:21  [ТС]     Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("
  #9
Да, по идее так и делала. Реквизит табличной части ТЧАкты называется Акты.
Писала Элемент.Акты, но то же самое... Поле объекта не обнаружено (Акты) \(О_о)/

Добавлено через 2 минуты
А нет. Всё! Ух ты! Работает! Спасибо огромное!!!
Yandex
Объявления
17.08.2012, 14:21
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать новую тему

Похожие темы
Тема Раздел Автор Дата
1С Ошибка при вызове метода контекста (Выполнить)
у меня в ПФР не формирует отчеты а выдает такую ошибку {ОбщийМодуль.ПроцедурыПерсонифицированногоУчета.Модуль(9383)}: Ошибка при вызове метода контекста (Выполнить) ТаблицаСтажаПоДоговорам =...
1С: Типовые и стандартные решения Веталина 20.06.2014 01:48
1С 1C 8.x Работа с запросом и ошибка "Ошибка при вызове метода контекста (Выполнить)"
Подскажите почему вылезает ошибка {Форма.ФормаОтчета.Форма(52)}: Ошибка при вызове метода контекста (Выполнить) Результат = Запрос.Выполнить().Выбрать(); по причине: {(2, 2)}: Поле не входит в...
1С: Собственные программы Ermak27 10.02.2014 12:42
1С 1C 8.x Не удалось сформировать внешнюю печатную форму(толстую)! Ошибка при вызове метода контекста (Выполнить): {(14, 1)}: Синтаксическая ошибка "ИЗ" <<?>>ИЗ
Подскажите, пожалуйста. Выбрал для счета только услуги, написал: Шапка = Запрос.Выполнить().Выгрузить(); Шапка.Следующий(); СтрокаВыборкиПоляСожержания =...
1cprogrammist 04.12.2013 22:18
1С 1C 8.x Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: При выборе Формирование книги продаж - формирование записей книги продаж возникает ошибка при нажатии на выбрать(F4) в...
Vladimir_SA 04.04.2013 15:18
1С Ошибка при вызове метода контекста
есть ссылка "e79ba7ae-0747-11db-9244-0011955c22cb"... как присвоить ее новому элементу справочника Добавлено через 7 минут вот так не получается док = документы.РеализацияТоваровУслуг; ...
shum_ont 29.03.2013 01:04
C# Ошибка при вызове метода: "Does not contain a static 'Main' method"
Приветствую. Собственно, проблема заключается в следующем: при вызове метода отсюда*, компилятор ругается. Ошибка: Program '......exe' does not contain a static 'Main' method suitable for an entry...
C# для начинающих Sk_y 25.12.2012 22:58
1С Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове метода контекста (ПолучитьОбъект) лОбъект = ДокументПересчета.ПолучитьОбъект(); не пойму почему ошибка при...
temi4444 08.09.2011 09:32
C# ASP.NET При вызове метода sqlDataAdapter.Fill(dataSet, "T_Vhod_doc") происходит ошибка "Login failed for user"
Доброго времени суток! При вызове метода sqlDataAdapter.Fill(dataSet, "T_Vhod_doc") происходит ошибка "Login failed for user". Описание: An unhandled exception occurred during the execution of...
C# под Web, ASP.NET Alexei_A 05.10.2006 20:59
Опции темы

Текущее время: 13:08. Часовой пояс GMT +4.

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.7 PL3
Copyright ©2000 - 2014, vBulletin Solutions, Inc.