Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.54/50: Рейтинг темы: голосов - 50, средняя оценка - 4.54
Titanum
1 / 1 / 1
Регистрация: 25.10.2011
Сообщений: 360
1

Ошибка при вызове метода контекста (Выполнить) по причине: Ожидается выражение "("

17.08.2012, 10:46. Просмотров 9123. Ответов 8
Метки нет (Все метки)

Что делать с этой ошибкой?

Код
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Ожидается выражение "("
АктКДоговоруТЧУслуги.Ссылка В <<?>>&СписокАктов
в процедуре:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура ЗаполнитьНаСервере()
    
Запрос = Новый Запрос;
    Запрос.Текст =
("ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В &СписокАктов");
 
СписокАктов = Новый СписокЗначений();
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элементы.ТЧАктыАкты);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецПроцедуры
Кстати эта процедура заполнит ТЧУслуги из списка документов АктКДоговору, который находится в ТЧАкты?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.08.2012, 10:46
Ответы с готовыми решениями:

Не удалось сформировать внешнюю печатную форму(толстую)! Ошибка при вызове метода контекста (Выполнить): {(14, 1)}: Синтаксическая ошибка "ИЗ" <<?>>ИЗ
Подскажите, пожалуйста. Выбрал для счета только услуги, написал: Шапка =...

Ошибка при вызове метода контекста
есть ссылка &quot;e79ba7ae-0747-11db-9244-0011955c22cb&quot;... как присвоить ее новому...

Ошибка при вызове метода контекста
Задача сделать автоподбор. Но вот при выполнении выдает...

Ошибка при вызове метода контекста (ПолучитьОбъект)
Привет народ Программа ругается что: {Форма.Форма.Форма(7)}: Ошибка при вызове...

Ошибка при вызове метода контекста (ВыбратьИзСписка)
Люди срочно помогите что не так???? В программе не лазили возникла ошибка: ...

8
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 11:33 2
1C
1
2
3
4
5
6
7
8
9
10
11
12
Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|   АктКДоговоруТЧУслуги.Ссылка КАК Ссылка,
|   АктКДоговоруТЧУслуги.НомерСтроки,
|   АктКДоговоруТЧУслуги.Имя,
|   АктКДоговоруТЧУслуги.Код,
|   АктКДоговоруТЧУслуги.Цена
|ИЗ
|   Документ.АктКДоговору.ТЧУслуги КАК АктКДоговоруТЧУслуги
|ГДЕ
|   АктКДоговоруТЧУслуги.Ссылка В (&СписокАктов)";
Наверное
1
Titanum
1 / 1 / 1
Регистрация: 25.10.2011
Сообщений: 360
17.08.2012, 11:59  [ТС] 3
Да, теперь нет ошибки )) Спасибо)

Добавлено через 16 минут
Ох нет. Теперь другая ошибка:
Код
Ошибка при вызове метода контекста (Выполнить)
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
по причине: Неверные параметры
АктКДоговоруТЧУслуги.Ссылка <<?>>В (&СписокАктов)
0
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 12:24 4
Что такое список актов? Тип значения какой? Должен быть список значений состоящий из ссылок документов данного типа.
1
Titanum
1 / 1 / 1
Регистрация: 25.10.2011
Сообщений: 360
17.08.2012, 12:32  [ТС] 5
Цитата Сообщение от wade25 Посмотреть сообщение
Должен быть список значений состоящий из ссылок документов данного типа.
Ну СписокАктов и есть список значений.

А состоять из ссылок документов данного типа ... это
1C
1
СписокЗначений.Добавить(Документы.АктКДоговору)
или как его заполнить заполнить списком документов?
0
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 13:38 6
Пробуй так

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
СписокАктов = Новый СписокЗначений;
Если Объект.ТЧАкты.Количество() > 0 Тогда
Для каждого Элемент из Объект.ТЧАкты Цикл
    СписокАктов.Добавить(Элемент..ДОКУМЕНТАКТ.ССЫЛКА);
    
КонецЦикла;
 
Запрос.УстановитьПараметр("СписокАктов",СписокАктов);
 
Объект.ТЧУслуги.Загрузить(Запрос.Выполнить().Выгрузить());
 
КонецЕсли;
 
КонецПроцедуры
1
Titanum
1 / 1 / 1
Регистрация: 25.10.2011
Сообщений: 360
17.08.2012, 13:47  [ТС] 7
А в этой строке
1C
1
СписокАктов.Добавить(Элемент.ДОКУМЕНТАКТ.ССЫЛКА);
что значит ДОКУМЕНТАКТ?
Что бы я там не писала, всегда пишет - Поле объекта не обнаружено (ДОКУМЕНТАКТ).
0
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
17.08.2012, 14:08 8
Смотри, Табличная часть состоит из колонок. В одной из колонок у тебя должны лежать документы (акты). "Элемент", это строка при обходе ТЧ, а к колонкам ты обращаешься через точку. Т.е. Элемент.ТУТ_НАЗВАНИЕ_КОЛОНКИ.
1
Titanum
1 / 1 / 1
Регистрация: 25.10.2011
Сообщений: 360
17.08.2012, 14:21  [ТС] 9
Да, по идее так и делала. Реквизит табличной части ТЧАкты называется Акты.
Писала Элемент.Акты, но то же самое... Поле объекта не обнаружено (Акты) \(О_о)/

Добавлено через 2 минуты
А нет. Всё! Ух ты! Работает! Спасибо огромное!!!
0
17.08.2012, 14:21
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.08.2012, 14:21

Ошибка при чтении изменений при обмене РИБ: Ошибка при вызове метода контекста (ПрочитатьИзменения): Ошибка записи!
Доброго всем времени суток! подскажи пожалуйста как исправить ошибку: Ошибка...

Ошибка при вызове метода контекста (МоментВремени): Элемент не выбран
В УТ 8.2 скопировал печатную форму &quot;Сравнительная накладная &quot; из...

Ошибка разбора XML/ Ошибка при вызове метода контекста (Прочитать)
1C 8.2 Документооборот КОРП 1.2 Текст ошибки...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru