Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/7: Рейтинг темы: голосов - 7, средняя оценка - 4.71
НатНат
0 / 0 / 0
Регистрация: 13.12.2011
Сообщений: 19
1

Записать ТЧ обработки в ТЧ документа

22.09.2012, 15:23. Просмотров 1335. Ответов 2
Метки нет (Все метки)

Здравствуйте!
У меня вот тут есть обработка результатом которой является измененная табличная часть документа Отчет о розничых продажах. и мне нужно то что получилось записать обратно в табличную часть документа в измененном виде. у меня есть процедура записи:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Процедура Записать(ПроводитьДокумент) Экспорт
    
    ДокОб   =   ДокументСсылка.ПолучитьОбъект();
    
    //работа с таблицами документа
    
    Для каждого ТекРеквизита из ТЧТабЧасти Цикл
        ДокОб = ТЧТабЧасти.ВыгрузитьКолонки("Цена,КоличествоУпаковокФакт,СтавкаНДС");
    КонецЦикла;
      ДокОб.Записать(РежимЗаписиДокумента.Запись);
    //ИЗМЕНЕНИЕ ДОКУМЕНТА
    
    Если ПроводитьДокумент Тогда
        РежимПроведения=РежимЗаписиДокумента.Проведение;            
    Иначе
        РежимПроведения=РежимЗаписиДокумента.Запись;    
    КонецЕсли;
        
    Попытка
        ДокОб.Записать(РежимПроведения);
    Исключение
        Сообщить(""+ОписаниеОшибки());
    КонецПопытки;
    
КонецПроцедуры
Но он когда нажимаю на кнопку "записать" выдает ошибку "Метод объекта не обнаружен (Записать)". Помогите пожалуйста разобраться. Обработку могу выложить.

Добавлено через 2 часа 25 минут
Все получилось! записывает! Спасибо Всем за внимание.=)
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.09.2012, 15:23
Ответы с готовыми решениями:

Создание внешней обработки документа
Добрый день! Мне необходимо создать документ КС-2 в 1С:Бухгалтерия 8.2. ...

Процедура обработки проведения документа
Документ Оказание услуг при оперативном проведение нужно чтобы бролась цена на...

Обработки. Заполнение ТЧ по выбору документа
Доброго времени суток! Вопрос такой: как программно решить вопрос заполнения...

Вызов обработки и заполнение полученными данными документа
Доброго времени суток, ALL! Столкнулся с проблемой заполнения формы документа...

Не выбран элемент при записи реквизита справочника из обработки проведения документа
Требуется из обработки проведения документа внести изменения в справочник, ...

2
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
22.09.2012, 23:50 2
Кто тебе этот безумный код дал???

И что вот ЭТО?
1C
1
2
3
Для каждого ТекРеквизита из ТЧТабЧасти Цикл
        ДокОб = ТЧТабЧасти.ВыгрузитьКолонки("Цена,КоличествоУпаковокФакт,СтавкаНДС");
    КонецЦикла;
0
НатНат
0 / 0 / 0
Регистрация: 13.12.2011
Сообщений: 19
23.09.2012, 19:32  [ТС] 3
ээ.. а я как бы его сама придумала.))) а в этом цикле по идее, должно было выгрузиться три колонки.=)но оказалось все нааааамного проще.))и в решении мне кстати ваш форум помог. полазила тут по полезным ссылкам.))
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.09.2012, 19:32

Изменение Внешней обработки печати накладной Для документа Реализация товаров и услуг
Суть задачи такова. Есть документ - РеализацияТоваровУслуг. Есть внешняя...

Реквизиты из документа записать в справочник
Здравствуйте! Есть документ "Док" с реквизитами: Фамилия и Имя. Есть кнопка...

Создание документа, невозможность записать
Доброго всем. Бухгалтерия 8.2 Проф.(2.0.44.7) Создали внешнюю обработку для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru