Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/7: Рейтинг темы: голосов - 7, средняя оценка - 4.86
mikle13
0 / 0 / 0
Регистрация: 06.10.2012
Сообщений: 8
1

Отчет ОСВ по счету

06.10.2012, 14:54. Просмотров 1318. Ответов 4
Метки нет (Все метки)

Добрий день! Мне нужно в 1с 7.7 Бухг. учет для Украини в отчете ОСВ по счету показать только групи контрагентов? можно ли так зделать, помогите пожалуста
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.10.2012, 14:54
Ответы с готовыми решениями:

Отчет переработать (в ОСВ поле регистратора)
Доброго времени суток всем. Так как я только начинаю осваивать 1с8 в плане...

ошибка бюджетных класификаторов КОССГУ 212 по счету 0 401 01 не соотвецтвует корреспондирующему счету
Увожаемые праграмисты пажалуйсто памагите с программой 1с.Я совсем неразбираюсь...

Отчёт ОСВ
Здравствуйте. Дело в том что я в конфигураторе пытаюсь сформировать отчет....

ОСВ по счёту
Добрый день! Подскажите, пожалуйста, где при формировании оборотки...

Проблемы с выводом отчета ОСВ
Ребята подскажите пожалуйста. Формирую ОСВ, периоды выставлены верно, а вместо...

4
sonatto
62 / 60 / 0
Регистрация: 02.10.2012
Сообщений: 448
07.10.2012, 00:12 2
Цитата Сообщение от mikle13 Посмотреть сообщение
учет для Украини в отчете ОСВ по счету
If у вас нутро ОСВ по счету тако ж само как у России, тогда просто. если можеш читать текст модуля на русском языке = пришлю, если не можеш - опубликуй текст модуля на украиньской мови)) зроблю

Добавлено через 4 часа 46 минут
Процедура ПоСубконто(Ит, Т, ФлВал)

ПолучитьУровниГруппировокДляРасчетаСальдо(Ит);

Если ОтборСубконто[1] = 1 Тогда // разворачивать
Ит.ВыбратьСубконто();
Пока Ит.ПолучитьСубконто() = 1 Цикл
Если ИтогиНеРавныНулю(Ит, 1) = 0 Тогда
Продолжить;
КонецЕсли;

ВыборкаИтоговПоГруппеСправочника[1] = Ит.ЭтоГруппа();
ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 1, СумСальдо, 1);

Расшифровка.Установить("ОтборСубконто"+Номер[1], 2);
Расшифровка.Установить("Субконто"+Номер[1], Ит.Субконто());
//Т.ВывестиСекцию("Секция_2");//вот так было
Если ПустоеЗначение(Ит.Субконто()) = 0 Тогда//начало добавлено
Если Ит.Субконто().ЭтоГруппа() = 1 Тогда
Т.ВывестиСекцию("Секция_2");
КонецЕсли;
КонецЕсли;//конец добавлено

...
КонецПроцедуры
1
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
07.10.2012, 00:17 3
Цитата Сообщение от sonatto Посмотреть сообщение
Если Ит.Субконто().ЭтоГруппа() = 1 Тогда
А если субконто не справочник?
0
sonatto
62 / 60 / 0
Регистрация: 02.10.2012
Сообщений: 448
07.10.2012, 17:44 4
Цитата Сообщение от Fenomen Посмотреть сообщение
А если субконто не справочник?
проверял по сч 60, пусть попробуют, не понравится - пусть уточнят задачу, а порядке пожарной помощи пойдет
или так
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
Процедура ПоСубконто(Ит, Т, ФлВал)
    
    ПолучитьУровниГруппировокДляРасчетаСальдо(Ит);
    
    Если ОтборСубконто[1] = 1 Тогда // разворачивать
        Ит.ВыбратьСубконто();
        Пока Ит.ПолучитьСубконто() = 1 Цикл
            Если ИтогиНеРавныНулю(Ит, 1) = 0 Тогда
                Продолжить;
            КонецЕсли;
            
            ВыборкаИтоговПоГруппеСправочника[1] = Ит.ЭтоГруппа();
            ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 1, СумСальдо, 1);
            
            Расшифровка.Установить("ОтборСубконто"+Номер[1], 2);
            Расшифровка.Установить("Субконто"+Номер[1], Ит.Субконто());
            //Т.ВывестиСекцию("Секция_2"); Было так
            ВывестиСекциюСекция_2 = 1;  //Начало добавления
            Если ТипЗначенияСтр(Ит.Субконто()) = "Справочник" Тогда
                Если Ит.Субконто().Вид() = "Контрагенты" Тогда
                    Если ПустоеЗначение(Ит.Субконто()) = 0 Тогда
                        Если (Ит.Субконто().ЭтоГруппа() = 0) И (ПоГруппам1 = 1) Тогда
                            
                            ВывестиСекциюСекция_2 = 0;
                            
                            
                        КонецЕсли;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
            Если ВывестиСекциюСекция_2 = 1 Тогда
                Т.ВывестиСекцию("Секция_2");
            КонецЕсли; //Конец добавления
            
 
            Если Ит.Счет.Количественный = 1 Тогда
                ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 1, КолСальдо, 3);
                Т.ВывестиСекцию("Секция_3");
            КонецЕсли;
            Если ФлВал = 1 Тогда
                Ит.ВыбратьВалюты();
                Пока Ит.ПолучитьВалюту()=1 Цикл
                    Расшифровка.Установить("Валюта",Ит.Валюта);
                    Расшифровка.Установить("ПоВалюте",1);
                    Т.ВывестиСекцию("Секция_4");
                КонецЦикла;
                Расшифровка.Установить("Валюта");
                Расшифровка.Установить("ПоВалюте");
            КонецЕсли;
 
            Если ОтборСубконто[2] = 1 Тогда // разворачивать
                Ит.ВыбратьСубконто(2);
                Пока Ит.ПолучитьСубконто(2) = 1 Цикл
                    Если ИтогиНеРавныНулю(Ит, 2) = 0 Тогда
                        Продолжить;
                    КонецЕсли;
                    
                    ВыборкаИтоговПоГруппеСправочника[2] = Макс(Ит.ЭтоГруппа(), ВыборкаИтоговПоГруппеСправочника[1]);
                    ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 2, СумСальдо, 1);
                    
                    Расшифровка.Установить("ОтборСубконто"+Номер[2], 2);
                    Расшифровка.Установить("Субконто"+Номер[2], Ит.Субконто(2));
                    Т.ВывестиСекцию("Секция_5");
                    Если Ит.Счет.Количественный = 1 Тогда
                        ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 2, КолСальдо, 3);
                        Т.ВывестиСекцию("Секция_6");
                    КонецЕсли;
                    Если ФлВал = 1 Тогда
                        Ит.ВыбратьВалюты(,,1);
                        Пока Ит.ПолучитьВалюту(1)=1 Цикл
                            Расшифровка.Установить("Валюта",Ит.Валюта);
                            Расшифровка.Установить("ПоВалюте",1);
                            Т.ВывестиСекцию("Секция_7");
                        КонецЦикла;
                        Расшифровка.Установить("Валюта");
                        Расшифровка.Установить("ПоВалюте");
                    КонецЕсли;
 
                    Если ОтборСубконто[3] = 1 Тогда // разворачивать
                        Ит.ВыбратьСубконто(3);
                        Пока Ит.ПолучитьСубконто(3) = 1 Цикл
                            Если ИтогиНеРавныНулю(Ит, 3) = 0 Тогда
                                Продолжить;
                            КонецЕсли;
                            
                            ВыборкаИтоговПоГруппеСправочника[3] = Макс(Ит.ЭтоГруппа(), ВыборкаИтоговПоГруппеСправочника[2]);
                            ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 3, СумСальдо, 1);
                
                            Расшифровка.Установить("ОтборСубконто"+Номер[3], 2);
                            Расшифровка.Установить("Субконто"+Номер[3], Ит.Субконто(3));
                            Т.ВывестиСекцию("Секция_9");
                            Если Ит.Счет.Количественный = 1 Тогда
                                ДобавитьИтогиПоСубконтоКРазвернутомуСальдо(Ит, 3, КолСальдо, 3);
                                Т.ВывестиСекцию("Секция_10");
                            КонецЕсли;
                            Если ФлВал = 1 Тогда
                                Ит.ВыбратьВалюты(,,2);
                                Пока Ит.ПолучитьВалюту(2)=1 Цикл
                                    Расшифровка.Установить("Валюта",Ит.Валюта);
                                    Расшифровка.Установить("ПоВалюте",1);
                                    Т.ВывестиСекцию("Секция_11");
                                КонецЦикла;
                                Расшифровка.Установить("Валюта");
                                Расшифровка.Установить("ПоВалюте");
                            КонецЕсли;
                        КонецЦикла;
                        Расшифровка.Установить("Субконто"+Номер[3]);
                        Расшифровка.Установить("ОтборСубконто"+Номер[3]);
                    КонецЕсли;
                КонецЦикла;
                Расшифровка.Установить("Субконто"+Номер[2]);
                Расшифровка.Установить("ОтборСубконто"+Номер[2]);
            КонецЕсли;
        КонецЦикла;
        Расшифровка.Установить("Субконто"+Номер[1]);
        Расшифровка.Установить("ОтборСубконто"+Номер[1]);
    КонецЕсли;
КонецПроцедуры
Добавлено через 16 часов 8 минут
Цитата Сообщение от mikle13 Посмотреть сообщение
Добрий день! Мне нужно в 1с 7
ну как, помогло - нет?
1
mikle13
0 / 0 / 0
Регистрация: 06.10.2012
Сообщений: 8
07.10.2012, 22:51  [ТС] 5
да помогло!
0
07.10.2012, 22:51
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.10.2012, 22:51

Переделать типовую ОСВ по счёту
Доброго времени суток господа программисты ! Вопрос такой: как переделать...

Отчет РАУЗ переделать в отчет с партионным учетом
Возможно ли типовой отчет построенный на РАУЗ переделать так, чтобы он работал...

Обороты по счету 77
Здравствуйте. Цель задачи сделать обработку для вывода оборотов по счету 77. ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru