Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
delete1991
2 / 2 / 0
Регистрация: 05.02.2011
Сообщений: 82
1

Реализация приходной и склада

21.11.2012, 01:51. Просмотров 711. Ответов 1
Метки нет (Все метки)

есть такая проблемка. Есть документ приходная которая будет фиксировать весь товар, который поступает на склад магазина. (может быть несколько магазинов) Есть документ чек, в который выдает все список товаров что купил покупатель. Ну например приходная зафиксировала прием товара Водки в количестве 10 штук. Все это провелось в регистр накопления Склад. В документе чек мы выбрали товар водка в количестве 5 штук. Товар продан т.к такое количество есть на складе. Нужно вычесть проданное количество с склада и там сохранить новое количество этого товара. Как это сделать?

эта процедура в документе чек. Производится подсчет общего количества опредленного товара в опредленном магазине в переменную КОЛ.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Процедура Склад() 
    рег=РегистрыНакопления.Склад.Выбрать();
    
    стр=ЭлементыФормы.Товары.ТекущиеДанные;
    кол=0;
    Пока рег.Следующий() Цикл
        Если Магазин=рег.Магазин Тогда
            Если стр.Товары=рег.Товары Тогда
                //Если стр.Количество>рег.Количество Тогда
                //  Сообщить("На складе нет такого количества товара. Осталось: "+рег.Количество+"шт");
                //КонецЕсли;
            кол=кол+рег.Количество;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    рег1=РегистрыНакопления.Склад.Выбрать();
    Пока рег1.Следующий() Цикл
        Если Магазин=рег1.Магазин Тогда
            Если стр.Товары=рег1.Товары Тогда
                Если стр.Количество>кол Тогда
                    Сообщить("На складе нет такого количества товара. Осталось: "+кол+"шт");
                    Прервать;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
как теперь вычесть в регистре накопления это проданное количество товара?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.11.2012, 01:51
Ответы с готовыми решениями:

Реализация мини-склада
Доброго дня всем! Я только начал изучать 1С и решил реализовать простейшую конфу "Мини-склад". Но,...

"Реализация товаров и услуг" со склада. Не меняется остаток.
Здравствуйте. Дело в том, что я провожу документ "Реализация товаров и услуг" в режиме "Со склада",...

Приходной кассовый ордер
всем привет.помогите решить проблему.заключается в следующем:при распечатки ордера растояние между...

Цена из Приходной накладной в справочник номенклатура
Помогите сделать! Есть чистая Торговля 9.50. Нужно чтобы при вводе Приходной накладной цены...

Как получить доступ к элементу на форме приходной накладной
Собственно сабж. тобиш я создаю новый документ - приходную накладную и в ней нужно поменять тип...

1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
21.11.2012, 08:50 2
Регистр накопления - это объект, про который Вам надо просто почитать. Со с самого со с начала.
Приведённый текст больше нигде не публикуйте.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.11.2012, 08:50

Оптимизация работы склада
Задача такая у организации есть склад нужно оптимизировать набор товаров. Один товар может лежать...

Загрузка приходной накладной из Excel
1С - 8.2 - Управляемые формы Пытаюсь реализовать заливку приходной накладной из Excel, по сути...

Не делает перемещение со склада
Конфа: Рарус общепит ред 6, на платформе 7.7. При перемещении заготовки (полуфабриката) в документе...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru