Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
forestrg
4 / 4 / 0
Регистрация: 10.11.2012
Сообщений: 52
1

Перебор элементов в спр

07.12.2012, 12:20. Просмотров 838. Ответов 1
Метки нет (Все метки)

не пойму почему стопорится
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
Процедура Залито()
    Залито=0;
    спрГСМ=СоздатьОбъект("Справочник.я_ГСМ");
    спрГСМ.ВыбратьЭлементы();
    Пока спрГСМ.ПолучитьЭлемент() = 1 Цикл
        Если спрГСМ.НайтиПоНаименованию(СокрЛП(тягач.ТопКарт.получить(ДатаПЛ))) =1 Тогда
        //  Если (спрГСМ.НР>=Дат) и (спрГСМ.КР<=Дат1) Тогда
                Кол=спрГСМ.ТекущийЭлемент().Кол;
        //  КонецЕсли; 
        КонецЕсли;
    Залито=Залито+Кол;
    
    конеццикла;
Форма.Обновить(0);  
КонецПроцедуры
есть Справочник.я_ГСМ там 4 записи, 3 где спрГСМ.НайтиПоНаименованию(СокрЛП(тягач.ТопКарт.получить(ДатаПЛ))) =1 и одна отличная, процедура возвращяет 1 попавшееся значение и стопорится
1C
1
2
Пока спрГСМ.ПолучитьЭлемент() = 1 Цикл
{Справочник.я_ПЛ.Форма.Модуль(308)}: Не выбран элемент!
Добавлено через 29 минут
сделал через ТЗ, но все равно интересно почему выдавало ошибку
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Процедура Залито()
    ТзЗаявки=СоздатьОбъект("ТаблицаЗначений");
    ТзЗаявки.НоваяКолонка("НомерКарты");
    ТзЗаявки.НоваяКолонка("НР");
    ТзЗаявки.НоваяКолонка("Кол");
    
    Залито=0;
    спрГСМ=СоздатьОбъект("Справочник.я_ГСМ");
    спрГСМ.ВыбратьЭлементы();
    Пока спрГСМ.ПолучитьЭлемент() = 1 Цикл
        ТзЗаявки.НоваяСтрока(); 
        ТзЗаявки.НомерКарты=спрГСМ.ТопКарт;
        ТзЗаявки.НР=спрГСМ.НР;
        ТзЗаявки.Кол=спрГСМ.Кол;
    конеццикла; 
    ТзЗаявки.Выбратьстроки();
    Пока ТзЗаявки.Получитьстроку()=1 цикл
        Если (СокрЛП(ТзЗаявки.НомерКарты))=(СокрЛП(тягач.ТопКарт.получить(ДатаПЛ))) Тогда       //тягач.ТопКарт.получить(ДатаПЛ))    и (ТзЗаявки.НР<=Дат1)
            Если (ТзЗаявки.НР>=Дат)  и (ТзЗаявки.НР<=Дат1) Тогда
                Кол=ТзЗаявки.Кол;
                Залито=Залито+Кол;
            КонецЕсли; 
        КонецЕсли;
        
    конеццикла;
    Форма.Обновить(0);  
КонецПроцедуры
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.12.2012, 12:20
Ответы с готовыми решениями:

Загрузка и парсинг в СПР
подскажите пожалуйста где можно прочитать про парсинг данных... нужно из файла имеющего вот такой...

За Двоился Спр.единица Изм.
В номенклатура при выборе ЕХО дает на выбор 2-ед. из них правильная одна(открываю в спр.ном....

Как назначить тип спр-ку в 8-ке
Объект в конфигурации - справочник типа &quot;СправочникСсылка&quot;. Проблемы 2 * Как назначить...

Система нумерации кодировки в спр. Номенклатура
Есть задача перенести БД состава изделия из старой Dos системы в 1С: Предприяти 7.7...

Можно ли настроить свое представление спр-ка?
Конфигуратор предлагает свойство &quot;Основное представление&quot; из 2 вариантов: Код, Наименование. А мне...

1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
07.12.2012, 16:45 2
Цитата Сообщение от forestrg Посмотреть сообщение
Пока спрГСМ.ПолучитьЭлемент() = 1 Цикл Если спрГСМ.НайтиПоНаименованию(СокрЛП(тягач.ТопКарт.получить(ДатаПЛ))) =1 Тогда
Нельзя перепозиционирование
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.12.2012, 16:45

Значения табличной части Спр. через запятую
Привет Всем Подскажите пож. как дальше продолжить (1C 8.1): ТЗ = Новый ТаблицаЗначений;...

Перебор элементов динамического списка
Добрый день. Как можно перебрать все элементы динамического списка &quot;Список&quot; из справочника...

Перебор нижестоящих элементов в иерархическом справочнике
Необходимо в цикле перебрать все элементы иерархического справочника, нижестоящие по отношение к...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.