Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.51/41: Рейтинг темы: голосов - 41, средняя оценка - 4.51
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
1

Управляемые формы 1с

07.12.2012, 17:18. Просмотров 8271. Ответов 11
Метки нет (Все метки)

как перебрать строки в таблице на управляемой форме и сделать невидимыми некоторые из них?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.12.2012, 17:18
Ответы с готовыми решениями:

Управляемые формы
Начал немного усваивать 1С, вопрос к профи. Есть "управляемые формы", все формы называются...

Автозаполнение табличной части, управляемые формы
Есть справочник Клиенты(реквизиты Наименование, Код) и документ Работа, с табличной частью...

Управляемые формы. Вызов процедуры общего модуля.
Код ( (Unknown Language)): &НаСервереБезКонтекста Процедура ВычислитьСебестоимостьНаСервере()...

Перебор значений динамического списка (1с 8.2, управляемые формы)
Добрый день всем. Столкнулся с проблемой. В общем задача: Есть два Excel документа. один...

Вызвать форму редактирования списка (8.2 не управляемые формы)
Доброго времени суток! Я тут думаю как реализовать: есть кнопка, по нажатию на нее открывается...

11
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
07.12.2012, 17:57 2
Цитата Сообщение от Pupsa Посмотреть сообщение
как перебрать строки в таблице на управляемой форме и сделать невидимыми некоторые из них?
Пожалуйста, уточните, для чего вам надо перебирать строки, и что вы понимаете под "сделать невидимыми некоторые из них"?
0
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
07.12.2012, 18:00  [ТС] 3
нужно в цикле проверить строки табличной части и скрыть некоторые из них в зависимости от одного из реквизитов документа
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
07.12.2012, 18:09 4
Это можно сделать в режиме 1С:Предприятие.
Все действия - Настроить список...
А там задавайте условия отбора, какие вам надо.
Или вам надо, чтобы форма выводила нужные строки сразу, после открытия формы?
Забыл уточнить: это работает в форме списка.
0
07.12.2012, 18:09
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
07.12.2012, 18:13  [ТС] 5
Цитата Сообщение от fjay69 Посмотреть сообщение
Или вам надо, чтобы форма выводила нужные строки сразу, после открытия формы?
да, нужно программно
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
07.12.2012, 18:48 6
Не самое рациональное решение, но думаю, натолкнёт вас на вариант получше:
Создаёте пользовательскую форму документа и создаёте обработчик для события ПриОткрытии:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Количество", 80);//Прописываете имена столбцов, по которым 
    //нужно сделать отбор, и пишем параметр отбора
    НайденныеСтроки = Объект.Товары.НайтиСтроки(ПараметрыОтбора);
    Объект.Товары.Очистить();//убираем все строки из табличной части
    Для Каждого СтрокаТаблицы Из НайденныеСтроки Цикл//перебираем строки в результате
        НоваяСтрока=Объект.Товары.Добавить();//добавляем пустую строку в табличную часть
        НоваяСтрока.Количество=СтрокаТаблицы["Количество"];//и заполняем по столбцам
        НоваяСтрока.Номенклатура=СтрокаТаблицы["Номенклатура"];
        //и т.д.    
    КонецЦикла;
КонецПроцедуры
0
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
07.12.2012, 19:01  [ТС] 7
Цитата Сообщение от fjay69 Посмотреть сообщение
Не самое рациональное решение, но думаю, натолкнёт вас на вариант получше:
Создаёте пользовательскую форму документа и создаёте обработчик для события ПриОткрытии:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПараметрыОтбора = Новый Структура;
    ПараметрыОтбора.Вставить("Количество", 80);//Прописываете имена столбцов, по которым 
    //нужно сделать отбор, и пишем параметр отбора
    НайденныеСтроки = Объект.Товары.НайтиСтроки(ПараметрыОтбора);
    Объект.Товары.Очистить();//убираем все строки из табличной части
    Для Каждого СтрокаТаблицы Из НайденныеСтроки Цикл//перебираем строки в результате
        НоваяСтрока=Объект.Товары.Добавить();//добавляем пустую строку в табличную часть
        НоваяСтрока.Количество=СтрокаТаблицы["Количество"];//и заполняем по столбцам
        НоваяСтрока.Номенклатура=СтрокаТаблицы["Номенклатура"];
        //и т.д.    
    КонецЦикла;
КонецПроцедуры
Это конечно вариант, но при этом строки удалятся совсем
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
07.12.2012, 19:29 8
А как бы вы хотели, чтобы они восстанавливались?
0
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
07.12.2012, 19:32  [ТС] 9
Цитата Сообщение от fjay69 Посмотреть сообщение
А как бы вы хотели, чтобы они восстанавливались?
да, если это возможно, но что-то я уже сомневаюсь
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
07.12.2012, 20:08 10
Я сам только начинаю осваивать 1С. Моего текущего опыта хватило бы только на то, чтобы создать копию таблицы, которая вставлялась бы в форму по нажатии волшебной кнопочки.
Хм... Странно, что больше никто не отписался в теме...
0
Pupsa
4 / 4 / 1
Регистрация: 02.03.2012
Сообщений: 112
08.12.2012, 19:15  [ТС] 11
Цитата Сообщение от fjay69 Посмотреть сообщение
Я сам только начинаю осваивать 1С. Моего текущего опыта хватило бы только на то, чтобы создать копию таблицы, которая вставлялась бы в форму по нажатии волшебной кнопочки.
Хм... Странно, что больше никто не отписался в теме...
была такая мысль, но в моем случае удобней и проще будет переделать интерфейс все-таки
0
Dethmontt
Модератор
Эксперт 1С
2701 / 2465 / 432
Регистрация: 10.03.2011
Сообщений: 8,934
Записей в блоге: 1
Завершенные тесты: 1
10.12.2012, 01:02 12
Вариант№ 1 (если это табличная часть на форме)
1C
1
2
3
4
5
    СтруктураОтбора = Новый Структура;
    СтруктураОтбора.Вставить("ИмяКолонки","ЗначениеКолонки");
    ФиксСтруктура = Новый ФиксированнаяСтруктура(СтруктураОтбора);
    
    Элементы.ИмяТабличнойЧасти.ОтборСтрок = ФиксСтруктура;
Добавлено через 5 минут
Вариант 2 через стандартный ОТБОР - читайте СП
0
10.12.2012, 01:02
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2012, 01:02

стиль интерфейса 8.2 (вместо квадратного - округленный) не управляемые формы
Доброго времени суток, форумчане) подскажите, вот есть у нас кнопка (элемент управления) - она...

Заполнить данными запроса табличную часть (управляемые формы)
Доброго времени суток! Имеется форма Есть регистр Суть вопроса: Нужно при нажатии...

Дайте кто нибудь ссылку на видео Павел Чистов(управляемые формы)
Дайте кто нибудь ссылку на видео Павел Чистов(управляемые формы)


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.