Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/9: Рейтинг темы: голосов - 9, средняя оценка - 4.67
kuz93
0 / 0 / 0
Регистрация: 25.12.2010
Сообщений: 10
1

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".

08.12.2012, 15:36. Просмотров 1713. Ответов 5
Метки нет (Все метки)

МОЙ ВОЗРАСТ. Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".

Сообщить("Введите возраст:"+a); ВвестиЧисло(а);
Сообщить("Мне "+ а);
если 10>Цел(а/100)<20 тогда Сообщить("лет"+a)
КонецЕсли;
ИначеЕсли Цел(а/10) = 1 тогда Сообщить("год"+a)
КонецЕсли;
ИначеЕсли 2> Цел(а/10)<4 тогда Сообщить("года"+a)
иначе Сообщить("лет"+a);
КонецЕсли;


КонецПроцедуры




помогите исправить код[/QUOTE]
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.12.2012, 15:36
Ответы с готовыми решениями:

Вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет"
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст человека,вывести фразу вида: &quot;Мне...

1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура"
Всем добрый день! Нужна помощь. В Форму элемента &quot;Номенклатура&quot; нужно добавить два поля с выводом...

Кто может поделиться конфигурацией и базой для "общепита" или "ресторана", хочу потестить
Кто может поделиться конфигурацией и базой для 1с предприятие общепит или ресторан, хочу потестить.

Cоздать ссылку на реквизит "Наименование" справочника "Специалисты" из справочника "ЗаявкаНаОбучениеКлиентов"
Пожалуйста, подскажите. Необходимо создать ссылку на реквизит &quot;Наименование&quot; справочника...

DVD-диском от книги "Профессиональная разработка в системе "1С: Предприятие 8" в двух томах"
Добрый день, товарищи! Есть такая книга: У кого есть от нее DVD? Поделитесь, пожалуйста, если у...

5
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
08.12.2012, 18:50 2
А в чем проблема то?
0
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
08.12.2012, 19:56 3
Проблема в том, что надо применять не Цел(Возраст/10), а Возраст%10. Вот исправленный код:
1C
1
2
3
4
5
6
7
8
9
10
11
12
Процедура МойВозраст(Команда)
    Возраст=0;
    Сообщить("Введите возраст:");
    ВвестиЧисло(Возраст);
    Если Возраст%100<10 ИЛИ Возраст%100>20 Тогда
        Если Возраст%10 = 1 Тогда Сообщить("Мне "+ Возраст +" год")
        ИначеЕсли Возраст%10<5 И Возраст%10>1 Тогда Сообщить("Мне "+ Возраст +" года")          
        Иначе Сообщить("Мне "+ Возраст + " лет");   
        КонецЕсли;
    Иначе Сообщить("Мне "+ Возраст + " лет");   
    КонецЕсли;
КонецПроцедуры
1
Dethmontt
Модератор
Эксперт 1С
2686 / 2466 / 429
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
10.12.2012, 00:48 4
1C
1
2
3
Возраст = 15;   
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
Сообщить(А);
1
fjay69
89 / 89 / 17
Регистрация: 26.10.2012
Сообщений: 248
10.12.2012, 18:01 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
1C
1
2
3
Возраст = 15;   
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
Сообщить(А);
Оно выдаёт выражение вида "пятнадцать лет". А если нужно число цифрами, но чтобы предмет исчисления также склонялся (год, года, лет,...)?
0
Dethmontt
Модератор
Эксперт 1С
2686 / 2466 / 429
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
10.12.2012, 18:03 6
1C
1
2
3
4
5
Возраст = 15;   
А = ЧислоПрописью(Возраст,"Л=ru_RU","Год,Года,Лет,м,Год,Года,Лет,м,0");
А = Прав(А,4);
А = СтрЗаменить(А," ","");
Сообщить("Мне "+Возраст+" "+А);
0
10.12.2012, 18:03
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2012, 18:03

УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!
Добрый день. Появилась необходимость сделать для Заявки на расходование денежных средств...

Не получается скопировать выделенные строчки из справочника "Сотрудники" в форму "Выбор"
Здравствуйте! У меня опыта работы с 1С мало поэтому хотел попросить помощи у более опытных коллег....

В чем основное отличие "управление холдингом " и "документооборот Корп"?
Всем добрый день. в чем основное отличие &quot;управлнеие холдингом &quot; и &quot;документооборот Корп&quot;?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru