Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
KatrinIT092
0 / 0 / 0
Регистрация: 14.10.2012
Сообщений: 10
#1

Создание документа

26.12.2012, 13:50. Просмотров 515. Ответов 3
Метки нет (Все метки)

Создать документ, при проведении которого клиенту должен создаваться новый вклад заданного типа.

Прописала код на 1С версии 7.7:

Процедура ПриОткрытии()
ПриЗаписиПерепроводить(1);
КонецПроцедуры

Процедура Запись()
СпрКлиенты=СоздатьОбъект("Справочник.Вклады");
СпрКлиенты.Новый();
Если СтрДлина(СокрЛП(Клиент))<>0 тогда
СпрКлиенты.Клиент=Клиент;
иначе
Сообщить("Пожалуйста, укажите фамилию клиента!");
КонецЕсли;

Если стрДлина(СокрЛП(ТипВклада))<>0 тогда
СпрКлиенты.ВидВклада=ТипВклада;
иначе
Сообщить("Пожалуйста, укажите тип вклада!");
КонецЕсли;

Если стрДлина(СокрЛП(РазмерВклада))<>0 тогда
СпрКлиенты.РазмерВклада=РазмерВклада;
иначе
Сообщить("Пожалуйста, укажите размер вклада!");
КонецЕсли;
СпрКлиенты.Записать();
КонецПроцедуры

Как сделать, чтобы в справочник записывал не одного клиента, на котором курсор, а всех перечисленных?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.12.2012, 13:50
Ответы с готовыми решениями:

создание документа
Подскажите, пожалуйста, подробно как создать документ, чтобы в нем отображались...

Создание документа
надо написать скрипт , для автоматического выставления счетов, язык 1с вижу...

Создание документа
Подскажите пож-та нужно создать програмно документ (реализация) в табличной...

Создание документа
Подскажите, как создать документ &quot;Реализация&quot; програмно. С указанием вида...

Создание нового документа
Подскажите,пожалуйста Док 2 создается на основании Док 1 Запрос = Новый...

3
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
26.12.2012, 13:59 #2
Цитата Сообщение от KatrinIT092 Посмотреть сообщение
записывал не одного клиента, на котором курсор, а всех перечисленных?
Что это значит? У Вас в документе табличная часть с клиентами?
0
KatrinIT092
0 / 0 / 0
Регистрация: 14.10.2012
Сообщений: 10
26.12.2012, 19:29  [ТС] #3
Цитата Сообщение от Fenomen Посмотреть сообщение
Что это значит? У Вас в документе табличная часть с клиентами?
Да, в документе есть таблица, заполненые строки должны переходить в справичник, у меня переходит только строка, на которой курсор. Надо вставить цикл, а куда и как я не знаю, куда только не пробовала, не получается:-(
0
Xomych
576 / 519 / 66
Регистрация: 01.11.2012
Сообщений: 1,841
26.12.2012, 20:02 #4
В Модуле Документа в Процедуре ОбработкаПроедения()

1C
1
2
3
4
5
6
7
СпрКлиенты=СоздатьОбъект("Справочник.Вклады");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 цикл
 
            //Тут ваша программа записи вклада
 
КонецЦикла;
Но надо учесть, если вы распроведете документ, то нужно удалить вклад, иначе при перепроведении документа у вас создастся ещё один. Или при проведении проверять есть ли уже по этому документу вклад. Иначе будут грабли.
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.12.2012, 20:02

Программное создание документа
Доброго времени суток! Господа, подскажите, как при программном создании...

Создание документа на основании
Делаю такую штуку - есть документ1, на его основании должен получится...

Создание документа, невозможность записать
Доброго всем. Бухгалтерия 8.2 Проф.(2.0.44.7) Создали внешнюю обработку для...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru